Jump to content

somethingx

Members
  • Content Count

    32
  • Joined

  • Last visited

Community Reputation

0 Neutral

About somethingx

  • Rank
    New Here
  1. somethingx

    Rails

    What I did is uninstall Rails package and install it using gems. That was before I read this reply. Which way is better?
  2. somethingx

    Rails

    I installed Mandriva 2007 and now when I try to run rails I get this error: /usr/lib/ruby/site_ruby/1.8/rubygems.rb:251:in `report_activate_error': RubyGem version error: activerecord(1.14.3 not = 1.14.4) (Gem::LoadError) from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:188:in `activate' from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:214:in `activate' from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:213:in `each' from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:213:in `activate' from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:66:in `active_gem_with_options' from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:59:in `require_gem' from /usr/bin/rails:17 The official RPM is ruby-activerecord-1.14.3-2mdv2007.0 , but this is obviously the wrong version.
  3. I also think a clean install would be best, but I'm a bit worried that /home might get deleted during install, eventhough it's in a separate partition. Anyway, this is not a very good time for an upgrade, since Mandriva 2007 will be available in just a few months. Why is it so difficult to unisinstall RPMs? When I was trying to install all those packages that are required by libgtkhtml2, I installed libfreetype6. Now I want to uninstall it, but in order to do that I must uninstall a lot of packages that had been there for a long time before. If those packages require libfreetype6, how did they manage to function properly when libfreetype6 wasn't installed?
  4. I knew this day would come evetually. Those dreaded dependencies ! Do you think I should upgrade anyway, even if I decide not to install libgtkhtml2 ?
  5. Since urpmi refuses to install, I have to use rpm. I've downloaded the required RPMs and did: rpm -Uvh libgtkhtml2_0-devel-2.6.2-1mdk.i586.rpm libgail17-devel-1.6.6-1mdk.i586.rpm libgnome-vfs2_0-devel-2.6.2-7mdk.i586.rpm libgnomecanvas2_0-devel-2.6.1.1-1mdk.i586.rpm libgnome-vfs2_0-2.6.2-7mdk.i586.rpm libbonobo2_0-devel-2.6.2-2mdk.i586.rpm libgtk+2.0_0-devel-2.4.9-9mdk.i586.rpm libxml2-devel-2.6.13-1mdk.i586.rpm libgtk+2.0_0-2.4.9-9mdk.i586.rpm libgtk+-x11-2.0_0-2.4.9-9mdk.i586.rpm libgdk_pixbuf2.0_0-devel-2.4.9-9mdk.i586.rpm libpango1.0_0-devel-1.4.1-1mdk.i586.rpm zlib1-devel-1.2.1.1-3mdk.i586.rpm libgdk_pixbuf2.0_0-2.4.9-9mdk.i586.rpm zlib1-1.2.1.1-3mdk.i586.rpm libgnome-vfs2_0-2.6.2-7.1.101mdk.i586.rpm libgtk+2.0_0-2.4.9-9.1.101mdk.i586.rpm libgtk+-x11-2.0_0-2.4.9-9.1.101mdk.i586.rpm libgdk_pixbuf2.0_0-2.4.9-9.1.101mdk.i586.rpm the result: warning: package libgnome-vfs2_0 = 2.6.2-7mdk was already added, replacing with libgnome-vfs2_0 <= 2.6.2-7.1.101mdk warning: package libgtk+2.0_0 = 2.4.9-9mdk was already added, replacing with libgtk+2.0_0 <= 2.4.9-9.1.101mdk warning: package libgtk+-x11-2.0_0 = 2.4.9-9mdk was already added, replacing with libgtk+-x11-2.0_0 <= 2.4.9-9.1.101mdk warning: package libgdk_pixbuf2.0_0 = 2.4.9-9mdk was already added, replacing with libgdk_pixbuf2.0_0 <= 2.4.9-9.1.101mdk error: Failed dependencies: devel(libexpat) is needed by libgtkhtml2_0-devel-2.6.2-1mdk devel(libfontconfig) is needed by libgtkhtml2_0-devel-2.6.2-1mdk devel(libfreetype) is needed by libgtkhtml2_0-devel-2.6.2-1mdk devel(libX11) is needed by libgtkhtml2_0-devel-2.6.2-1mdk devel(libXcursor) is needed by libgtkhtml2_0-devel-2.6.2-1mdk devel(libXext) is needed by libgtkhtml2_0-devel-2.6.2-1mdk devel(libXft) is needed by libgtkhtml2_0-devel-2.6.2-1mdk devel(libXi) is needed by libgtkhtml2_0-devel-2.6.2-1mdk devel(libXinerama) is needed by libgtkhtml2_0-devel-2.6.2-1mdk devel(libXrandr) is needed by libgtkhtml2_0-devel-2.6.2-1mdk devel(libXrender) is needed by libgtkhtml2_0-devel-2.6.2-1mdk devel(libexpat) is needed by libgail17-devel-1.6.6-1mdk devel(libfontconfig) is needed by libgail17-devel-1.6.6-1mdk devel(libfreetype) is needed by libgail17-devel-1.6.6-1mdk devel(libX11) is needed by libgail17-devel-1.6.6-1mdk devel(libXcursor) is needed by libgail17-devel-1.6.6-1mdk devel(libXext) is needed by libgail17-devel-1.6.6-1mdk devel(libXft) is needed by libgail17-devel-1.6.6-1mdk devel(libXi) is needed by libgail17-devel-1.6.6-1mdk devel(libXinerama) is needed by libgail17-devel-1.6.6-1mdk devel(libXrandr) is needed by libgail17-devel-1.6.6-1mdk devel(libXrender) is needed by libgail17-devel-1.6.6-1mdk libgnome-vfs2_0 = 2.6.2-7mdk is needed by libgnome-vfs2_0-devel-2.6.2-7mdk devel(libcrypto) is needed by libgnome-vfs2_0-devel-2.6.2-7mdk devel(libssl) is needed by libgnome-vfs2_0-devel-2.6.2-7mdk devel(libexpat) is needed by libgnomecanvas2_0-devel-2.6.1.1-1mdk devel(libfontconfig) is needed by libgnomecanvas2_0-devel-2.6.1.1-1mdk devel(libfreetype) is needed by libgnomecanvas2_0-devel-2.6.1.1-1mdk devel(libX11) is needed by libgnomecanvas2_0-devel-2.6.1.1-1mdk devel(libXcursor) is needed by libgnomecanvas2_0-devel-2.6.1.1-1mdk devel(libXext) is needed by libgnomecanvas2_0-devel-2.6.1.1-1mdk devel(libXft) is needed by libgnomecanvas2_0-devel-2.6.1.1-1mdk devel(libXi) is needed by libgnomecanvas2_0-devel-2.6.1.1-1mdk devel(libXinerama) is needed by libgnomecanvas2_0-devel-2.6.1.1-1mdk devel(libXrandr) is needed by libgnomecanvas2_0-devel-2.6.1.1-1mdk devel(libXrender) is needed by libgnomecanvas2_0-devel-2.6.1.1-1mdk libgtk+2.0_0 = 2.4.9-9mdk is needed by libgtk+2.0_0-devel-2.4.9-9mdk libgtk+-x11-2.0_0 = 2.4.9-9mdk is needed by libgtk+2.0_0-devel-2.4.9-9mdk XFree86-devel is needed by libgtk+2.0_0-devel-2.4.9-9mdk devel(libX11) is needed by libgtk+2.0_0-devel-2.4.9-9mdk devel(libXcursor) is needed by libgtk+2.0_0-devel-2.4.9-9mdk devel(libXext) is needed by libgtk+2.0_0-devel-2.4.9-9mdk devel(libXft) is needed by libgtk+2.0_0-devel-2.4.9-9mdk devel(libXi) is needed by libgtk+2.0_0-devel-2.4.9-9mdk devel(libXinerama) is needed by libgtk+2.0_0-devel-2.4.9-9mdk devel(libXrandr) is needed by libgtk+2.0_0-devel-2.4.9-9mdk devel(libXrender) is needed by libgtk+2.0_0-devel-2.4.9-9mdk devel(libexpat) is needed by libgtk+2.0_0-devel-2.4.9-9mdk devel(libfontconfig) is needed by libgtk+2.0_0-devel-2.4.9-9mdk devel(libfreetype) is needed by libgtk+2.0_0-devel-2.4.9-9mdk libgdk_pixbuf2.0_0 = 2.4.9-9mdk is needed by libgdk_pixbuf2.0_0-devel-2.4.9-9mdk devel(libX11) is needed by libgdk_pixbuf2.0_0-devel-2.4.9-9mdk devel(libXext) is needed by libgdk_pixbuf2.0_0-devel-2.4.9-9mdk freetype2-devel >= 2.1.3-4mdk is needed by libpango1.0_0-devel-1.4.1-1mdk devel(libexpat) is needed by libpango1.0_0-devel-1.4.1-1mdk devel(libfontconfig) is needed by libpango1.0_0-devel-1.4.1-1mdk devel(libfreetype) is needed by libpango1.0_0-devel-1.4.1-1mdk devel(libX11) is needed by libpango1.0_0-devel-1.4.1-1mdk devel(libXext) is needed by libpango1.0_0-devel-1.4.1-1mdk devel(libXft) is needed by libpango1.0_0-devel-1.4.1-1mdk devel(libXrender) is needed by libpango1.0_0-devel-1.4.1-1mdk I have 2 problems: 1. libgdk_pixbuf2.0_0-devel-2.4.9-9mdk needs ibgdk_pixbuf2.0_0 = 2.4.9-9mdk. Other packages need an updated version (2.4.9-9.1.101mdk) 2. There is no XFree86-devel for Mandrake 10.1 . Searching rpm.pbone.net gave this list. As you can see, this package existed in Mandrake 10.0, but not in 10.1. Instead, there is a package called libxorg-x11-devel, but I'm not sure if it is indeed the same thing.
  6. EAI (Everything already installed)
  7. I also found libgnome-vfs2_0-devel and libgail-gnome-devel, but not gnome-vfs2_0-devel or gail-gnome-devel. It seems that Mandrake/Mandriva adds this "lib" at the beginning, while other distributions don't. Why is that? Is there a difference? Maybe that's the cause for this situation. The RPM requires the wrong packages.
  8. Where can I find gail-devel and gnome-vfs2-devel?
  9. Installation\ CD\ 1\ (cdrom1) removable://mnt/cdrom/media/main { hdlist: hdlist.Installation CD 1 (cdrom1).cz key-ids: 70771ff3 removable: /dev/hdc with_hdlist: ../../media/media_info/hdlist1.cz } Installation\ CD\ 2\ (cdrom2) removable://mnt/cdrom/media/main2 { hdlist: hdlist.Installation CD 2 (cdrom2).cz key-ids: 70771ff3 removable: /dev/hdc with_hdlist: ../../media/media_info/hdlist2.cz } Installation\ CD\ 3\ (cdrom3) removable://mnt/cdrom/media/main3 { hdlist: hdlist.Installation CD 3 (cdrom3).cz key-ids: 70771ff3 removable: /dev/hdc with_hdlist: ../../media/media_info/hdlist3.cz } plf-nonfree ftp://ftp.free.fr/pub/Distributions_Linux/plf/mandrake/non-free/10.1 { hdlist: hdlist.plf-nonfree.cz key-ids: caba22ae list: list.plf-nonfree with_hdlist: hdlist.cz } jpackage ftp://ftp.ciril.fr/pub/linux/mandrakelinux/official/10.1/i586/media/jpackage { hdlist: hdlist.jpackage.cz key-ids: c431416d with_hdlist: media_info/hdlist.cz } plf-free ftp://ftp.free.fr/pub/Distributions_Linux/plf/mandriva/free/10.1/i586 { hdlist: hdlist.plf-free.cz key-ids: caba22ae list: list.plf-free with_hdlist: hdlist.cz } updates ftp://ftp.ens-cachan.fr/mirror/Mandrakelinux/official/updates/10.1/main_updates { hdlist: hdlist.updates.cz key-ids: 22458a98 list: list.updates update with_hdlist: media_info/hdlist.cz } main ftp://ftp.ens-cachan.fr/mirror/Mandrakelinux/official/10.1/i586/media/main { hdlist: hdlist.main.cz key-ids: 70771ff3 with_hdlist: media_info/hdlist.cz } contrib ftp://ftp.ens-cachan.fr/mirror/Mandrakelinux/official/10.1/i586/media/contrib { hdlist: hdlist.contrib.cz key-ids: 78d019f5 with_hdlist: media_info/hdlist.cz }
  10. Yes. Again , "Everything already installed"
  11. If I have some other version already installed, then "rpm -qa | grep libgtkhtml" should find it, but it doesn't. It does find libgtkhtml2_0-2.6.2-1mdk , libgtkhtml1.1_3-1.1.10-6mdk and libgtkhtml-3.1_11-3.2.4-1.1.101mdk , but I need libgtkhtml2_0-devel-2.6.2-1mdk . Is it possible that these packages can't coexist? Do I have to uninstall libgtkhtml2_0-2.6.2-1mdk? I'd rather not, because it means I also have to uninstall essential packages like gnome-media , gnome-panel and gnome-session.
  12. I know that using urpmi is better than using rpm , but urpmi thinks for some reason that "Everything already installed" . rpm -vv --rebuilddb didn't change anything. :dry:
  13. somethingx

    RPM problem

    I have Mandrake 10.1 and I'm trying to install the package libgtkhtml2_0-devel . When I tried to install it using rpmdrake , I got this message: Sorry, the following package(s) can't be selected. libgtkhtml2_0-devel-2.6.2-1mdk Then I tried urpmi libgtkhtml2_0-devel , which gave this message: Everything already installed but the query rpm -qa | grep libgtkhtml returned: libgtkhtml2_0-2.6.2-1mdk libgtkhtml-3.1_11-3.2.4-1.1.101mdk libgtkhtml1.1_3-1.1.10-6mdk As you can see, libgtkhtml2_0-devel was not there. So I found libgtkhtml2_0-devel-2.6.2-1mdk on the net, downloaded it and tried to install it with rpm -Uvh libgtkhtml2_0-devel-2.6.2-1mdk.i586.rpm Which produced this: error: Failed dependencies: gail-devel is needed by libgtkhtml2_0-devel-2.6.2-1mdk gnome-vfs2-devel is needed by libgtkhtml2_0-devel-2.6.2-1mdk devel(libart_lgpl_2) is needed by libgtkhtml2_0-devel-2.6.2-1mdk devel(libatk-1.0) is needed by libgtkhtml2_0-devel-2.6.2-1mdk devel(libexpat) is needed by libgtkhtml2_0-devel-2.6.2-1mdk devel(libfontconfig) is needed by libgtkhtml2_0-devel-2.6.2-1mdk devel(libfreetype) is needed by libgtkhtml2_0-devel-2.6.2-1mdk devel(libgailutil) is needed by libgtkhtml2_0-devel-2.6.2-1mdk devel(libgdk_pixbuf-2.0) is needed by libgtkhtml2_0-devel-2.6.2-1mdk devel(libgdk-x11-2.0) is needed by libgtkhtml2_0-devel-2.6.2-1mdk devel(libgnomecanvas-2) is needed by libgtkhtml2_0-devel-2.6.2-1mdk devel(libgtk-x11-2.0) is needed by libgtkhtml2_0-devel-2.6.2-1mdk devel(libpango-1.0) is needed by libgtkhtml2_0-devel-2.6.2-1mdk devel(libpangoft2-1.0) is needed by libgtkhtml2_0-devel-2.6.2-1mdk devel(libpangox-1.0) is needed by libgtkhtml2_0-devel-2.6.2-1mdk devel(libpangoxft-1.0) is needed by libgtkhtml2_0-devel-2.6.2-1mdk devel(libX11) is needed by libgtkhtml2_0-devel-2.6.2-1mdk devel(libXcursor) is needed by libgtkhtml2_0-devel-2.6.2-1mdk devel(libXext) is needed by libgtkhtml2_0-devel-2.6.2-1mdk devel(libXft) is needed by libgtkhtml2_0-devel-2.6.2-1mdk devel(libXi) is needed by libgtkhtml2_0-devel-2.6.2-1mdk devel(libXinerama) is needed by libgtkhtml2_0-devel-2.6.2-1mdk devel(libxml2) is needed by libgtkhtml2_0-devel-2.6.2-1mdk devel(libXrandr) is needed by libgtkhtml2_0-devel-2.6.2-1mdk devel(libXrender) is needed by libgtkhtml2_0-devel-2.6.2-1mdk devel(libz) is needed by libgtkhtml2_0-devel-2.6.2-1mdk Now, rpmdrake doesn't find gail-devel, while urpmi again says "Everything already installed" , but rpm -qa gail returns: libgail-gnome-1.0.6-1mdk gail-1.6.6-1mdk libgail17-1.6.6-1mdk and if that's not weird enough , although the last rpm (libgail17-1.6.6-1mdk) is installed, rpmdrake shows it on the list packages that can be installed. please
  14. I tried to access my Linux PC from my Windows PC (the other machine on the network) and it went ok. The strange thing is that right after that I tried smb:/ on Linux again and it worked. I don't get it.
  15. I've been using Samba for some time and it was working just fine. Today when I wrote smb:/ in Konqueror as I always do, I got this error: "Unable to find any workgroups in your local machine". Even if there was a problem accessing another machine on the network, which is possible, the name of the workgroup should have been displayed. What could cause this change and how do I fix it?
×
×
  • Create New...