Jump to content
Sign in to follow this  
Guest ruhrpottrider83

how to disable automount during boot ???

Recommended Posts

Guest ruhrpottrider83

hi,

i have several removable harddisks in my sytem, using mobile racks.

they have a fat 32 file system , because i use them also with windows.

every time i boot, these disks get mounted, although i don't want them to be mounted generally.

 

how can i disable this automount, so that they generally are unmounted, and that i have to mount them manually, when i want to access them ???

 

moreover, the directories cdrom, cdrom2 and floppy in /mnt are locked directories, so that i can't access them , even not as root

 

trying to change their attributes using the command chmod as root failed, the output was something like input output error

 

how can i change this, moreover i want them to mount myself manually, too

 

can anyone help me ??

Share this post


Link to post
Share on other sites

to disable supermount, pass the parameters 'nomount' to lilo before booting. this is just from memory so somebody might correct it later (or post an equivalent for grub).

 

- during the lilo screen, press escape. you should get a prompt like this

  lilo:

- assuming you use the option labeled 'linux' to boot your linux system, enter on the prompt linux nomount (or was it linux append=nomount?).

 

your system should then boot without supermount. you can automate this by editing your /etc/lilo.conf, copying the 'linux' stanza and renaming the pasted copy to something else (like 'linux-nomounnt') and then adding the 'nomount' option in the append line of the new stanza. save the changes and run

# lilo -v

to have the changes be reflected (assuming there is no error in your new stanza) in the lilo menu options.

 

as for your mounting directories, you have to do it through the /etc/fstab. search for fstab and mount here in the board for threads which discusses the topics further.

 

ciao!

Share this post


Link to post
Share on other sites

after re-reading your original posts, you might only have to do everything in fstab. comment out the lines corresponding to your windows partitions, save the changes and run

 # mount -a

.

 

ciao!

Share this post


Link to post
Share on other sites

Ramfree's above suggestion will work. You can also add "noauto" w/o quotes to the comma separated options in the /etc/fstab entry for the drive you don't want mounted at boot. That way you will be able to make a mounting desktop icon for it by right clicking on the desktop and choosing Create New>Hard Drive.

Share this post


Link to post
Share on other sites

Oops. Don't mean to follow my own post but you have to include "user, noauto" if you want to be able to mount the drive as an ordinary user, otherwise you can only do so as root.

Share this post


Link to post
Share on other sites

If anyone reads this and uses grub, it's basically the same concept, but the steps are a little diff. What I've done: When grub appears press e for edit>then select the image you want to boot and press e again. If you already have an "append=" just add nomount to the end, if not add append=nomount.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...