Jump to content
Sign in to follow this  
ilia_kr

Flicking fonts

Recommended Posts

I have a stange problem on FC4: when i move the mouse around the screen (KDE & Gnome), the fonts are flicking barely noticeable, but still annoing. This never happend in gnome. What could it be and how to fix this?

Thanks.

Edited by ilia_kr

Share this post


Link to post
Share on other sites

The most obvious thing to try is increase refresh frequency of the monitor - this can be configured via MCC but essentailly it is just a selection of another modeline. Another possible solution would be to check whether freetype fonts are installed.

 

I personally found FC4 fonts being of much poorer quality than those used by Mandriva. This was especially noticable when I ran evolution on the remote desktop via putty. Under FC4, evolution fonts were plain unreadable, while under mandriva, the fonts were not perfect but legible. Since the Mandriva CDs were on my desk, I just got rid of FC4 for good.

Share this post


Link to post
Share on other sites

I would try:

 

rpm -qa | grep freetype

 

and see if it lists them. Or, if not, in case of a case mismatch, since it's case sensitive, you could try:

 

rpm -qa > installedapps | sort

 

that will pipe all your installed apps into the file called installedapps, and then you can open this with vi or nano and see if it's listed.

Share this post


Link to post
Share on other sites

Where can i find the refresh rate here?

# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier	 "single head configuration"
Screen	  0  "Screen0" 0 0
InputDevice	"Mouse0" "CorePointer"
InputDevice	"Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

RgbPath	  "/usr/X11R6/lib/X11/rgb"
FontPath	 "unix/:7100"
EndSection

Section "Module"
Load  "dbe"
Load  "extmod"
Load  "fbdevhw"
Load  "glx"
Load  "record"
Load  "freetype"
Load  "type1"
Load  "dri"
EndSection

Section "InputDevice"

Option	"XkbModel"	"microsoft"

Identifier  "Keyboard0"
Driver	  "kbd"
Option		"XkbModel" "pc105"
Option		"XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier  "Mouse0"
Driver	  "mouse"
Option		"Protocol" "IMPS/2"
Option		"Device" "/dev/input/mice"
Option		"ZAxisMapping" "4 5"
Option		"Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier   "Monitor0"
VendorName   "Monitor Vendor"
ModelName	"L1750SQ"
DisplaySize  340	270
HorizSync	30.0 - 83.0
VertRefresh  56.0 - 75.0
Option		"dpms"
EndSection

Section "Device"
Identifier  "Videocard0"
Driver	  "tdfx"
VendorName  "Videocard vendor"
BoardName   "Banshee (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device	 "Videocard0"
Monitor	"Monitor0"
DefaultDepth	 24
SubSection "Display"
	Viewport   0 0
	Depth	 16
	Modes	"800x600" "640x480"
EndSubSection
SubSection "Display"
	Viewport   0 0
	Depth	 24
	Modes	"1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group		0
Mode		 0666
EndSection

Also, currently i got 75hz refresh, the only other option is 60hz, but when i switch - the monitor goes out of range...

Share this post


Link to post
Share on other sites

Is your monitor a CRT or a flat screen? Anyway, the frequency of 75Hz should be high enough for you not noticing any flicker. Run xvidtune from the console, it will show the exact modeline at which the monitor is operating.

Share this post


Link to post
Share on other sites

I've just found some new evidences: I'm using a device (don't know how to call it) that allows me to use 1 keybord & mouse & monitor with 2 boxes.

If i turn on both boxes - there is no sign of any flickerings at all, they appear only when i turn off my XP box (when only a Linux box working).

Just in case, here how my boxes are connected:

 

 

Got any ideas?

Share this post


Link to post
Share on other sites

Have you tried swapping the cables around. For example, if your Linux box is using one set of cables, to switch so that it's using the keyb/mouse/video cable that's attached to the XP box. Then see if the problem occurs this way round.

 

If so, I would expect it's the KVM switch that's the problem. If not, then it would hint that the cables previously connected were the problem for the interference.

 

Is the KVM near anything magnetic. Perhaps reposition it away from the monitor if it's close to this, and away from anything else that might be magnetic.

Share this post


Link to post
Share on other sites

I experienced a similar behaviour with KVM switches with Macs, used togeter with Windows machines. Don't know though how it can be solved. Maybe it depends on the manufacturer. :unsure:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...