Jump to content

kernel panic error 6


Recommended Posts

I have been working on this for some time without success. I did a clean install on an old Compaq laptop, 333Mhz with 64 meg of ram, and a 40 gig hard drive. This machine had been running Mdk 9.2 for about two years, and was stable.


I installed Ubuntu, and it loaded without problems. I could not get the sound to work, and could not find any help, so I thought I would take my Mandriva 2006 CD's and install. During the install, I saw a warning about being low on resources. I continued the install, and all seem good until I reboot. Then I see the following:


'mount: error 6 mounting reiserfs flags notail' The system retries twice more without the flags, but does not mount the file system. The last line reports 'Kernel panic - not syncing: No init found. Try passing init= option to kernel.'


What I have done: If I boot the system with Knoppix, I can mount all partitions and read the files. I mounted hda1, the boot partition, and was able to write to the lilo.conf file. As far as I can tell, teh partitions are O.K.


I tried pressing ESC at the lilo boot screen, and tried 'linux noapic acpi=off mem=64M'. This made no difference.


Here is the /etc/fstab file.


/dev/hda1 / reiserfs notail,noatime 1 1
/dev/hda7 /data reiserfs notail,noatime 1 2
/dev/hda6 /home reiserfs notail,noatime 1 2
/dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859-15,codepage=850,noauto,ro,exec,users 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-15,sync,codepage=850 0 0
none /proc proc defaults 0 0
/dev/hda5 swap swap defaults 0 0

Here is the output of fdisk -l

Disk /dev/hda: 40.0 GB, 40007761920 bytes

240 heads, 63 sectors/track, 5168 cylinders

Units = cylinders of 15120 * 512 = 7741440 bytes


Device Boot Start End Blocks Id System

/dev/hda1 * 1 1350 10205968+ 83 Linux

/dev/hda2 1351 5168 28864080 5 Extended

/dev/hda5 1351 1419 521608+ 82 Linux swap / Solaris

/dev/hda6 1420 2779 10281568+ 83 Linux

/dev/hda7 2780 5168 18060808+ 83 Linux


Here is /etc/lilo.conf


# File generated by DrakX/drakboot

# WARNING: do not forget to run lilo after modifying this file















append=" acpi=ht resume=/dev/hda5 splash=silent"






append=" acpi=ht resume=/dev/hda5"





append=" failsafe acpi=ht resume=/dev/hda5"


I did have a look to make sure initrd.img and vmlinuz are where they are supposed to be.


Does any one know what 'error 6' is ??? Thoughts on what to try next?

Link to comment
Share on other sites

My system only has the notail option in, not noatime. Boot from the livecd again, edit your fstab, and remove the comma and noatime, leaving just notail on it's own, and then see if you can boot.


This is how my fstab looks for comparision:


/dev/md0 / reiserfs notail 1 1
/dev/hda1 /boot reiserfs notail 1 2
/dev/hdb5 /home reiserfs notail 1 2


disregard /dev/md0. This is my raid 1 array mirroring my / partition in the event of disk failure. My settings are default from 2006 installation (other than that I'm using raid).

Link to comment
Share on other sites

That one is hard to solve imho. The most common thing (screwed partitions) is unlikely,a s fstab, fdisk and lilo.conf look quite fine, except what Ian noted. The only things left are IMO that your kernel does not support all hardware you have (maybe you need to compile it again with certain modules before it lifts off) or that you forgot to create the initrd after compiling the kernel or running mrproper after compiling the kernel.


I searched on the net, but could not find anything really useful there, too. :unsure:

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...