Jump to content
Sign in to follow this  
ianw1974

PHP pages appearing blank [solved]

Recommended Posts

Trying to get my php pages loaded with Apache, and they don't seem to be working.

 

In /etc/httpd/conf/httpd.conf I have the following line:

 

Include /etc/httpd/conf.d/*.conf

 

and in this directory is a php.conf file, which I've posted the contents of below:

 

#
# PHP is an HTML-embedded scripting language which attempts to make it
# easy for developers to write dynamically generated webpages.
#

LoadModule php4_module modules/libphp4.so

#
# Cause the PHP interpreter to handle files with a .php extension.
#
AddType application/x-httpd-php .php
# AddType application/x-httpd-php-source .phps

#
# Add index.php to the list of files that will be served as directory
# indexes.
#
DirectoryIndex index.php

 

All seems to be correct in the configuration, but when it attempts to load the page, it's just blank, and doesn't appear how it should.

 

Version Information:

 

Apache - 2.0.52

PHP - 4.3.9

 

It's all running on Red Hat Enterprise Linux ES, and I've just been using the standard rpm's for installation to make things easier than trying to compile stuff and complicate things even further. Help appreciated, I must be missing something :unsure:

Share this post


Link to post
Share on other sites

tail /var/log/apache/error.log

 

it could be a simple as having E_ERROR off, and your script having an error

Share this post


Link to post
Share on other sites

It might be worth checking that you've installed mod_php and not plain old php (not sure how redhat splits them up).

Share this post


Link to post
Share on other sites

I'm honestly not sure what happened with this, but it started to work. I did stop and start the services, and it kept appearing blank.

 

I then rebooted the system, and then all seemed to work. Bizarre as normally restarting the httpd service sorts it out.

Share this post


Link to post
Share on other sites

Weird synchronicity about this one. One of my friends was setting up a LAMP server the other day (just to play with) and had the same problem.

 

The solution? Remove spaces from his php tags. He was typing

<? php /* stuff */ ?>

instead of

<?php /* stuff */ ?>

This, after spending 3 days loading and unloading modules, upgrading PHP to latest version, and generally climbing a Dollis Hill.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...