Jump to content
Sign in to follow this  
mr_coffee

Just installed mandriva again! Internet Problems

Recommended Posts

Hello everyone, a very odd thing has happened. Well orginally when i installed mandriva 2006 powerpack edition, the first boot up, no sound, and no internet connection. I reb00ted and it worked fine. Later I tried to change the machine name, totally messed up, and ended up making the internet stop working. So I just did a clean install, starting over from scratch.

 

I'm having the same problems! I didn't change anything, but still no sound, and no internet. When I could connect to the internet, my machine name wasn't "localhost" it was like "x1-20-392-blah". But this time when I installed it just named it localhost. I'm not worried about the sound right now, i just need to be able to connect to the internet with mandriva 2006 Power Pack. Here is my iconfig result, and a few other commands to show you what my machine is doing. I am a n00b!

 

[root@localhost coffee]# ifconfig
eth0	  Link encap:Ethernet  HWaddr 00:50:8D:D1:C1:97
	  inet addr:12.183.103.29  Bcast:255.255.255.255  Mask:255.255.254.0
	  inet6 addr: fe80::250:8dff:fed1:c197/64 Scope:Link
	  UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
	  RX packets:389 errors:0 dropped:0 overruns:0 frame:0
	  TX packets:1494 errors:0 dropped:0 overruns:0 carrier:0
	  collisions:0 txqueuelen:1000
	  RX bytes:23719 (23.1 KiB)  TX bytes:90684 (88.5 KiB)
	  Interrupt:16 Base address:0x2000

eth1	  Link encap:UNSPEC  HWaddr 00-50-8D-00-00-D0-C1-97-00-00-00-00-00-00-00-00
	  UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
	  RX packets:0 errors:0 dropped:0 overruns:0 frame:0
	  TX packets:0 errors:6 dropped:6 overruns:0 carrier:0
	  collisions:0 txqueuelen:1000
	  RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

eth2	  Link encap:UNSPEC  HWaddr 00-02-3C-01-51-11-E9-25-00-00-00-00-00-00-00-00
	  UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
	  RX packets:0 errors:0 dropped:0 overruns:0 frame:0
	  TX packets:0 errors:6 dropped:6 overruns:0 carrier:0
	  collisions:0 txqueuelen:1000
	  RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

lo		Link encap:Local Loopback
	  inet addr:127.0.0.1  Mask:255.0.0.0
	  inet6 addr: ::1/128 Scope:Host
	  UP LOOPBACK RUNNING  MTU:16436  Metric:1
	  RX packets:713 errors:0 dropped:0 overruns:0 frame:0
	  TX packets:713 errors:0 dropped:0 overruns:0 carrier:0
	  collisions:0 txqueuelen:0
	  RX bytes:64605 (63.0 KiB)  TX bytes:64605 (63.0 KiB)

[root@localhost coffee]# ping www.google.com
ping: unknown host www.google.com

[root@localhost coffee]# cat /etc/resolv.conf
nameserver 65.83.241.181
nameserver 67.32.118.46

[root@localhost home]# slocate resolv.conf
/etc/resolv.conf
/usr/share/man/man5/resolv.conf.5.bz2

[root@localhost home]# slocate resolv.conf.bak
[root@localhost home]# ping 66.249.87.104
connect: Network is unreachable
[root@localhost home]#	 

[root@localhost etc]# cat hosts
127.0.0.1			   localhost

 

My ethernet card is located at eth0, and is a Realtek RTL8169/8110 Family Gigabit and i'm connecting to the internet through a cable modem. When my internet was working on mandriva it was set as a LAN connection. Even though this is the only computer hooked up into the internet and is not networked to any other machine. ANy help would be great! I'm running KDE 3.4, Mandriva 2006 PowerPack.

 

 

This may help or hinder the problem, but some other guy from another forum told me the following:

its because of /etc/resolv.conf file .... by changing ur hostname u flushed that file ...try search the file by the name /etc/resolv.conf.bak

if ur lucky .. u will get the dns IP from that bakup file .. if not then .. u will have to get ur DNS ip and add in /etc.resolv.conf

try this

#cat /etc/resolv.conf.bak > /etc/resolv.conf

 

now ur internet is gonna work .. given ur interface is working .. actually ur interent is still working but ur dns is not ...

if u try

ping 66.249.87.104

it will ping

but when u try

ping www.google.com

it wont why?

because ur request for name resolution is put down coz of no nameserver available ..

check ur /etc/resolv.conf

it shud be empty ... if it is .. enter the name of ur nameserver .. which must be in /etc/resolv.conf.bak if ur lucky enough

 

But this can't be the case now, because I've totally did a clean install, and I didn't mess with my host name.

Edited by mr_coffee

Share this post


Link to post
Share on other sites

Hmmm... why are there three ethernet devices? Do you really have three ethernet cards on your box?

Check if you or your system accidently activated lo (local Loopback) instead of eth0 as primary networking device. This happened on one of my laptops once and it took me half an hour to notice it. Also disable your firewall for now if you have set one up.

 

PS: What do your network config files look like? Maybe a typo somewere? Did you use static IP or DHCP for connecting?

Share this post


Link to post
Share on other sites
Hmmm... why are there three ethernet devices? Do you really have three ethernet cards on your box?

Check if you or your system accidently activated lo (local Loopback) instead of eth0 as primary networking device.

 

 

Artic, I also had no idea why its showing 3 ethernet devices! I think its static, but I could be wrong. On windows its saying the following when i type in ipconfig /all

 

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Mr. Coffee>ipconf /all
'ipconf' is not recognized as an internal or external command,
operable program or batch file.

C:\Documents and Settings\Mr. Coffee>ipconfig /all

Windows IP Configuration

	Host Name . . . . . . . . . . . . : OWNER-E2F654771
	Primary Dns Suffix  . . . . . . . :
	Node Type . . . . . . . . . . . . : Unknown
	IP Routing Enabled. . . . . . . . : No
	WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

	Connection-specific DNS Suffix  . :
	Description . . . . . . . . . . . : Realtek RTL8169/8110 Family Gigabit
Ethernet NIC
	Physical Address. . . . . . . . . :
	Dhcp Enabled. . . . . . . . . . . : Yes
	Autoconfiguration Enabled . . . . : Yes
	IP Address. . . . . . . . . . . . : 12.183.102.170
	Subnet Mask . . . . . . . . . . . : 255.255.254.0
	IP Address. . . . . . . . . . . . : fe80::250:8dff:fed1:c197%4
	Default Gateway . . . . . . . . . : 12.183.101.1
	DHCP Server . . . . . . . . . . . : 209.55.0.135
	DNS Servers . . . . . . . . . . . : 65.83.241.181
										67.32.118.46
										fec0:0:0:ffff::1%1
										fec0:0:0:ffff::2%1
										fec0:0:0:ffff::3%1
	Lease Obtained. . . . . . . . . . : Saturday, February 18, 2006 4:07:09
PM
	Lease Expires . . . . . . . . . . : Sunday, February 19, 2006 9:50:12 AM


Tunnel adapter Teredo Tunneling Pseudo-Interface:

	Connection-specific DNS Suffix  . :
	Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
	Physical Address. . . . . . . . . : 
	Dhcp Enabled. . . . . . . . . . . : No
	IP Address. . . . . . . . . . . . : fe80::5445:5245:444f%5
	Default Gateway . . . . . . . . . :
	NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter 6to4 Tunneling Pseudo-Interface:

	Connection-specific DNS Suffix  . :
	Description . . . . . . . . . . . : 6to4 Tunneling Pseudo-Interface
	Physical Address. . . . . . . . . : 
	Dhcp Enabled. . . . . . . . . . . : No
	IP Address. . . . . . . . . . . . : 2002:cb7:66aa::cb7:66aa
	Default Gateway . . . . . . . . . : 2002:c058:6301::c058:6301
										2002:836b:213c::836b:213c
	DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
										fec0:0:0:ffff::2%1
										fec0:0:0:ffff::3%1
	NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter Automatic Tunneling Pseudo-Interface:

	Connection-specific DNS Suffix  . :
	Description . . . . . . . . . . . : Automatic Tunneling Pseudo-Interface

	Physical Address. . . . . . . . . : 0C-B7-66-AA
	Dhcp Enabled. . . . . . . . . . . : No
	IP Address. . . . . . . . . . . . : fe80::5efe:12.183.102.170%2
	Default Gateway . . . . . . . . . :
	DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
										fec0:0:0:ffff::2%1
										fec0:0:0:ffff::3%1
	NetBIOS over Tcpip. . . . . . . . : Disabled

C:\Documents and Settings\Mr. Coffee>

 

I have no idea what the heck those are! I don't have a wireless anything in my computer, just a regualr modem, and an ethernet card.

 

 

 

How do I know if it accidently activated a lo(local Looopback) instead of eth0? And if it did, how do I fix it? SOrry i'm pretty new to linux! When you say network configure files, do you know where they are located the ones u want me to show you? Again this is a clean install I don't know how somthing could already be messed up with me not touching any system settings/files. Its my lucky day heh :)

Edited by mr_coffee

Share this post


Link to post
Share on other sites

Please post the contents of these files (open a terminal and type)

 

cat /etc/networking-scripts/ifcfg-eth0

cat /etc/network/interfaces

 

Copy and paste the contents here. The first one will show us how your network device is configured and if it is using DHCP or a static IP. Your Windows System is using DHCP, thus Mandriva should use DHCP, too.

 

The second one will perhaps explain us why there are three ethernet devices shown and which device is set as system-default with which basic configs. Try to set up a LAN DHCP system first. I guess this is all that needs to be done.

Share this post


Link to post
Share on other sites

I wasn't able to use ur commands it kept saying unkown command...

[root@mybox etc]# cat /etc/network/interfaces
cat: /etc/network/interfaces: No such file or directory

[root@mybox etc]# cat /etc/networking-scripts/ifcfg-eth0
cat: /etc/networking-scripts/ifcfg-eth0: No such file or directory



[root@mybox etc]# slocate networking
/etc/sysconfig/networking
/etc/sysconfig/networking/devices
/etc/sysconfig/networking/profiles
/etc/sysconfig/networking/profiles/default
/etc/sysconfig/networking/tmp
/etc/sysconfig/networking/ifcfg-lo

 

But tHanks alot, I finally got it to work! I had to do the oddest of things!

What i had to do is the following, I had to add another host definition.

I put the static IP address as the address, for name, i put mybox, alias, mybox as well.

 

Thanks I think i got it working!

What i had to do is the following, I had to add another host definition.

I put the static IP address as the address, for name, i put mybox, alias, mybox as well.

 

 

[root@mybox coffee]# route
Kernel IP routing table
Destination	 Gateway		 Genmask		 Flags Metric Ref	Use Iface
12.183.102.0	*			   255.255.254.0   U	 10	 0		0 eth1
127.0.0.0	   *			   255.0.0.0	   U	 0	  0		0 lo
default		 *			   0.0.0.0		 U	 10	 0		0 eth1

 

I pinged that static IP address and it worked! I got:

[root@mybox coffee]# ping 66.249.87.104
PING 66.249.87.104 (66.249.87.104) 56(84) bytes of data.
64 bytes from 66.249.87.104: icmp_seq=1 ttl=242 time=111 ms
64 bytes from 66.249.87.104: icmp_seq=2 ttl=242 time=112 ms
64 bytes from 66.249.87.104: icmp_seq=3 ttl=242 time=113 ms
64 bytes from 66.249.87.104: icmp_seq=4 ttl=242 time=144 ms
64 bytes from 66.249.87.104: icmp_seq=5 ttl=242 time=120 ms

--- 66.249.87.104 ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4004ms
rtt min/avg/max/mdev = 111.624/120.301/144.093/12.317 ms

 

This is what my ipconfig looks like now:

[root@mybox coffee]# ifconfig
eth0	  Link encap:UNSPEC  HWaddr 00-50-8D-00-00-D0-C1-97-00-00-00-00-00-00-00-00
	  UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
	  RX packets:0 errors:0 dropped:0 overruns:0 frame:0
	  TX packets:0 errors:5 dropped:5 overruns:0 carrier:0
	  collisions:0 txqueuelen:1000
	  RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

eth1	  Link encap:Ethernet  HWaddr 00:50:8D:D1:C1:97
	  inet addr:12.183.102.170  Bcast:12.183.103.255  Mask:255.255.254.0
	  inet6 addr: fe80::250:8dff:fed1:c197/64 Scope:Link
	  UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
	  RX packets:8931 errors:0 dropped:0 overruns:0 frame:0
	  TX packets:10503 errors:0 dropped:0 overruns:0 carrier:0
	  collisions:0 txqueuelen:1000
	  RX bytes:4994193 (4.7 MiB)  TX bytes:876213 (855.6 KiB)
	  Interrupt:16 Base address:0x8000

eth2	  Link encap:UNSPEC  HWaddr 00-02-3C-01-51-11-E9-25-00-00-00-00-00-00-00-00
	  UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
	  RX packets:0 errors:0 dropped:0 overruns:0 frame:0
	  TX packets:0 errors:4 dropped:4 overruns:0 carrier:0
	  collisions:0 txqueuelen:1000
	  RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

lo		Link encap:Local Loopback
	  inet addr:127.0.0.1  Mask:255.0.0.0
	  inet6 addr: ::1/128 Scope:Host
	  UP LOOPBACK RUNNING  MTU:16436  Metric:1
	  RX packets:1495 errors:0 dropped:0 overruns:0 frame:0
	  TX packets:1495 errors:0 dropped:0 overruns:0 carrier:0
	  collisions:0 txqueuelen:0
	  RX bytes:140269 (136.9 KiB)  TX bytes:140269 (136.9 KiB)

 

 

This didn't work though:

[root@mybox coffee]# ping fec0:0:0:ffff::1
ping: unknown host fec0:0:0:ffff::1

 

I have no idea why device, eth0 or eth1 keeps switching on me! but it does! Sorry, i just paste what the console shows me. Now that my internet is working I get the following when i type in ifconfig:

[root@mybox coffee]# ping fec0:0:0:ffff::1
ping: unknown host fec0:0:0:ffff::1

 

 

here is a link to show you what my configuration looks like and how its working

http://img499.imageshack.us/img499/1232/snapshot12nf.png

 

Thanks again for the help!! Is it bad that I made it into a static IP even though it does support dchp?

Edited by mr_coffee

Share this post


Link to post
Share on other sites

No, you can use dhcp or static ips. However, dhcp is easier to manage, thus it is the natural choice to use it if it is available, unless you need a static ip (for some things, static ips are better than dhcp).

 

About the cat command resulting in zero hits... I guess my memory was fooling me. Sitting in front of a Debian box currently, it's hard to remember all filenames from memory. Could be that the files are stored in /etc/sysconfig/networking or such thing. Many distros have slightly differing layouts. :D

 

As long as everything works, I suggest to just ignore the other eth devices for now.

Share this post


Link to post
Share on other sites

hah yeah until they give me problems i'll just let them float around there for awhile. I actually found out waht they were I think, I use ipV6, not v4, so they arn't really eth devices, they are just tunneling adapters! I could be wrong but kind of makes sense. Thanks again!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...