Jump to content

flightgear doesn't start [solved]


Recommended Posts

Thanks Ian,

How do I check that I have kernel source installed??


I have downloaded the following driver to my fat32 folder which I use to share files between XP and linux:

Linux Display Driver - IA32

Version: 1.0-8174

Operating System: Linux IA32

Release Date: December 5, 2005

with the file name: NVIDIA-Linux-x86-1.0-8174-pkg1.run



Can you confirm that this is the right driver?????

Since it is the same filename as you wrote in your last mail I suppose it's OK

Link to comment
Share on other sites

I'd use the one you downloaded from nvidia. As I said, couldn't get opengl working any good. It was crap. The nvidia driver worked wonders and gave me 4000 fps. Before it was 200fps with the so called great working mandriva one.

Link to comment
Share on other sites

Sorry Ian, what is


"Before it was 200fps with the so called great working mandriva one."


Here it is late night. I will install the driver first ting tomorrow.


How do I check that I have kernel source installed??



Edited by Arne
Link to comment
Share on other sites

You can check my doing:


ls -l /usr/src/linux


if it reports something listing linux pointing to linux- or similar, then the kernel source is installed.


If not, you can install by checking what kernel your running:


uname -a


and making a note of the version. Then:


urpmi kernel-source


and it'll most likely list what kernel-source choices you have. You can then choose the relevant one, so:


urpmi kernel-source-


or whatever the rest of the filename is to get it to install.


What I was saying about the nvidia driver was that the dkms-nvidia-7676 or whatever version it was only gave me 200fps, which meant I could practically do nothing with 3D graphics. FPS is frames per second. The nvidia driver, from nvidia, gave me 4000fps. A lot faster.

Link to comment
Share on other sites

Hello Guys,

The kernel source was installed

Then I run:

rpm -qa nvidia
urpme nvidia-7676-5mdk

After copying

NVIDIA-Linux-x86-1.0-8174-pkg1.run into my /home/arne I run:

sh NVIDIA-Linux-x86-1.0-8174-pkg1.run

Installer asked if I wanted it to download kernel interface from nvidia website which I refused since I didn't have a internet connection at the time.

Installer confirmed it will compile the kernel interface

Installer then installed the driver and asked if I wanted it to configure X11 for me which I happily accepted.

Then I reboot and graphic desktop is back working nicely.


Thank you Ian for standby and help :thanks:

PS: Flightgear work as a charm

Link to comment
Share on other sites

Yes maybe Ian.

Actually it could also be the plf-free upgrade who destroid the function of the the original 2006 nvidia. I am not shure.


I still wonder how AaRTee could get it to work with the original. Maybee some day I will know.


Even though I am not sure, somebody should put up a big warning for newbie not to update this nvidia.......plf driver running urpmi --update --auto-selet and instead run 'urpmi --auto-select' and check that this 'dkms-nvidia......plf is not included. More people have the same problem, i.e. Where we crahed on the other post yesterday.


Marry Christmas, Ian

Edited by Arne
Link to comment
Share on other sites


Thanks for reply. Yes I also believe it was 'auto' makng the mess.

For people using nvidia graphic card should use 'urpmi --auto-select' because it shows which files/packages for you to accept thereby give people a chance to avoid the problem.


With the original nvidia driver I get 3,300 FPS and I am happy.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...