Jump to content
Sign in to follow this  
Guest wretchlikeme

"Mobile" Mandriva on USB HD w/o Globetrotter?

Recommended Posts

Guest wretchlikeme

I have Mandriva 10.2 LE 2005 i586 PowerPack...

 

I installed this OS on my 200GB Maxtor external usb hard drive. It runs great on my pc at home...but I want more- so much more.

 

I read about Mandriva's Move OS that works from a usb thumb drive. I also read about the Globetrotter USB Hard Drive from LaCie that has a "modified version of Mandriva LE 2005" installed on it. The point is that I already have an external hard drive (that was much cheaper) and I want the same functionality. I want to be able to plug my usb hard drive in at work/school/a friend’s house/wherever and bring up my Mandriva Desktop (with all of my files and settings).

 

So far- I can plug my usb hard drive and change the bios settings on my computer at work to boot from the usb. The usb HD is activated and LILO comes up. I boot Linux and it BEGINS to work…but then the kernel panics and has a bunch of errors. This figures since I am not using the computer that I installed Mandriva on and since I don’t have access to that “special version” of Mandriva that the Globetrotter uses.

 

Does anyone out there in cyberspace have:

a ) a version of Mandriva that allows users to have “live-cd functionality” without the live-cd limitations?

 

b ) The version of Mandriva that the Globetrotter uses?

 

And/or

 

c ) Any suggestions regarding my ultimate goal: using Mandriva wherever I go on whatever computer that I happen to be using?

 

Like I said, LILO boots up from the Hard drive but Mandriva simply refuses to. The external still works fine at the house- but I know that there is a way to get this to work.

 

HELP, HELP, HELP!

Thanks, thanks, thanks.

 

I should probably mention:

I know just enough about Linux to get me into trouble. I am like on the edge of newbie and intermediate user. I just need someone to give me a shove and I should be fine.

 

let me give you the kernel panic error that happens when I boot Mandriva from Lilo on my external HD (when I plug it into anything but my home computer...you know, the one that I installed Mandriva from):

 

"kernel panic-not syncing: No init found. Try passing init=option to kernel"

 

this happens in both regular and failsafe boots.

 

 

also, does anyone have the globetrotter or mandriva move boot cd? i wanna mess around with that.

 

[formating edited by arctic]

Share this post


Link to post
Share on other sites

Mandriva 10.1 installs and works on a USB external drive. The only problem I have been having is getting it to "see" my USB zip drive and the Windows fat32 partition that is on the USB external drive. It sees my internal hd Windows XP partition easily. I put lilo in the MBR of the USB drive as my computer will boot from USB. I have also used a boot cd to boot when USB booting is disabled. The boot cd is the mkrescue cd that can be created by MDK 10.1.

 

I have tried to used MDK 2005LE from USB but have not been successful getting it to boot- either from USB or a rescue cd. It did install though by using the alt2 option at installation boot up.

 

Jim

Share this post


Link to post
Share on other sites

I was able to install both 10.1 and 2005LE on a WD Passport 40gig usb drive but booting from it is another story. I have tried to boot from the laptop that I have used to install both versions to no avail. Now after installing 2006RC2, I have a globetrotter clone at much cheaper price. There will be systems out there that do not support Mandriva. I have tried my usb drive on some Gateway laptops, but these laptops have some hardware that does not support linux in general. The drive either does not boot or kernel panic.

 

J.T.

Edited by crazyspongebob

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...