Jump to content
heather1113

mplayer crashes when trying to open

Recommended Posts

I am confused about something and could use some help. When I try to open Mplayer crashes/closes right away. Just in case you need to know I have the mplayer-gui, mplayerplugin, and mplayerskins. When I tried to open it from the console this is what I get

[heather@applwibas02-l10-1025 heather]$ mplayer
MPlayer 1.0pre7-3.3.1 (C) 2000-2005 MPlayer Team
CPU: Advanced Micro Devices Duron Spitfire (Family: 6, Stepping: 1)
Detected cache-line size is 64 bytes
CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 0 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE SSE2



Warning unknown option "ao at line 2
85 audio & 196 video codecs
Usage:   mplayer [options] [url|path/]filename

Basic options: (complete list in the man page)
-vo <drv[:dev]>  select video output driver & device ('-vo help' for a list)
-ao <drv[:dev]>  select audio output driver & device ('-ao help' for a list)
vcd://<trackno>   play (S)VCD (Super Video CD) track (raw device, no mount)
dvd://<titleno>   play DVD title from device instead of plain file
-alang/-slang    select DVD audio/subtitle language (by 2-char country code)
-ss <timepos>    seek to given (seconds or hh:mm:ss) position
-nosound         do not play sound
-fs              fullscreen playback (or -vm, -zoom, details in the man page)
-x <x> -y <y>    set display resolution (for use with -vm or -zoom)
-sub <file>      specify subtitle file to use (also see -subfps, -subdelay)
-playlist <file> specify playlist file
-vid x -aid y    select video (x) and audio (y) stream to play
-fps x -srate y  change video (x fps) and audio (y Hz) rate
-pp <quality>    enable postprocessing filter (details in the man page)
-framedrop       enable frame dropping (for slow machines)

Basic keys: (complete list in the man page, also check input.conf)
<-  or  ->       seek backward/forward 10 seconds
up or down       seek backward/forward  1 minute
pgup or pgdown   seek backward/forward 10 minutes
< or >           step backward/forward in playlist
p or SPACE       pause movie (press any key to continue)
q or ESC         stop playing and quit program
+ or -           adjust audio delay by +/- 0.1 second
o                cycle OSD mode:  none / seekbar / seekbar + timer
* or /           increase or decrease PCM volume
z or x           adjust subtitle delay by +/- 0.1 second
r or t           adjust subtitle position up/down, also see -vf expand

* * * SEE THE MAN PAGE FOR DETAILS, FURTHER (ADVANCED) OPTIONS AND KEYS * * *

 

So, I looked over the message and saw Warning unknown option "ao at line 2 . I looked in /home/heather/.mplayer/config and saw nothing out of the ordinary.

# Write your default config options here!
"ao=arts"

But just in case, I deleted the "ao=arts" , saved and tried again but still wouldn't open and still got the same message so I added it back.

I tried Googling it and got nothing. I tried searching on the board and it seemed one person had that problem but if it was solved the solution wasn't posted.

 

So, you can see I did my homework. Hopefully someone can shed some light on this.

Share this post


Link to post
Share on other sites

It's ao=arts without the "" in the config.

 

To see what ao (audio out) options you have type: mplayer -ao help. The start the mpeg/avi with: mplayer -ao <name of option> xxxxx.avi

Share this post


Link to post
Share on other sites

I did what you said and took the quotes out of the ao=arts and then I did mplayer -ao help and arts is listed so I tried:

[heather@applwibas02-l10-1025 heather]$ mplayer -ao arts /home/heather/videos/Veronica.Mars/veronica.mars.112.hdtv-lol.avi
MPlayer 1.0pre7-3.3.1 (C) 2000-2005 MPlayer Team
CPU: Advanced Micro Devices Duron Spitfire (Family: 6, Stepping: 1)
Detected cache-line size is 64 bytes
CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 0 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE SSE2



85 audio & 196 video codecs
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0 : No such file or directory
Can't init input joystick
Playing /home/heather/videos/Veronica.Mars/veronica.mars.112.hdtv-lol.avi.
File not found: '/home/heather/videos/Veronica.Mars/veronica.mars.112.hdtv-lol.avi'
Failed to open /home/heather/videos/Veronica.Mars/veronica.mars.112.hdtv-lol.avi


Exiting... (End of file)

 

Also I went in to /etc/mplayer/mplayer.conf and where it said

 

# Specify default audio driver (see -ao help for a list).

# ao=oss

 

I changed it to

# Specify default audio driver (see -ao help for a list).

# ao=arts

 

It still will not open though :wall:

Edited by heather1113

Share this post


Link to post
Share on other sites

Thank you for your help but I think I will just uninstall mplayer and keep using xine/kaffeine. I don't really need that much choice after all, I'll just stick with what's been working so far.

Share this post


Link to post
Share on other sites

I know you've already switched, but you might try changing in the mplayer.conf ao=arts to ao=alsa. Dunno if that would work or not.

Share this post


Link to post
Share on other sites

this happened to me once. turned out i hadn't installed MPlayer fonts. do you have those installed? go to Mandrake Control Center->software management->install & type mplayer in the search. look for a package called mplayer-fonts-<version #>. or, you could also do as root from a terminal urpmi mplayer-fonts if you're one of those cli hardcores. install the package, then try running MPlayer.

 

Chris

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...