Jump to content
Sign in to follow this  
derxen

how to remove dkms-nvidia [solved]

Recommended Posts

hello all,

 

i have been having trouble with dkms-nvidia on le2005 (it accelerates my geforce fx, but it's rather choppy and generally unimpressive), so i want to try out nvidia's own 7667 package. what's the best way to uninstall dkms-nvidia completely? i've tried before, and i think the kernel module got left behind, leading to even worse trouble.

 

derxen

Share this post


Link to post
Share on other sites

you might want to try a simple "dkms remove" (or "dkms-nvidia remove"? dunno exactly, as i don't use nvidia) as root for the module of your kernel. then do a "dkms build" and "dkms install" with the new module. check if you get unresolved symbols when compiling. if nothing is being displayed, it should basically work.

 

usually, when you build the whole thing, your system should automatically choose the correct (newer) module, i guess (if not, somebody should say so). however, if everything gets messed up, you should perhaps try to build a custom kernel with that module included.

Share this post


Link to post
Share on other sites

I installed thac's nVidia_GLX-7667-2 last week, and it brought dkms-nvidia along with it. This dropped my glxgears scores by almost a third, so I decided to revert back to the nVidia supplied driver. I used MCC/rpmdrake to remove them both, and it seemed to work fine.

Share this post


Link to post
Share on other sites

i got rid of everything by rpm -e dkms-nvidia, as well as dkms, nvidia, and nvidia-kernel. i installed the nvidia package without a problem, but glx gears still seems choppy (seems to stop and start), and not very quick (around 1800 fps, with a geforce fx 5200). is that abnormal?

 

derxen

Share this post


Link to post
Share on other sites

could you specify that? what type of error in which conf file?

 

concerning the speed of your graphics, could you please give us some specs of your box and the amount of swap you have set up? also, try disabling some services that you don't need in the mcc. that might speed the box up a bit.

Share this post


Link to post
Share on other sites
could you specify that? what type of error in which conf file?

 

can't remember exactly what kind of error, sorry (cheked the logs, but couldn't find it), but it was in /var/lib/dkms/nvidia (or a subdirectory of it)

 

this is on a pentium 4 1.7 ghz, with 243 mb swap, 640 mb ram

 

derxen

Share this post


Link to post
Share on other sites

My guess is it was this:

 

Jul 15 15:03:00 localhost dkms: /etc/rc5.d/S04dkms: line 68: /var/lib/dkms/nvidia/7174/source/dkms.conf: No such file or directory

 

:D

Share this post


Link to post
Share on other sites
My guess is it was this:

 

Jul 15 15:03:00 localhost dkms: /etc/rc5.d/S04dkms: line 68: /var/lib/dkms/nvidia/7174/source/dkms.conf: No such file or directory

 

:D

 

that's the file, but the error message had something to do with files being mentioned in the conf file not being found.

 

derxen

Share this post


Link to post
Share on other sites

as there ain't more precise information i can only guess. maybe it is some libraries that you need for compiling that were missing on your system, maybe it was some needed prefixes, maybe it was a faulty config file (unlikely).

Share this post


Link to post
Share on other sites

sorry i can't be more precise, i should have kept the error message, but i was too stressed about getting the acceleration working. i did get the error consistently, even after a reinstall (don't ask). i'm not tempted to reproduce it though.

 

anyway, thanks everyone.

 

derxen

Share this post


Link to post
Share on other sites
sorry i can't be more precise,
no problem :)
i'm not tempted to reproduce it though.
quite understandable B)

 

is your topic solved now or not yet? if yes, i will mark it as solved later.

Share this post


Link to post
Share on other sites
sorry i can't be more precise,
no problem :)
i'm not tempted to reproduce it though.
quite understandable B)

 

is your topic solved now or not yet? if yes, i will mark it as solved later.

 

yes, go ahead. if i find a way to improve the acceleration, i'll report back, but for now let's consider it solved. thanks everyone.

 

derxen

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...