Jump to content

Lilo User icon login


riseringseeker
 Share

Recommended Posts

Well, I have successfully installed 2005LE on both the laptop and desktop. I rsycn'ed to a USB drive, to save all the pictures and such that I had, and was very happy that ndiswrapper that is now built in, properly configured my wireless card.

 

OK, I have a couple of issues left to resolve, but this one is driving me buggy! :wall:

 

I was used to having the user icons show as a selection on the user log-in. No matter what I try, I cannot get them back. (It's for the desktop, not the laptop - makes it easier for my grand-daughter and wife to log in).

 

First, I do not have a choice of "LILO with graphical menu" on the desktop, though I do on the laptop, which I find strange, since I installed them both from the same 3 CD's I downloaded. The option just flat isn't there on the desktop.

 

Second, when I go to "Configure your desktop"->"System"->"Login Manager", I do not have all the options that the help file says I should see. (On either machine).

 

In hopes someone can spot what I'm missing here - here is my lilo.conf:

 

# File generated by DrakX/drakboot

# WARNING: do not forget to run lilo after modifying this file

default="linux"

boot="/dev/hda"

map=/boot/map

install=menu

keytable=/boot/us.klt

compact

nowarn

timeout="100"

message=/boot/message

menu-scheme=wb:bw:wb:bw

 

image="/boot/vmlinuz"

label="linux-nonfb"

root="/dev/hda5"

initrd="/boot/initrd.img"

append="resume=/dev/hda6"

read-only

 

other=/dev/hda1

label="windows"

table=/dev/hda

 

image=/boot/vmlinuz

label="linux"

root=/dev/hda5

initrd=/boot/initrd.img

append="resume=/dev/hda6 splash=silent"

read-only

 

image=/boot/vmlinuz

label="failsafe"

root=/dev/hda5

initrd=/boot/initrd.img

append="failsafe resume=/dev/hda6 devfs=nomount"

read-only

 

(and yes, except for once, I've remembered to run lilo, or lilo -v as root after any and all changes.)

 

If anyone can help, please let me know

Link to comment
Share on other sites

What do you get when you boot up? Is one of the packages installed, either mdkkdm, kdm, or gdm?

 

I get two blank lines, asking for user name and password. Below that I get a choice of session themes/types (i.e. KDE, Gnome, etc.), and a boot choice menu (Shutdown, Restart, etc.)

 

When you ask what packages I have installed, I am not sure what you are asking - installed where? If I look under MCC->System->Display Manager I have GDM, KDM and XDM available to choose from. If I choose MCC->Boot->Select Graphical Theme I have "mandrakelinux" chosen (the default).

 

I just want the user icons to show selected users and make it easier for the ladies here to log in.

Link to comment
Share on other sites

Second, when I go to "Configure your desktop"->"System"->"Login Manager", I do not have all the options that the help file says I should see. (On either machine).

 

you should click the button below that says "administrator mode" then enter the root passwd so you can do some changes on that

 

 

When you ask what packages I have installed, I am not sure what you are asking - installed where? If I look under MCC->System->Display Manager I have GDM, KDM and XDM available to choose from. If I choose MCC->Boot->Select Graphical Theme I have "mandrakelinux" chosen (the default).

 

try KDM

 

 

edit: and I think its not Lilo user login, its your Desktop Manager User Login, since in lilo, there's no user there, thus are only options to boot, either to a different kernel or to your windows if you've dual boot

Edited by aioshin
Link to comment
Share on other sites

Second, when I go to "Configure your desktop"->"System"->"Login Manager", I do not have all the options that the help file says I should see. (On either machine).

 

you should click the button below that says "administrator mode" then enter the root passwd so you can do some changes on that

 

I did click on Admin mode, otherwise I wouldn't have been able to make any changes at all! This is one thing that is not like editing lilo.conf by hand, and forgetting to run lilo-v afterward - no changes can be made at all unless one goes into admin mode. (Something more than one person - present poster included has been guilty of!) That does not change the fact that ALL the various options listed in the help file are not all there.

 

When you ask what packages I have installed, I am not sure what you are asking - installed where? If I look under MCC->System->Display Manager I have GDM, KDM and XDM available to choose from. If I choose MCC->Boot->Select Graphical Theme I have "mandrakelinux" chosen (the default).

 

try KDM

 

That's what I have selected.

 

I did get the "use graphical theme" working. It was weird - the box was checked, but it didn't allow a selection of "LILO with graphical menu". Since it was already checked, I didn't change it (at first). I tried unchecking the tick box, and saving it, then later, checked it again. When I checked it, it said I needed to install a package, and pick a video mode - did, and now the box boots with a graphical display instead of just scrolling all the things. Don't know why it was checked, and not working by default.

 

 

edit: and I think its not Lilo user login, its your Desktop Manager User Login, since in lilo, there's no user there, thus are only options to boot, either to a different kernel or to your windows if you've dual boot

 

That didn't work either - Aussie John posted in another thread what I needed to do. Edit a file a later poster in this thread mentioned, and change one line.

Link to comment
Share on other sites

kdm now uses themes as default, I think you have to remove that to be able to see the user icons.

 

Try this:

In the file:

"/etc/kde/kdm/kdmrc"

change the line:

"UseTheme=false"

to:

"UseTheme=true"

 

Give it a try...

 

That did it. I actually found this in another thread, tried it, it worked. Not only do the user ions show, now have actual pictures of each user showing instead of a mdk icon!

Edited by riseringseeker
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...