Jump to content

Problems with Intel 536EP PCI Modem


Recommended Posts

Hey there guys,


Not 100% sure that this belongs in the hardware forum or not, but will give it a try otherwise.


I managed to patch the driver for 10.1 kernel (2.6.10 I believe) and managed to install the driver for the modem. Kppp managed to query the modem and dial, but returned an error (which I foolishly have not noted). After that I had removed an old modem and connection entry from a previous attempt. Now kppp crashes when I query the modem or try to connect.


Anyone with any experienec of kppp or the Intel 536EP modem that could give any pointers with regards to configuring this modem in kppp, could it be a problem with the link to /dev/modem?


For info I am running Kppp using KDE 3.3, on Kernel 2.6.11-6mdk (using full source given on installation disks).



Link to comment
Share on other sites



I am now typing this from Mandriva, at long last.


Not sure where the problem lied.


I used the correct driver for a change (was using the one for symmetric processors, although couldn't really see the difference).


Manually added Intel536 to /etc/modules (although still don't see anything in the verbose results on start up....)


What I believe to be the problem, was kppp, it didn't like me having only the one modem set up, I had to have two, even if they were identical in every way bar the Name.


Much wierdness, but i'm now able to get online now without having to use windoze......

Link to comment
Share on other sites

Guest Jim_Gillespie



Would you care to share your solution? My C hacking skills are rather rusty; I traced the problem with the Intel-provided driver to a missing symbol and then gave up and plugged in my old serial modem :-)


Thanks for any help,



Link to comment
Share on other sites

Sure thing Jim....


First I downloaded and extracted the following driver from intel:




You need to find the following file in the 536 Drivers:




Then I manually changed the files using the following patch (obtained here)


(Remove lines with a single -, add lines with a single +)


diff -ur intel-536EP- intel-536EP-
--- intel-536EP-  2004-10-15 10:16:53.000000000 +0200
+++ intel-536EP-   2005-01-22 18:51:32.000000000 +0100
@@ -86,7 +86,7 @@
int  softserial_open           (struct tty_struct*, struct file*);
void softserial_put_char       (struct tty_struct*, unsigned char);
void softserial_set_termios    (struct tty_struct*, struct termios*);
-int  softserial_write          (struct tty_struct*, int, const unsigned char*, int);
+int  softserial_write          (struct tty_struct*, const unsigned char*, int);
int  softserial_ioctl          (struct tty_struct*, struct file*, unsigned int, unsigned long);

Only in intel-536EP- softserial.o
diff -ur intel-536EP- intel-536EP-
--- intel-536EP-       2004-10-15 16:00:42.000000000 +0200
+++ intel-536EP-        2005-01-22 18:51:17.000000000 +0100
@@ -55,7 +55,6 @@
static DECLARE_MUTEX(softserial_write_sem);
int softserial_write(struct tty_struct* ptty,
-                      int from_user_space,
                      const unsigned char* input_buffer,
                      int write_count_asked)  //why is it a signed int?
@@ -73,41 +72,6 @@
   //printk("write: fus%d, count%d\n",from_user_space, write_count_asked);

-   if(from_user_space)
-   {
-      down(&softserial_write_sem); //this may not be enough
-      while(write_count_asked - written_count > 0)
-      {
-         softcore_space = G.softcore.write_free();
-         if(softcore_space == 0) break;  //try again?  potential infinite loop?
-         //printk("space free %d\n",softcore_space);
-         if(write_count_asked > softcore_space)
-         {
-            copy_size = softcore_space;
-         }
-         else
-         {
-            copy_size = write_count_asked;
-         }
-         copy_from_user(G.softcore.tx_fifo, input_buffer_ptr, copy_size);
-         //printk("tx_fifo[0]=%c copysize=%d",*(G.softcore.tx_fifo),copy_size);
-       // if(copy_size <= 0)
-        // {
-        //    return(-EFAULT);
-        // }
-         G.softcore.write(copy_size);
-         input_buffer_ptr += copy_size;
-         written_count += copy_size;
-      }
-      up(&softserial_write_sem);
-   }
-   else           //data is from kernel space
-   {
      while(write_count_asked - written_count > 0)
         softcore_space = G.softcore.write_free();
@@ -127,7 +91,6 @@
         input_buffer_ptr += copy_size;
         written_count += copy_size;
-   }



In addition to this I used the following patch (original Here)


diff -ur intel-536EP- intel-536EP-
--- intel-536EP-	2005-05-10 20:20:31.000000000 +0100
+++ intel-536EP- 2005-05-10 18:56:51.000000000 +0100
@@ -858,7 +858,7 @@
asmlinkage void kScheduleDPC(void)
#ifdef CONFIG PM
-    pm access(power dev);
+    //pm access(power dev);
   #if defined(TARGET CATAWBA)
      dpc function( 0 );


Then running the terminal in intel-536EP- I ran the following:


make clean
make 536
make install


You know when this has installed without error as it will say done!


Allegedly this is all you should need to do....


However kppp kept hanging up on me, I did the following


echo Intel536 >> /etc/modules


Still didn't solve my problem, and it doesn't do anything to the startup, however when I added another modem to kppp (even though it had the same config as the first) kppp would work with both options. When I deleted one (any of the two, it didn't matter) kppp screwed up again (wondering if this is just a quirk with pci modems, or something to do with a lucent modem I tried to install drivers for before hand, not sure that I have completely cleared that one out yet.). The minute I create another duplicate modem for kppp, hey presto, working again.

Edited by Reiver_Fluffi
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...