Jump to content

40 second pause when booting LE2005


Recommended Posts

Just upgraded to LE2005 from 10.1 OE, and everything has gone really well.


There are no errors on boot-up, however, it seems to pause for about 40 seconds at the following stage:


Entering non-interactive startup


Any ideas as to why?

Link to comment
Share on other sites

Have you tried turning OFF ....Hardrake in MCC--->Services.

If you haven't then it is rechecking all hardware for any changes of hardware even though you have not changed any. Other than equipment rebuilds, you do not need hardrake after installation of your OS.



Cheers. John.

Link to comment
Share on other sites

I'll have a go at that, although that was another pause later on! I've just done the urpmi --auto-select --auto, as I was missing a load of stuff that hadn't been upgraded.


Since then, the 40 second pause has stopped, but as you mentioned harddrake pauses for about 10 seconds - which is not good when you want to boot quick!


I'll disable that now, many thanks for that John.

Link to comment
Share on other sites


Just as John from lovely sunny Cairns said, its in the Services somewhere.

Open the MCC, check the services. Next to each service it says what that one is for. You should look and check what you need, but do be careful

If some services are enabled for something you dont have or need, for instance for a network that doesnt exist, it will first take its time for checking, and some time more till it realizes that nothing's there to check or do.

By looking at the services you learn a lot about what makes your machine run.



Edited by Helmut
Link to comment
Share on other sites

I've disabled the following services on my system, because I don't believe you need them anyway (and some got added with LE2005).


apmd (didn't start anyway)

atd (I don't schedule jobs)

bluetooth (I don't use it)

cpufreq (doesn't work on my machine anyway)

dund (linked to bluetooth)

haldaemon (added in LE2005 - apparently to collect and maintain hardware information)

harddrake (as suggested by aussiejohn - as my hardware doesn't change often anyway)

hidd (linked to bluetooth)

hotplug (either it didn't start, or I didn't think it was relevant)

mDNSResponder (added in LE2005 - to perform zeroconf service discovery - I don't use)

messagebus (didn't think it was relevant)

nifd (linked to mDNSResponder)

pand (linked to bluetooth)

postfix (didn't work anyway)

rawdevices (didn't work anyway)

ultrabayd (only relevant to Thinkpads)

xprint (didn't work anyway)


Quite a lot of services I have stopped, system still working though!!!

Link to comment
Share on other sites

If you ever intend to plug something in and have it work you probably want to turn haldaemon, hotplug and messagebus back on. Automounting likely won't work without haldaemon and messagebus (aka hal and dbus) either. You may want to reconsider atd, also, you may not schedule jobs but Mandriva does, like security checks and temp file cleanups and slocate database updates...

Link to comment
Share on other sites

My LE2005 pauses at the line "starting portmapper" for a good 20sec or so - any idea what that could be? 10.1 didn't do that, so my boot is a fair bit slower now.


On the subject of "Non-interactive startup", I had a highly amusing problem with the 10.1 boot (no longer happens with LE) - occasionally it would just stick at the line "Press 'I' for interactive startup", then wait until I pressed 'I' (it ignored every other key press, and just waited if I pressed nothing), and then _only_ when I pressed 'I', did it continue, and say "now entering non-interactive startup" !! Only by asking for interactive did it give non-interactive!!

Link to comment
Share on other sites

I have noticed it pausing at Port Mapper. This only happened when my network cable was unplugged. When I'm patched into the network, it works fine.


Just re-enabled atd. I wondered why my slocate was still pointing to old rpmnew's that didn't exist anymore!!!

Link to comment
Share on other sites

yeah, updatedb updates it, but I find if I disable auto-updating, I never do updatedb unless I actually want to run a search, and if you're going to run updatedb before every search you do, using slocate becomes pointless, since its only advantage over find is that it _has_ a precached database so the results are instant :)

Link to comment
Share on other sites

True! Would agree with that! Else you'd be better doing another kind of search than to prepare the database first lol.


I'll leave atd to do it. Since I rebuilt my test system though, it hasn't ran yet, so I might have to run it initially to get myself going :-)

Link to comment
Share on other sites

actually it'd be anacrond / crond that would do updatedb, as it's a recurring event. atd is used for one-time events. It's less commonly used than crond / anacrond, so on many systems disabling it may well not cause any problems, but it's a service that would be present on any standard *nix box, it hardly consumes any resources, so it's probably just a good idea to have it there in case something wants to use it at any point.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...