Jump to content

GUI - Another Nvidia question [solved]


Recommended Posts

Still learning the ropes with Linux after a couple of weeks.

Decided to do a fresh install last week as compiled so many different libaries and ran so many updates wanted to start from fresh.


Install Mandriva 2005

Loads up fine.


Installed the NVIDIA drivers (same ones as before 7157?)

Tells me that the install went ok


Edit the the /etc/X111/XForgconfig file (not sure of the exact name as away from PC)


Restart the PC - Problems begins


It now loads straight in to a shell prompt, which I have to login in to and type startx

This is not a problem, but when I go to logout now it dosnt give me the option to shut the PC down, I have checked the setup in the Auto login and it is set to load up KDE straight away. What have I done wrong (this time)


Apart from that Linux kicks ass

Link to comment
Share on other sites

It sounds like the dm service isn't loading properly. Check what services are set to load at boot in the mandriva control center system tab. the dm service should be set to start at boot.


Also, when you have to start X fromt he console, do it by typeing


service dm restart


That will start X with the display manager, so you'll have the full reboot and shutdown options.

Oh, and if you start it that way, you'll need to it ctrl-alt-f7 to switch to the desktop

Link to comment
Share on other sites

Edit /etc/modprobe.preload and add a new line which contains nothing but the word 'nvidia', then reboot.

Yes - that one cost me a pseudoulcer.


Also check your xorg.conf I once typed "Options" instead of "Option" and I couldn't boot to X.

Kristi (I regularly put the line

Option "NoLogo"

into xorg while I'm changing nv to nvidia. (put it on the next line.)

Link to comment
Share on other sites

Edit /etc/modprobe.preload and add a new line which contains nothing but the word 'nvidia', then reboot.


just worked for me :)


I also added alias char-major-195* nvidia in the /etc/modprobe.conf file but I don't know if it is necessary!?


in all the cases, add nvidia in the /etc/modprobe.preload, that resolved the problem for me.



Edited by theo
Link to comment
Share on other sites

I will try it tonight, the error message that I am getting is:


unable to load the nvidia kernel module.


Now what is strange be for I updated mandriva from 10.1 to LE it worked fine, I have since reinstalled 10.1 fresh with no update and I cant get the drivers to work at all now.


I might try an earlier nvidia driver.

Link to comment
Share on other sites

This is what I have tried tonight


Installed LE2005 again - fresh

Installed kernel-source-stripped-2.6-2.6.11-6Mmdk

SU -


telinit 3

sh NVID-xxxxxxxxxx.bin


Error: Unable to build the NVIDIA kernel module, stating to pull my hair out

Link to comment
Share on other sites

after installing all of the source files. I was able to install the drivers.

telinit 5

edit /etc/X11/XF68config

replace nv with nvidia


restart back to square one goes straight to command and says

Failed to initialize GLX extension (NVIDIA X driver not found

when trying to load x.

unable to find nvidia module


I have editied the modprobe.preload file but still no joy

Where would I find the nvidia module?

Link to comment
Share on other sites

now ready I hope.



after install 2005LE, you will be presented with a login.

login with root hit enter

enter password, hit enter.

type kde and hit enter.

This will bring you to a root kde session.


In a console (menu,system,terminals konsole check your source and kernel:

rpm -qa | grep kernel

mine look like:




If they are both the same, as above (kernel- you are clean - go to step 3.

Dirty system:

using MCC (menu,system,configure your computer

click remove software, search on the word source, and delete the stripped kern.

Go to /usr/src and delete folders linux and linux-2.6.1.blah... to actually get rid of it.

Quit the MCC software remover.


Click add software, search on the word source.

add the kernel source : kernel-source-2.6-2.6.11-6mdk it will ask for and read it off your CD or DVD


STEP 3. check:

in a console run

rpm -qa | grep kernel


if they are the same, copy the NVIDIA-Linux-x86-1.0-7167-pkg1.run to the root folder.


Log out of root.

X will not close so it looks wierd.

type ls (that's ell ess or LS in small letters) and hit enter. you should see your NVIDIA-Linux-x86-1.0-7167-pkg1.run there along with a bit of other junk.


sh NVIDIA-Linux-x86-1.0-7167-pkg1.run and hit enter

on the first question do left arrow and hit enter to accept.

Just whack enter on the next 2 questions, but note what they were for later post mortem.

It should then slowly build a module.

It should then slowly build another module.

It should then tell you Nvidia is installed.


cd /etc

vi modprobe.preload and make sure it has a line for nvidia-agp AND a line for nvidia.

esc :wq to save esc :q to just quit without saving.



ERROR ERROR ERROR edited by Kristi May 19 05

(THIS IS WRONG) vi initprobe and change the line from 3 to 5   so:       id:5:initdefault:


vi inittab and change the line from 3 to 5   so:       id:5:initdefault:

esc :wq to save


cd X11 this puts you in /etc/X11

vi xorg.conf

assure your mouse is correct ("4 5" not "6 7")

change nv to nvidia

esc :wq to save



reboot and hit enter.

Hopefully that will do it for you.



(uname -r will tell you what kern you are actually running in your system - the source you download MUST BE the same for Nvidia to compile. )

Edited by kristi
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...