Jump to content
Sign in to follow this  
Naim89

No MIDI sound [SOLVED]

Recommended Posts

Hi there,

 

I'm not sure this question goes under hardware or software but I'll ask it anyway.

 

I'm having trouble getting sounds to play in Rosegarden. MIDIs CAN play on my system, as Timidity++ works like a charm. However, when I try to create MIDIs in Rosegarden, I hear no sounds, even when the program is playing through the composition.

 

I am using an Intel sound card, Mandrake 10.1 under GNOME (with Rosegarden as a KDE app), Kernel 2.6.8.

 

Any ideas?

Edited by Naim89

Share this post


Link to post
Share on other sites

Followed the instructions provided in the link, with no success - JACK fails to start.

 

I've tried installing the multimedia kernel from rpmdrake, and I've gotten a little further, however I get this in the JACK message output:

 

16:04:19.968 Statistics reset.
16:04:20.042 MIDI connection graph change.
16:04:21.203 Startup script...
16:04:21.203 artsshell -q terminate
16:04:21.520 Startup script terminated with exit status=256.
16:04:21.521 JACK is starting...
16:04:21.521 /usr/bin/jackstart -R -dalsa -dhw:0 -r48000 -p1024 -n2
16:04:21.527 JACK was started with PID=32561 (0x7f31).
jackstart: cannot get realtime capabilities, current capabilities are:
          =ep cap_setpcap-ep
   probably running under a kernel with capabilities disabled,
   a suitable kernel would have printed something like "=eip"
16:04:21.531 JACK was stopped with exit status=1.
16:04:23.588 Could not connect to JACK server as client.

 

Any ideas?

Share this post


Link to post
Share on other sites
jackstart: cannot get realtime capabilities, current capabilities are:

          =ep cap_setpcap-ep

  probably running under a kernel with capabilities disabled,

  a suitable kernel would have printed something like "=eip"

 

You need to load the realtime module (modprobe realtime <option>) or run jack as root.

Share this post


Link to post
Share on other sites

modprobe realtime <option> returns the following:

 

[root@localhost naim]# modprobe realtime
FATAL: Module realtime not found.

 

Running JACK as root returns the following:

 

[root@localhost naim]# jack
This is  jack 3.0.0 (C) 2003  Arne Zellentin <zarne@users.sf.net>
*debug* global_cf: {}
*debug* user_cf: {}
*debug* argv_cf: {}
*debug* username is naim
*debug* hostname is localhost
*debug* mail is naim@localhost
*warning* charset has no effect without a char_filter
*debug* multi_mode:0
*info* maybe cdparanoia is not installed?
*error* could not read CD's TOC.

 

Running jackstart as root returns the following:

 

[root@localhost naim]# jackstart &
[1] 8622
[root@localhost naim]# jackstart: cannot get realtime capabilities, current capabilities are:
          =ep cap_setpcap-ep
   probably running under a kernel with capabilities disabled,
   a suitable kernel would have printed something like "=eip"


[1]+  Exit 1                  jackstart

 

:wall::wall::wall:

Share this post


Link to post
Share on other sites

hi...i got qjackctl but i have the same problem --> (

I'm having trouble getting sounds to play in Rosegarden. MIDIs CAN play on my system, as Timidity++ works like a charm. However, when I try to create MIDIs in Rosegarden, I hear no sounds, even when the program is playing through the composition
)

 

what should i change?? everything i did was unuseful...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...