Jump to content

External harddisk on MDK 10.1


Recommended Posts



I'm mandrake 10.1 official and I've a firewire external harddisk with 2 NTFS partitions. When I plug the harddisk, mandrake don't mount it but I do a "dmesg". It detects the partitions on sdb1 and sdb2.


I've tried to write a line in the fstab, but with this I can go on the disk.


I need help to write a line for a automatic mount (as with windows) or not automatic but I want the users can read data too, not only the root :

/dev/sdb1 ==> /mnt/hdext1 in readonly (ntfs) with access for the users (read)

and the same with /dev/sdb2 ==> /mnt/hdext2



Thanks and scuse me for the english



Link to comment
Share on other sites

First you need to be able to mount it 'normally'....

if it won't mount from the command line it won't from fstab...


I suggest

mount /dev/sda1 /mnt/hdext1 -o ro,user,no_root_squash -t ntfs


then if it works you need to make sure /mnt/hdext1 has permissions for a normal user to see it. as root

chmod 755 /mnt/hdext1

should do it... but do it unmounted then mount...




get back if this gives a prob...

if it works it can be used as the basis of the fstab line

Link to comment
Share on other sites

I've tried but no good result :

[root@sony pozzyx]# mount /dev/sdb1 /mnt/hdext1 -o ro,user,no_root_squash -t ntfs
mount: type de sys. de fichiers erroné, option erronée, super bloc erroné sur /dev/sdb1,
      ou trop de systèmes de fichiers montés

==== mount : filesystem type error, pareameter error, super bloc error on /dev/sdb1, or too many filesystem mounted.


After I tried :

[root@sony pozzyx]# mount /dev/sdb1 /mnt/hdext1 -o ro,user -t ntfs

That is ok but I don't can access to folder in user.

when I do :

[root@sony pozzyx]# chmod 755 /mnt/hdext1
chmod: modification des permissions de `/mnt/hdext1': Read-only file system

== chmod : changing permissions on /mnt/hdext1 : Read-only file system.


PS : My /mnt/ folder :

[root@sony pozzyx]# ls -la /mnt/
total 17
drwxr-xr-x   8 root   root  208 déc 15 12:29 ./
drwxr-xr-x  20 root   root  528 déc 24 11:38 ../
drwxr-xr-x   2 root   root   48 nov 24 19:25 cdrom/
dr-x------   1 root   root 4096 déc  9 12:36 hdext1/
drwxr-xr-x   2 root   root   48 déc 15 12:24 hdext2/
drwxr-xr-x   2 pozzyx root   48 déc  2 18:46 removable/
drwxrwxrwx   7 root   root 4096 jan  1  1970 transfert/
dr-xr-xr-x   1 root   root 8192 déc  9 12:22 windows/

The directory hdext2 as dr-x------ too when I mount the second partition.





Edited by PoZZyX
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...