Jump to content

error retrieving packages [solved]


Recommended Posts

Drake: For what it's worth, I have done the upgrade from 10.1CE to 10.1 Official, using urpmi, and it worked fine. Of course, I installed a clean 10.1 CE, then updated my urpmi sources, and did the upgrade, all without adding any additional software or tweaking any other settings.


Basically, make sure your urpmi mirrors are for 10.1 Official.


The next thing I did was run "urpmi urpmi" to make sure I had the latest & greates urpmi. (Probably not necessary, but what the heck. :) )


Then I just did "urpmi --auto-select", and let it run. When it was done, I had a 10.1 Official system. :)

Link to comment
Share on other sites

yup thanks :) im in the middle of getting the sources now (i made sure i removed my last lot). ill follow instructions to the letter and post here how it goes :)


:banana: so far so good..........! 3 sources downloaded


edit : just so as i get this right - ive done this :


1. installed a clean mdk 10.1 CE


2. signed up (didnt have to do this) to mandrakeonline so i get auto updates (eventually maybe)


3. downloading the sources from urpmi


4. urpmi uprmi (says everything is installed)


5. urpmi --auto-select

Edited by Drake
Link to comment
Share on other sites

wooo its downloading 320 packages now :-)


this will take some time, even on my 1meg connection......anything i do when this is complete? just reboot and carry on as nothing happened?



Link to comment
Share on other sites

..........and then i can look into which servers i will be using, spamming (err sorry) posting in the network section :)


everything went well :-)


rebooted and says i have mandrakelinux 10.1 woot :banana:


thanks everyone who helped



Edited by Drake
Link to comment
Share on other sites

Gowator, updating from CE to OE is fine.

It's between previous final/OE versions where you can have problems to upgrade to next CE/OE versions, since there they may change things in a big way, like 10.0 => 10.1 switching from xfree to xorg and from devfs to udev.


Drake, good to see you're doing ok. Welcome to this board.

Link to comment
Share on other sites

BTW, one thing you need to do after this kind of urpmi upgrade is to upgrade the kernel manually:


urpmi kernel-2.6


urpmi --auto-select doesn't currently update the kernel (though actually there's a change going through in Cooker right now which will mean that it does, in future).


The reason CE does not have update sources is, basically, that it doesn't need to. OE has separate update sources because the OE tree is frozen; the packages for 10.1OE were set in stone in December and will never change, the same set of packages will always form '10.1OE' and you'll always see that set of packages in the 10.1 directory. So updated packages have to go into a separate tree. This is not the case for CE. CE is never completely frozen; new packages can be, and are, added to the main tree, sometimes as security and bug fixes, sometimes as new feature additions. (This is the difference between CE and OE after OE has been released; CE changes from being a testing-ground for OE to being a slightly more dynamic distribution).


So the executive summary - bug / security fixes for CE are delivered straight into the main tree, negating the need for a dedicated updates source. If you want to continue running CE instead of OE, you should set up main and contrib sources and use urpmi --auto-select periodically to obtain updates.

Link to comment
Share on other sites

  • 1 month later...

THis is great info! Bad mirrors I assume. Followed chris' info below and got 10.1 to update!



i wonder if this problem happened to anybody else in 10.1 after the intial install while trying to get updates? i had the same thing happen to me. same error message, same scenerio. when i finally did get to the updates (more on that in a moment) i noticed there were updates for GURPMI & PERL-URPMI. so i'm thinking maybe it's a bug that the updates fix. after i got the upates installed, the problem stopped happening.


what i did.......... first, it seems alot of the mirrors that MDK supplies as default choices are either not up to date, or inaccessible. i'd suggest going to the Easy URPMI link i supplied above & trying the Proax mirrors from France. those mirrors have always been fast, reliable, & up to date (for me, at least). get all of the above sources i mentioned...... plf, contrib, main, updates, & jpackage. add them per the instructions at Easy URPMI. if you find you have trouble adding a mirror, then just add an update mirror for now & get the rest later.


after you have the sources added, go to Mandrake Control Center->software management & try the update function. if it errors out, try it several times. it worked intermittently for me at first. if you find you're still getting the error, then go to media manager & unselect all sources except for the install CD's & the update source. that's what finally did the trick for me.


get all of the updates available. if it tells you that you can't select a few packages, ignore them this time around & get what you can. that happened to me, also. coincidentally enough, 2 of the packages i couldn't install at first were the urpmi related ones. after you get the packages installed, reboot. if you get a GTK error when trying to quit MCC (or find that the "quit" button doesn't work), close it out with the X in the upper right corner. again, another glitch i ran into.


after you reboot, go back to the update section of MCC & search for updates again. get any that it might list. reboot again, then re-check the sources you disabled earlier, or re-add them via Easy URPMI if you couldn't add them the first time around.


let me know if it all worked out. and, again, i'd like to hear if anybody else ran into this problem.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...