Jump to content
Sign in to follow this  
PoZZyX

Internet Connection on Linux [SOLVED]

Recommended Posts

Hello,

 

I've got a D-Link router (in 192.168.1.1). When I'm on Windows, everything is OK. I can go on internet without problems. But on linux, when I type google.ch in a browser (Konqueror or Firefox or Lynx), I cannot reach the website. If I ping www.google.ch, there is a positive answer and after the ping I can go on google.ch. On windows, I don't need to ping anything, everything is OK. But on linux, I can use AMSN, but the mail doesn't work either.

 

Thanks a lot.

 

PoZZyX

 

PS : I've tried with another routeur and everything is ok with linux and windows.

Share this post


Link to post
Share on other sites

hehe... i also have one of those bloody d-link routers. the problem you are experiencing is due to a ipv6 problem with the 2.6.x kernel (or with the firmware that is shitty. whatever you prefer..).

here are some tips:

log into your system as root. now, some basic things you could try are:

edit your /etc/sysconfig/network file and add the following line:

NETWORKING_IPV6=0

and edit your /etc/sysctl.conf file. add a line at the ipv-section:

net.ipv4.tcp_window_scaling=0

and: edit /etc/modprobe.conf so that you have these entries in it:

alias net-pf-10 off
alias ipv6 off

if that does not help, install "pump" and "dnsmasq" and reboot your system. (if you want to do it with urpmi, est some valid dns-entries in your /etc/resolv.conf and save the file, then ping via terminal your mirror. then start the urpmi command. this should temporarily "disable" the ipv6 problem).

 

then, as a last desperate attempt, you can lock your /etc/resolv.conf in case it gets changed automatically. type in a terminal as root

chattr +i /etc/resolv.conf

and not even root will be able to change the file-content! do not forget to add valid dns-values first!!! (you should google for some dns-servers (either ping the site or do it in windows) before changing the above mentioned file)

 

you could also stop your resolv.conf from being changed by modifying your /etc/dh-client file (if you have one), but do not ask me to what it needs to be changed. i am no coder ;)

 

good luck :)

Edited by arctic

Share this post


Link to post
Share on other sites

thank you so much, after making those changes (the first 3 steps) and rebooting i can surf without a problem on the internet, now lets see if everything works

but anyway, you're very good ;)

Share this post


Link to post
Share on other sites
thank you so much, after making those changes (the first 3 steps) and rebooting i can surf without a problem on the internet, now lets see if everything works

but anyway, you're very good ;)

nice to hear that it worked :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...