Jump to content
knightmb

No Automatic Mouse Detection in Mandrake 10.1

Recommended Posts

Hi All,

 

Backupground on problem:

 

I had Mandrake 10.1 Community release installed for the last month, everything worked fine. I upgraded to 10.1 Offical Release and everything works fine except the Mouse.

 

When KDE starts up, I see the mouse cursor but have no control over it. I tested the mouse on another system, it works fine so I know it isn't hardware related. If I log in to the system and run "mousedrake" from the console and select the "Any PS/2 & USB mice" then everything works fine. Everything for the mouse breaks if I reboot the system as though it's not detected during startup. My mouse is a PS/2 and has worked fine for a long time. I've searched through the forums here and on google but have found plenty of "I fixed my mouse problem" topics that don't explain how they fixed it, LOL.

 

Any help would be greatly appreciated!

 

Thanks.

Edited by knightmb

Share this post


Link to post
Share on other sites

Try opening Mandrake Control Centre and doing your Mouse setting from there. Doing it from within it should save the settings. I think that is what the problem is, the setting is not being saved.

 

Cheers. John.

Share this post


Link to post
Share on other sites

I gave this a try, still doesn't seem to be saving the settings. If I log into KDE and go through either the control panel or the console I can get the mouse auto-detected, but another reboot and the system forgets I have a mouse. Is there anyway to manually set the mouse somewhere? It's just a generic PS/2 mouse with the wheel roller, that's what is detected when I run auto-detection through the control panel or the console using "mousedrake".

Share this post


Link to post
Share on other sites
Guest Labonte

haveing the same problem here,

 

no mouse but i see the mouse pointer...

 

anyone know how to fix this, as i cant go any where i Gnome or is there any keyboard shotcuts that i can try to for example navigateing on the startmeny?

 

/Daniel

Share this post


Link to post
Share on other sites

laborite: 'alt-f2' will get you to a 'run program' dialogue box. type 'gnome-terminal' to open a terminal then you can run 'mousedrake' from there.

Share this post


Link to post
Share on other sites

Well I thought I would do an update to this topic.

 

I never could figure why Mandrake 10.1 Offical would forget my mouse every reboot. I didn't have anything on the server I couldn't backup, so I did a fresh install of Mandrake 10.1 Offical and everything works, almost better than before.

 

I think my problem was upgrading from 10.1 Community to 10.1 Offical, something in the upgrade process may have been my problem.

 

Cheers!!

Share this post


Link to post
Share on other sites

if anybody is still having the mouse problem, try editing the "InputDevice" section of xorg.conf. it seems udev doesn't like the old /dev/mouse path on some set ups, for some reason. here's an example of mine using a ps2 scroll wheel mouse...........

 

Section "InputDevice"

    Identifier "Mouse1"

    Driver "mouse"

    Option "Protocol" "ExplorerPS/2"

    Option "Device" "/dev/input/mice"

    Option "ZAxisMapping" "6 7"

EndSection

 

if your entry for "Device" read /dev/mouse try changing to the above.

 

Chris

Share this post


Link to post
Share on other sites
Guest Nicholas Vrtis

I just got 10.1 for Christmas, and had a similar problem. I knew the mouse was working, because it worked fine during the installation, and the system had been running 9.0 just prior.

 

I did a complete reformat and restall.. not an upgrade from 9.0.

 

After doing some experiments and poking around, I noticed that if I set the security level to "higher", the mouse would not work after the install. If I left the security level at the default "standard", the mouse worked after the install.

 

I looked that the X logs, and noticed that the open failed for the mouse when I had the system at "higher"... I tried mousedrake, but that didn't change anything. It didn't even start the mouse working. After doing some more poking around, I figured out that for some reason, /dev/input/mice (actually, /dev/input/) never got created with the higher security setting, but did when it was standard.

 

I tried opening an incident with mandrakeexpert, but got the standard "apply all the patches and call me in the morning"... so, I bumped the security level down for the time being.

 

Nick

Share this post


Link to post
Share on other sites
Guest jjoliver

Thanks for the guidance here - it solved my problem:

 

Mandrake 10.1 and the mouse worked fine during install and then would not work with KDE afterwards. I could get it working through the control center but the setting was always forgotten. Security level is set to "higher".

 

Changing the xorg.conf file to:

Option "Device" "/dev/input/mice"

as suggested by chris z worked a treat!

 

Thanks

 

:juggle:

Share this post


Link to post
Share on other sites
Guest mrvnmrtn

I had the exact same symptoms, installed 10.1 from scratch with high security, no mouse on bootup, but the mouse would work fine when configured with drakconf/mousedrak. Modifying /etc/X11/xorg.conf did not solve my situation. Turned out that udev was not running so the device files weren't being created. chkconfig --add udev solved that.

Share this post


Link to post
Share on other sites
Guest bobn9lvu

Try changing the /etc/X11/XF86Config file in the device section for the mouse;

 

Option "Device" "/dev/mouse"

 

to

 

Option "Device" "/dev/psaux"

 

 

It seems there is no /dev/mouse directory....

 

Bob :wall:

Share this post


Link to post
Share on other sites
Guest Outerarm

Hi,

 

Had exactly the same issue -- mouse was fine on install screens with 'highest' security level selected, but didn't work once the system was booted. As suggested, opening up a console window, su'ing to root and typing:

 

chkconfig --add udev

solved the problem on next reboot.

 

Cheers,

Ian,

Share this post


Link to post
Share on other sites
Guest mtcerio
Section "InputDevice"

    Identifier "Mouse1"

    Driver "mouse"

    Option "Protocol" "ExplorerPS/2"

    Option "Device" "/dev/input/mice"

    Option "ZAxisMapping" "6 7"

EndSection

 

It worked for me on mdk 10.1! Thank you very much!

 

Matteo

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...