Jump to content

can't burn CDs - cdrecord problem [SOLVED]


Recommended Posts

Hi all,


I've a big problem with my burner; i can't burn at all even when i'm root (with k3b, xcdroast .......).


When i do a cdrecord scanbus my burner is not recognised and at his place i've my SATA HD.


       0,0,0     0) 'ATA     ' 'WDC WD1600JD-00H' '08.0' Disk
       0,1,0     1) *
       0,2,0     2) *
       0,3,0     3) *
       0,4,0     4) *
       0,5,0     5) *
       0,6,0     6) *
       0,7,0     7) *


The problem is that i'm able to read CDs and used to burn with previous version of mandrake (9,10).


k3b's log :


scsidev: '/dev/hdc'
devname: '/dev/hdc'
scsibus: -2 target: -2 lun: -2
Warning: Open by 'devname' is unintentional and not supported.
Linux sg driver version: 3.5.27
/usr/bin/cdrecord: Warning: using inofficial libscg transport code version (warly-Mandrakelinux-scsi-linux-sg '@(#)scsi-linux-sg.c 1.83 04/05/20 Copyright 1997 J. Schilling').
SCSI buffer size: 64512
/usr/bin/cdrecord: Warning: controller returns wrong size for CD capabilities page.
/usr/bin/cdrecord: Warning: controller returns wrong size for CD capabilities page.
/usr/bin/cdrecord: Warning: controller returns wrong size for CD capabilities page.
/usr/bin/cdrecord: Sorry, no CD/DVD-Recorder or unsupported CD/DVD-Recorder found on this target.
/usr/bin/cdrecord: Warning: controller returns wrong size for CD capabilities page.
Cdrecord-Clone 2.01-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004 Jörg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to <warly@mandrakesoft.com>.
Note: The author of cdrecord should not be bothered with problems in this version.
TOC Type: 1 = CD-ROM
Using libscg version 'schily-0.8'.
Driveropts: 'burnfree'
atapi: 1
Device type    : Removable CD-ROM
Version        : 0
Response Format: 2
Capabilities   : 
Vendor_info    : 'SONY    '
Identifikation : 'CD-RW  CRX320E  '
Revision       : 'NYK1'
Device seems to be: Generic CD-ROM.
Using generic SCSI-2       CD-ROM driver (scsi2_cd).
Driver flags   : 
Supported modes: 
FIFO size      : 4194304 = 4096 KB
/usr/bin/cdrecord: Drive does not support TAO recording.
/usr/bin/cdrecord: Illegal write mode for this drive.


My kernel is the, may i upgrade ?

What i'm doing wrong ?? How can i burn :help:


Link to comment
Share on other sites

is your burner really scsi? it seems from the log that's what it's saying, but more than likely it's ide. try running K3B setup & let it re-detect your drives. k3b->tools->k3b setup.



Edited by chris z
Link to comment
Share on other sites

My burner is IDE.


When i launch the k3bsetup it finds my burner but i can't burn and get these errors.

I've forgotten that when it fails i get this message "mkisofs didn't exit normally" "unknow error 255' maybe it won't be really helpfull ...


You've said that cdrecord is looking for an scsi drive . Where to change this ? How can i let it know it's an IDE drive ? Is there any config files to change ?



Link to comment
Share on other sites

Guest messenger7

I have just finished an AMD64 3500 2.4 /1g ram. It will read CDs but gives me a file size error. It says not enough room and gives me the total of the files. These are good cds, I've used hundreds of them and packed them full and can burn them in 2.5 minutes with XP, same files. It has to be something simple because the 10.1 is a KILLER in every other aspect.

Link to comment
Share on other sites

I've finally solved my problem.

I think it's a specific problem to my burner : Sony CRX320E (bulk version of the CRX320A). I don't know why MDK didn't recognise it as a burner ...


I've just updated the firware of my burner from NYK1 to NYK5 available on this page (http://sony.storagesupport.com/cdrw/crx320adwn.htm).


And now all work perfectly, my burner is recognised :D

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...