Jump to content

Directory "/" has no space available


Recommended Posts

Hello all,


I'm having a problem. I have no free space on my / directory (/var specifically), though the partition has a total of 5.8GB available to it. After checking the properties of each folder within /var, I found that no more than 500MB are being used. Where is the other 5.3GB? This problem is preventing me from starting the X server, and preventing anybody from seeing my website (the linux server is my webserver). Any help is appreciated, thanks!


(I've cleared all tmp folders and buffers as well)

Link to comment
Share on other sites

I had this happen to me once. I was working with some video files and had accidentally written to my / partition instead of my /mnt/Video partition (30 GB) What I ended up doing was clearing a few hundred kilobytes from my / partition, then executing this:


du -b / > usage.txt


This gave me a file containing the size of every single file on my root partition. Then I wrote a simple C program to check the size of each file from usage.txt, looking for a file that is abnormally large. I think I set the limit to > 1GB.


Good luck!

Link to comment
Share on other sites

Are you able to obtain or burn a copy of Knoppix or any other LIVE-CD.

With it you can access every folder on every partition and sub partition and see where the huge occupying data is located and if necessary delete it.


Below is a copy of a post I made a while ago and it shows how things can get screwed up but using a LiveCD can save the day :-.................................."


Hello Chrism.

I tried that urpmi from 10.1-CE to OE on three occassions and despite the very best of care, I always ended up with an unreliable and grossly unstable, often freezing. Totally unusable.


On the other hand I reinstalled Mandrake10-OE and did the urpmi to mandrake10.1-OE. The first time I tried this approach I selected ALL the appropriate updates for everything already installed in 10-OE in one big hit and after 2 days and nights of stop start mayhem it was still too unreliable.

So I restarted from scratch doing 10-OE again then urpmi but doing it sections at a time and then when it showed signs of not progressing properly, it was necessary to fully reboot twice in row each time before things were stable enough to proceed with more downloads until it was finally all done.

Everything seemed to be finally completed and working okay then suddenly I could not log in because it said that ../ ... was full. What with a 5Gb partition and only 2.4Gb of programs ???

Got out the PCLinuxOS Live CD and went into find out why. By checking through every part of the root partitions I found in /usr/lib that a folder for Open Office had 2.2Gb of data in it (yes that figure is correct) and when I opened it I found masses of core dumps totalling nearly 2GB and the complete OpenOffice program there as well.


Using PCLinuxOS as root I deleted all the dumps. Rebooted into my OS again and did an MCC un-install process of Open Office and the went back to /usr/lib and deleted the OpenOffice folder. During this whole upgrade process, somehow it had managed to install OpenOffice or a repeat of it into /usr/lib and because it was perpetually trying to start up and failing it was making these core dumps constantly.


What I am working from at this moment is the upgrade which also took nearly all of my waking hours of two days. It now appears to be quite stable and pretty fast.

Thank god for small mercies.


It was a learning experience alright but would I do it again.

Absolutely not. What I did learn was not justified by the time spent learning it.


I am waiting for my 4 CDROM set of Mandrake10.1-OE to see if it verifys my present setup.


Would I encourage anyone else to try this idea ??? No way. It simply IS NOT worth the effort no matter how good I now know urpmi to be. ...................."





I have a second Linux setup and I am able to achieve the same thing, but of course not many people have a second Linux OS.



I hope this helps in some way or at least inspires.

Cheers. John.

Link to comment
Share on other sites

Thanks for all the help! I ended up running the

du -b / > usage.txt

command from a knoppix startup (easier to see what the file had through kwrite) and found that my dang root trash directory had over 3 gigs in it! Don't ask how that much info got there...because I have no idea! But anyway, I then rebooted to root, deleted the trash contents and X server started up fine. Now I just need to re-install the postgresql and httpd2 services (they somehow got deleted...) and my website should work fine again! Wish me luck! :D


I'll post my findings tomorrow

Edited by ShineDesign
Link to comment
Share on other sites

Ok, well, it seems as though it's not as easy as just reinstalling httpd2 and postgresql. For one, postgresql (even after reinstall) is asking for a password even when I log in through root...and since I've never set a password...it won't let me in. (even if I just press enter, to accept no password). And I can't see how it's possible to reinstall just httpd2...any ideas?


I only need these two services to be running again! bleh...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...