Jump to content

Firefox + Java problem


Recommended Posts

I installed Firefox 0.10 to play around, see what the hype is about and hopefully find out if would work better with some sites that Opera doesn't. Hate having to use Internet Excuse...anyway, so far I've:


Installed firefox-0.10-0.1.0.rh7.dag (RH 7.3 rpm) went fine, no problem at all.


Installed j2re-1.4.2_05 (alongside j2re-1.3.1_02, used by Opera 7.50), from j2re-1_4_2_05-linux-i586.rpm, downloaded from Sun's website.


created a symlink in /usr/lib/firefox/plugins (and just to be sure and for other uses, also in /usr/lib/mozilla/plugins and /usr/lib/netscape/plugins) with the command:


#ln -s /usr/java/j2re1.4.2_05/plugin/i386/ns610-gcc32/libjavaplugin_oji.so


I saw the warnings about j2re-1.4.2 needing libgcc_s.so.1, and it is installed, in /lib/libgcc_s.so.1, from the package libgcc3.0.


Everything seems right. But loading a java applet from any site still crashes Firefox. Bummer, 'cause while it's still lacking some things in Opera, Firefox does show some promise. I could get used to it if it works with certain sites, but I gotta have java going to find out.

BTW, this is on my main Mdk 8.2 box. Anyone got any idea where to go from here? I'm stumped again...the only thing I can think of is that maybe the installed libgcc_s.so.1 is too old a version??

Link to comment
Share on other sites

3 things.............


if you had an old Java plugin in the firefox/plugins directory, did you delete it before adding the new one? you can't have 2 Java plugins at the same time.


did you symlink the plugin with Firefox closed (not running)? if you do it with Firefox or Moz running, it will cause them to crash on Java applets.


if none of those apply, try removing the older version of Java, remove the plugins from all browsers, & set them all back up using the new Java. it could be a conflict somewhere because 2 versions are installed. i use Opera & Java 1.4.2-05 & it works fine. that version of Java you have for Opera is way old, so it might behoove you update it.



Link to comment
Share on other sites

Thanks for the answer...


1. No, no old java plugins in /us/lib/firefox/plugins, /usr/lib/mozilla/plugins or /usr/lib/netscape/plugins.


2. I thought you might have something there. I couldn't remember for sure, but it was a definite possibility that I did have Firefox open when I created the symlinks. So I deleted and re-created them. No good.


3. It should be quite possible to have more than one java installed. I do even on Windoze boxes. Anyway, I don't want to remove j2re1.3.1 yet 'cause Opera's using it and it works fine. 'Til I sort out Firefox at least, I still need Opera fully functional.


Also, and this is kinda strange, if I open Opera's preferences and try to set the java pathway to: usr/lib/firefox/plugins or /usr/lib/netscape/plugins, directories where I made the symlinks, then click the "Validate Java path" button, i get an error: "Could not find a valid Java installation. Enter another directory and try again." In fact, I can't find any path it likes.


So, the obvious question is, what pathway are you using for j2re-1.4.2_05 with Opera? I want to see if I can get Opera to use j2re1.4.2. I have the feeling something isn't right with the new java installation, not with Firefox.

Link to comment
Share on other sites

the path i have for Java in Opera is.............




works every time, for all versions of Java i've tried. i never had it search in any plugin directory, or elsewhere.



Link to comment
Share on other sites

That pathway worked! Thanks! A check at:




confirmed Opera is now running j2re-1.4.2_05 instead of j2re-1.3.1 with no problems. So the new Java install itself *seems* OK, and I went ahead and removed the old version since nothing was using it anymore.


I'm getting a little closer...but I still can't get Firefox going with it...

I still have a funny feeling it's because even though Java j2re-1.4.2 itself runs OK, the *plugin* used by Firefox I created symlinks to will not, probably due to the requirement for 'libgcc_s.so.1', which though it is installed, my installed version might be too old, like I said in my 1st post in this thread.


For grins and to kinda sort this out, I downloaded 'libgcc1-3.2-1mdk.i586.rpm' to get a version of 'libgcc_s.so.1" compiled with gcc3.2 instead of gcc3.0 like mine, and ran a test install. Sure enough, it stopped at:


# rpm -ivh --test libgcc1-3.2-1mdk.i586.rpm

Preparing... ########################################### [100%]

file /lib/libgcc_s.so.1 from install of libgcc1-3.2-1mdk conflicts with file from package libgcc3.0-3.0.4-2mdk


I didn't think it a bright thing to do to try and force that. I might try extracting it from the rpm and do a rename-the-old-file-add-new and see what, if anythng, breaks. If nothing does, I think maybe that would fix it. Possible?? :unsure:


Somehow, this all seems like it shouldn't be necessary...I mean, I installed a rpm of the newest Firefox version, but for RH 7.3, which also has gcc3.0 instead of gcc3.2. So how did they get it tested and all working with j2re-1.4.2 on a RH 7.3 machine? :wall:

Edited by Crashdamage
Link to comment
Share on other sites


Nah, nice try, but that won't work. Firefox 0.10 is compiled with gcc3.2 and so has to have a gcc3.2-compatible plug-in. So it must be linked to /ns610-gcc32.


Jeez...I don't know what I was thinking before, trying to aim Opera at the plugin directory. Opera wants a directory location for an *executable* - Firefox wants a link to a *plugin*. Ahhrgg - too tired, I guess, or maybe just plain stupid. Anyway, it sure would be nice if Firefox worked this like Opera. Seems much more straightforward to me to just run the Java executable.

Link to comment
Share on other sites

  • 4 months later...

I managed to get this working last week with Firefox.


I'm using the jre1.5 etc version. How I got it working was as follows:


1. sh - jre1.5.....rpm.bin (this extracts and installs).

2. Go into remove and find the jre option listed and select and remove.

3. Find the rpm (not rpm.bin) and install this.

4. Do the ln -s to the lib in the ns7 directory under the created usr/java/jre...etc directory.


Then run Firefox, and ensure that in the Preferences that Use Java is selected, and away you go.

Link to comment
Share on other sites

Let me add the paths and filenames that I had after downloading.


Website www.java.com

File downloaded jre-1_5_0_01-linux-i586.rpm.bin

sh jre-1_5_0_01-linux-i586.rpm.bin


Remove (I used KDE System/Configuration/Packaging/Remove Software) list alphabetically and remove the jre installed option.


Find the jre-1_5_0_01-linux-i586.rpm file and double click this (or run the CLI option if you prefer - I'm new to this so I just use the GUI for now). It will install again (you cannot install over the top if it's already there).


It should install to usr/java/jre1.5.0_01


Sit yourself in your firefox/plugins directory and type


ln -s /usr/java/jre1.5.0_01/plugin/i386/ns7/libjavaplugin_oji.so


If you type ll after you've typed it, you should see the link itself, and where it's pointing to. When you then lauch Firefox, go into Preferences and Web Settings and ensure Enable Java is selected, close and rerun Firefox, it'll be working fine.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...