Jump to content
Sign in to follow this  
Lowe

Kanji?

Recommended Posts

Hey,

 

I don't know if this is the right forum, but i will ask anyway. Is their anyway to get mandrake to read kanji? a lot of my music etc are tagged in kanji, and it's a bit of a pain not being able to see it. Could you posibly link me to the packages or whatever.

 

Thanks

Share this post


Link to post
Share on other sites

Use urpmi to get the following:

 

FreeWnn

im-ja

kon2

VFlib (probably)

 

Doing it via urpmi will, of course, take care of the deps as well.

 

There may be others but you definitely need these ones

Share this post


Link to post
Share on other sites

No real help here but I tend to install every language font I can just to make sure every web page I run across loads correctly. And boy does it make the net a better place. I might not be able to read the page the formating is way better. And no more stupid little squares.

Share this post


Link to post
Share on other sites

If you just want to be able to see kanji in a file list, installing the Japanese language package should be all you need to do (I think). If you want to be able to input kanji, it gets a little more complex... you can install the packages that nocturne mentioned (which are more of a 9.x solution), or use packages called XIM, anthy, and SCIM (which are what came with 10). You'll also need to switch locales, I think.

 

Or you can do what I'm doing... wait for 10.1. 10.1 will be using SCIM fully, and you won't have to switch locales or anything. 10.1 will have a lot of advances for those of us who use Asian characters.

Share this post


Link to post
Share on other sites

I installed the package nocturnes mentioned, but still no joy, can't even view webpages with kanji. :(

 

EDIT: ok i can now see it in webpages, but i still can't see it on files.

Edited by Lowe

Share this post


Link to post
Share on other sites
Come on, someone must know.

 

Did you get any further?

 

What do you mean by saying you can't see kanji on the files? If you mean, you can't read the file names, on what kind of file-system are the files? If it's a windows partitions, you probably have to tell mandrake the right encoding for it. It's done in /etc/fstab. My entry is

 

/dev/hda1 /mnt/windows ntfs noauto,iocharset=utf8,ro,umask=0 0 0

 

it's the iocharset part that matters. Some applications need to be told to use the right font before they can display kanji. Xmms is like this - you'll have to try which font works.

Share this post


Link to post
Share on other sites

Yes it's a windows partiton i copied your fstab bit noauto,iocharset=utf8,ro,umask=0 0 0.

But i still don't see my files that are in kanji (filenames ,they just don't show the files at all not even with squilly squares) i don't even know if i have those fonts.

 

EDIT: could you post a link to those fonts ^_~

Edited by Lowe

Share this post


Link to post
Share on other sites

I don't think im ever going to get this right. Anyway i read somewhere i need to change my /etc/sysconfig/i18n/

 

Here is what it currently contains.

 

SYSFONTACM=iso15

LANGUAGE=en_GB:en

LC_ADDRESS=en_GB

LC_COLLATE=en_GB

LC_NAME=en_GB

LC_NUMERIC=en_GB

LC_MEASUREMENT=en_GB

LC_TIME=en_GB

LANG=en_GB

LC_IDENTIFICATION=en_GB

LC_MESSAGES=en_GB

LC_CTYPE=en_GB

LC_TELEPHONE=en_GB

LC_MONETARY=en_GB

LC_PAPER=en_GB

SYSFONT=lat0-16

 

Any idea what to change? if im supposed to change it that is.

Share this post


Link to post
Share on other sites

Here's mine... try changing some of the settings to what I have, and see if it works. Be sure to reboot after you change any of these settings.

 

LANGUAGE=en_US

GTK_IM_MODULE=uim-anthy

LC_ADDRESS=en_US

LC_COLLATE=ja_JP

XIM=uim-anthy

LC_NAME=en_US

LC_NUMERIC=en_US

LC_MEASUREMENT=en_US

LC_TIME=ja_JP

LANG=ja_JP

LC_IDENTIFICATION=en_US

LC_MESSAGES=ja_JP

LC_CTYPE=ja_JP

LC_TELEPHONE=en_US

ENC=eucj

LC_MONETARY=en_US

XIM_PROGRAM=uim-xim

LC_PAPER=en_US

XMODIFIERS="@im=uim-anthy"

 

Marc...

Share this post


Link to post
Share on other sites

Thanks for your help, im getting a bit closer now. I actually think it's a font problem now, hopefully you will be able to tell. I made those changes and i can now see the directorys that normally wouldn't show up at all, but they show up with Squares etc which you can see in the attached pic.

Here is my new /etc/sysconfig/i18n/

 

SYSFONTACM=iso15

LANGUAGE=en_GB:en

LC_ADDRESS=en_GB

LC_COLLATE=ja_JP

LC_NAME=en_GB

LC_NUMERIC=en_GB

LC_MEASUREMENT=en_GB

LC_TIME=en_GB

LANG=ja_JP

LC_IDENTIFICATION=en_GB

LC_MESSAGES=ja_JP

LC_CTYPE=ja_JP

LC_TELEPHONE=en_GB

LC_MONETARY=en_GB

LC_PAPER=en_GB

SYSFONT=lat0-16

post-6369-1094611198_thumb.jpg

Share this post


Link to post
Share on other sites

try replacing the ja_JP with ja_JP.UTF-8

 

Also, instead of modifying the /etc/sysconfig/i18n, you can copy the file to ~/.i18n (hidden file). This way, you don't have to mess with system wide settings and the changes to ~/.i18n take effect once you log out and in again instead of having to reboot.

 

If this doesn't work, try modifying the /etc/fstab entry. Maybe

iocharset=iso-2022-jp instead of iocharset=utf8 will do. Or maybe it has to be

iocharset=iso2022jp (not sure).

Edited by paleo

Share this post


Link to post
Share on other sites

Uhm before i do that i think it's about time i told you what fonts i have installed.

Name: fonts-ttf-japanese

Thats the only japanese fonts i have, do i need more?

Share this post


Link to post
Share on other sites

that should be enough. If you have a windows installation, you can grab windows fonts as well. Just drop msgothic.ttc and msmincho.ttc into your /usr/share/fonts/ttf/japanese

and then run

fc-cache -fv

(as root) and the fonts will be available.

 

Have you tried typing in Japanese? That is, try create a new file with a Japanese name? If you can save the file and its name displays correctly, then it should be possible to convince your setup to show Japanese file names correctly even if they sit on a windows partition.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...