Jump to content
  • Announcements

    • spinynorman

      Mandriva Official Documentation

      Official documentation for extant versions of Mandriva can be found at doc.mandriva.com.   Documentation for the latest release may take some time to appear there. You can install all the manuals from the main repository if you have Mandriva installed - files are prefixed mandriva-doc.
    • paul

      Forum software upgrade   10/29/17

      So you may have noticed the forum software has upgraded !!!
      A few things that have changed. We no longer have community blogs (was never really used) We no longer have a portal page.
      We can discuss this, and decide whether it is needed (It costs money) See this thread: Here
Sign in to follow this  
furfurdemon666

HW-03: Lucent Winmodem drivers mdk10 Kernel 2.6

Recommended Posts

Browse: [About the FAQ Forum] [Table of Contents] [FAQs] [Contribute] [HW: Hardware, drivers...]

 

HW-03: Lucent Winmodem drivers mdk10 Kernel 2.6

 

Some of you may use a Lucent Winmodem like I do with Mandrake. When I used Mandrake 9.2 I would just grab an RPM for Kernel 2.4 here or here and they installed with ease.

 

However, when I installed Mandrake 10 Official with Kernel 2.6.3.7mdk, I couldn't find any RPMs that worked with a 2.6 kernel! I finally found this page which had source I could use here. But as a newbie, how could I do it? I had compiled programs from source before, but this wasn't working! I would receive an error when I tried to compile. So I asked for help and received some excellent advice which I followed and found to work without problems! Hooray! Thanks to Tormented's post in this thread on linuxquestions.org (from which I will now quote), here are the step by step instructions:

 

Downloading

 

Get this file before you begin, it's what you'll compile using the instructions below. I copied it into /root/ and it compiled correctly, otherwise in other directories it gave an error. Of course you need to extract the contents of the file before you begin. :)

 

** Quote begin: **

 

1. Make sure you have the kernel-source rpm installed.

 

2. Edit the modem driver's Makefile and change:

 

KERNEL_DIR := /usr/src/linux-2.6/

to

KERNEL_DIR := /usr/src/linux/

 

3. Become root and type make.

 

4. Type the following commands:

 

mkdir /lib/modules/`uname -r`/other
cp -v *.ko /lib/modules/`uname -r`/other
mknod --mode=0640 /dev/ttyLT0 b 62 64
depmod -a
modprobe ltserial
ln -vs /dev/ttySLT0 /dev/modem

 

5. Add these lines to /etc/modprobe.conf

 

install winmodem /sbin/modprobe ltserial
alias /dev/modem ltserial
alias char-major-62 ltserial
alias /dev/tts/LT0 ltserial[/color]

 

6. Add this to the end of /etc/modprobe.preload

 

winmodem

 

** Quote End **

 

After all the above I rebooted my system (even though I may not have needed to, I did it anyway) and installed KPPP. When I ran KPPP my modem was found without any problems. I hope this helps some of you Lucent Winmodem users who may be having trouble getting yours to work with Mdk10 and Kernel 2.6.

Edited by Tuxiscool

Share this post


Link to post
Share on other sites
Sign in to follow this  

×