Jump to content

Mandrake 10.0 ****** up my HD


Recommended Posts

  • 1 month later...
  • Replies 82
  • Created
  • Last Reply

Top Posters In This Topic

Yep - definately Mandrake 10. I have the exact same condition on totally different hardware. Neither Lilo or Grub would boot. Have lost everything but only through stupidity.


Your mandrake 10 should still work and can be used to acess your data NTFS or FAT32 to back up. Will lose all your windows install though unless your are smarter than me, might not be hard.


Still don't have the dual boot working. last time I used mandrake 8 and formatted with partition magic.

Link to comment
Share on other sites

  • 5 months later...

The saga continues…


I also have problems with mandrake 10.0 and win2K/xp. Some time ago I had 1 hard drive(seagate40Gb) with windows partition. So I formatted the drive create 1(20Gb) windows(2K) partition and left the other 20Gb free and unformatted for linux installation. And the nightmare begin. Man 10.0 changed something in my partition table and win was unable to boot (I had the “Couldn’t load operating system” error). So I made fixmbr and fixboot but that wasn’t enough! After completely formatting the hard drive windows gave me the same error. I was frustrated. But Mandrake worked perfectly. But I was unable to install any windows, I tried 98, 98IIIed., 98ME, 2000Prof, Xp Prof. But all of the gave me this “Couldn’t load operating system” error. I was confused. But then I looked into my BIOS and saw something strange. Parameters of my hard drive (number of cylinders, sectors and everything) has been something completely different from the hard drive producers info. I thought that lilo or grub (tried them both) messed up with them. So I changed into manual and set the parameters correctly. After this I was able to install windows, but Man couldn’t run J. So I re installed Man and the windows couldn’t load J The funny thing is that windows automatically during installation changes my Hard drive BIOS info, and so does windows. So I tried to install lilo/grub on a floppy drive rather then on my hard disk. Everything worked (I mean windows) until I run lilo/grub, then my setting change and windows is unable to load. So both myself another hard drive. Just to have windows on one and Mandrake on the other. A then “The saga continues”. There’s no difference where I install grub/lilo is the first drive the second or the flopp. (when I install it on the second drive and the set is as a Master then it also goes to BIOS changes the configuration of my second drive so if I even change the first drive(with win2K) into master again and try to boot form it I get my usual “Couldn’t load operating system” error. So I’m in a coma here. What to do to run both win2K/XP and Mandrake?!? I am using a MSI K7N2 –Delta Motherboard and my first hard drive is a Seagate 40Gb and the second one is a WD Caviar 80Gb. The only solution I can think of is flashing my BIOS but that’s the last thing I want to do. The fun thing is that both Man and Win change my HD BIOS setting to some weird numbers that doesn’t match the HD manufacturers specifications. Another weird thing that I can change those setting(like nr of sectors or cylinders, and so on) only in CHS mode, in Auto or LBA I can’t change anything. Any of those auto setting don’t give the right parameters of my drive. So when I install windows it changes my setting to “weird setting 1” and runs on those with no problems and Mandrake during install and booting changes my setting to “weird setting 2”. But to cancel the “Couldn’t load operating system” error I have to change my HD parameters manually in CHS mode to those given by the manufacturer and the and only the win runs.


I still haven’t tried other Linux dist. But I’m new with Linux and like to continue using the Man 10.0. If anybody need’s any more info about my PC configuration I’ll be more then happy to answer if it will help me run both operating systems.


I’m no specialist on HD or BIOS issues all those info comes from my experience(it took me some time, and You can believe me it wasn’t easy ), so there might be an error in my thinking process. If so please correct me, I’ll be more than happy to learn something new.


Please excuse my weak English :thanks:

Link to comment
Share on other sites

The only thing I can think of is get the seagate hard drive utilities from their website and thoroughly check the drive. If it checks out OK, back up any data you want to save and do a zero fill, sometimes called a low level format, using the seagate utilities, set it to lba and see if the problem persists. In particular, see if you still get the incorrect readings on the hard drive geometry in the bios after a zero fill. If your consistently getting erroneous readings on the drive from the bios, there's either something wrong with the bios or the hard drive. Windows and linux are handling these errors in different ways as they partition and write the bootloader to the mbr causing one to not work with the other's hacks around the problem.

Link to comment
Share on other sites

this was the common problem that was mostly reported on fedora but actually affected all linux distros, wasn't it? If I remember correctly, the best fix was not to set everything manually in the BIOS but set it to LBA mode, should make Windows and Linux both work. This is just vaguely remembered stuff though.

Link to comment
Share on other sites

But like I said the problem is that I altready have a sceond hard drive and even when I use it as a singel drive I have the same problem. The new HD is 100% operational and works perfectly, no errors and stuff. So I have no idea is it a mand 10.0 problem or a BIOS/motheroboard problem.

Link to comment
Share on other sites

  • 2 months later...
Guest neovanglist

Ok, forgive my ignorance-I am a total newbie. Born and raised Windows. Anyway, I'm just wondering... is this fixed in Mandrake 10.1? I, too have a crappy laptop BIOS-no option for LBA vs auto mode, and I have no idea what any of that fix with the geothing has to do with anything. Yes, I am clueless.


Also, is there any non-floppy way to save partitions and whatnot? I have, sadly, no access to a floppy drive.


And yet another thing... should I do the auto-partition or the advice given in http://mandrakeusers.org/index.php?showtopic=23097 (this is essentially my exact issue. I cannot afford to lose this drive, so this seems to be my best bet). Thanks for helping an utter Windows wimp see the light.


EDIT: And will disks 2 and 3 for 10.0 work with the 10.1 disk one? Thanks.

Edited by neovanglist
Link to comment
Share on other sites

it is fixed in 10.1


disks 2 and 3 from 10.0 will not work as almost every package as been upgraded to a newer version.


as far as partitioning, if you have empty space on your hard drive you should be able to choose the automatic option.


If you have further questions, it's a generally accepted etiquette that you start your own thread to ask them.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...