Jump to content
Sign in to follow this  
ezroller

libstdc++.so.2.10 and a project i should not have started.

Recommended Posts

okay, so I found this really cool lookin replacement for the pager in any WM. Its called 3ddesktop

 

http://desk3d.sourceforge.net/images/car1.jpg

 

I installed from rpm, and it pisses and moans about not finding

libstdc++.so.2.10

 

well, I looked on rpmfind.net and could only find a package for PLD distro.

running locate will yield

 

[ezroller@omniscience ezroller]$ locate libstdc++.so.2.10

[ezroller@omniscience ezroller]$

 

NOTHING. however

 

[ezroller@omniscience ezroller]$ locate libstdc++.so

/usr/lib/gcc-lib/i586-mandrake-linux-gnu/3.0.4/libstdc++.so

/usr/lib/gcc-lib/i586-mandrake-linux-gnu/2.96/libstdc++.so

/usr/lib/libstdc++.so.3

/usr/lib/libstdc++.so.3.0.4

[ezroller@omniscience ezroller]$

 

 

I am assuming my version is newer, and I have the latest version of 3ddesktop.

There are no config files for me to edit in 3ddesktop either to point it to this.

 

anyone know where I should take this?

Share this post


Link to post
Share on other sites

Ah glorious success. well, i installed the rpm for the "other" distro and it works!

 

albeit is slow as all hell...and i mean like S...L....O.....W.

 

If I can get it working at a normal speed, I think I'm gonna write a how-to for this.

Share this post


Link to post
Share on other sites

My ignorance amazes me sometimes. I have never had DRI installed. Well, it is now. now i can play quake at 1024x768 too! Holy Sh*t

 

only thing is though...glx info gives me an error message now:

 

 

 

[ezroller@omniscience ezroller]$ glxinfo

glxinfo: error while loading shared libraries: libGLU.so.1: cannot open shared object file: No such file or directory

[ezroller@omniscience ezroller]$

 

do i need to relink something...or something?

Share this post


Link to post
Share on other sites

well, it seems as though glxinfo nor this 3ddesktop app know where to find libglu. is there a way to update the path that all thse apps are looking in? glxgears works fine and quake does as well, so i know everything is installed right.

 

i know for certain

 

[root@omniscience stuff]# locate libGLU.so.1

/usr/X11R6/lib/libGLU.so.1

/usr/X11R6/lib/libGLU.so.1.3.401

Share this post


Link to post
Share on other sites

if glx gears and quake work fine then glxinfo should work as well, can't see why it wouldn't.

very strange :!:

 

Had a look a the man pages but no info there.

Share this post


Link to post
Share on other sites

yeah, i dunno where to take this. Since all of my apps are working better than usual, I'm gonna leave it be and come back to it in a few days with a clear head.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...