Jump to content

How to send audio to bluetooth [solved]


Recommended Posts

From your previous post, pulseaudio is running. Did you try rebooting with the Creative device attached? This would at least mean that it is detected by the system before pulseaudio starts, and maybe (long shot) it would be detected, like I mentioned about my HDMI sound issue.


Other than that, I'm out of ideas, as if the system is detecting it correctly as a bluetooth audio device, it should be showing up. Have you got the bluetooth packages installed that would recognise it as a sound device? And also the pulseaudio packages that allow bluetooth usage?

Link to comment
Share on other sites

OK, I guess I'll have to give up. Amongst other packages, I have these installed, but it's still not working:


  • pulseaudio-module-bluetooth
  • bluez-alsa
  • bluez-gstreamer

Thanks for all your assistance!

Edited by dude67
Link to comment
Share on other sites

This is what I have on Ubuntu 10.04 LTS:


root@jasiek:/home/ian# aptitude search pulse | grep ^i
i   gstreamer0.10-pulseaudio        - GStreamer plugin for PulseAudio           
i   libcanberra-pulse               - PulseAudio backend for libcanberra        
i   libpulse-browse0                - PulseAudio client libraries (zeroconf supp
i   libpulse-mainloop-glib0         - PulseAudio client libraries (glib support)
i   libpulse0                       - PulseAudio client libraries               
i   libsdl1.2debian-pulseaudio      - Simple DirectMedia Layer (with X11 and Pul
i   pulseaudio                      - PulseAudio sound server                   
i   pulseaudio-esound-compat        - PulseAudio ESD compatibility layer        
i   pulseaudio-module-bluetooth     - Bluetooth module for PulseAudio sound serv
i   pulseaudio-module-gconf         - GConf module for PulseAudio sound server  
i   pulseaudio-module-x11           - X11 module for PulseAudio sound server    
i   pulseaudio-utils                - Command line tools for the PulseAudio soun
i A vlc-plugin-pulse                - PulseAudio plugin for VLC                 

root@jasiek:/home/ian# aptitude search alsa | grep ^i
i   alsa-base                       - ALSA driver configuration files           
i   alsa-utils                      - ALSA utilities                            
i   bluez-alsa                      - Bluetooth audio support                   
i   gstreamer0.10-alsa              - GStreamer plugin for ALSA


I know package names will vary etc, but generally working OK. Just connected a USB Jabra Speak 410 device to my system which didn't work at first until I gave it a firmware update under Windows, but then it worked under Linux fine when I chose it under the input and output settings in pulseaudio.


Other issues might be running alsamixer and choosing the second device and making sure it's not muted. Had to do this with HDMI and if I remember with my bluetooth headset too.


You can do this as root, by running:




or by specifying the card directly:


alsamixer -c 1


thats a number one. Or, if you need to identify the devices:


aplay -l


thats a lowercase L.

Link to comment
Share on other sites

I think it may be a problem with my BT dongle. I'll scout for a new one and report back when I have tested a new one. I just tried this dongle with a different OS (Win7) and it didn't work there either.

Link to comment
Share on other sites

Yes, I managed to get the BT link to work! All it needed was a new BT dongle. :thumbs:


OK; sorry for not trying that earlier, but it did look like it was connected OK. But that was the problem.


Thanks for all your help in this! Here' a few virtuals for you guys. :beer: :beer:

Link to comment
Share on other sites

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...