Jump to content
  • Announcements

    • spinynorman

      Mandriva Official Documentation

      Official documentation for extant versions of Mandriva can be found at doc.mandriva.com.   Documentation for the latest release may take some time to appear there. You can install all the manuals from the main repository if you have Mandriva installed - files are prefixed mandriva-doc.
    • paul

      Forum software upgrade   10/29/17

      So you may have noticed the forum software has upgraded !!!
      A few things that have changed. We no longer have community blogs (was never really used) We no longer have a portal page.
      We can discuss this, and decide whether it is needed (It costs money) See this thread: Here
Sign in to follow this  
daniewicz

gnu backgammon problem

Recommended Posts

Any backgammon players out there?

 

I installed gnu backgammon gnubg 0.9 on my 2010.2 system with KDE.

 

As I near the end of a game, the program crashes (sometimes) with the following message:

 

Segmentation fault

 

 

 

Can anyone help?

Share this post


Link to post
Share on other sites

I'm guessing that's the only error that is shown when you launched gnu backgammon from the console window? No other text?

 

The only real way of diagnosing that would be to run an strace as you play the game, but it will generate a load of info, but would be ideal to add to a bug report as that strace would show exactly what is going on.

 

Could try switching from your Xorg video driver to vesa and see if it would settle down a bit? Before doing an strace with your existing video driver.

Share this post


Link to post
Share on other sites

sorry I didn't have any idea so I googled it

 

got this that links link1 and Link 2

 

which help me understand, sorry I couldn't help w/ a solution but maybe with definition of possible causes

 

best luck ;)

Share this post


Link to post
Share on other sites

Here's a quick fix... if you don't need sound. Open the game gui and go to settings > options > sound > and disable the sound effects > click OK. :)

 

Also, you 'may' have to do this every time you start the gui... or add the -q option to the command line:

gnubg -q

:D

Share this post


Link to post
Share on other sites

Thanks for the responses guys

 

Ian

I'm guessing that's the only error that is shown when you launched gnu backgammon from the console window? No other text?

yes, that is all I am seeing from the console

 

Greg

Not that I am doubting you, but why do you think this is a sound related problem?

Share this post


Link to post
Share on other sites

I was also having an intermittent segmentation fault during the game. So I opened the game with the -d (debug) option

gnubg -d

for more output, but that didn't show the problem. I then used gdb to run the game

gdb /path/to/gnubg

then entered 'run' to check. This gave me some libpulse text in the output.

 

So I turned off the sound and the game hasn't had a sigsegv since... YMMV :unsure:

Share this post


Link to post
Share on other sites

Well turning off the sound did not work for me. I have noticed that if I keep the default design, there is no crashing.

 

I remember now while I stopped playing gnubg long ago. I grew tired of getting spanked! This is POWERFUL stuff.

Share this post


Link to post
Share on other sites

Video driver? Like I mentioned, maybe change to vesa, and see what happens? Did you not try this yet? :)

Share this post


Link to post
Share on other sites

I grew tired of getting spanked! This is POWERFUL stuff.

 

Turn the predefined settings down. It's probably set on expert by default, so try the advanced setting. If you really want to get spanked... set it on grandmaster. :D

Share this post


Link to post
Share on other sites

Ian,

 

I have a ridiculously underpowered GeForce FX 5200 video card, so if I switch to the vesa driver my KDE struggles. Thus I have not tried to make this driver switch. I appreciate your input, but I think I need fixes that allow me to stay with the NVidia driver.

Share this post


Link to post
Share on other sites

You only needed to switch temporarily to find out if the nvidia driver is the problem. Not asking you to do it permanently. If we then find that the nvidia driver is the problem, then we need to check the version and if there is another version of it newer or something that you can use.

Share this post


Link to post
Share on other sites

Well I am getting back to this problem after being distracted by other things.

 

Before trying Ian's suggestion, I decided to implement the gnu debugger (gdb) as suggested by Greg. When I run gnubg from within gdb, I am unable to make gnubg crash! In other words, if I run the program as follows all is well:

 

gdb /usr/games/gnubg

 

:o

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×