Jump to content
Sign in to follow this  
menendez

Trouble connecting to new Router

Recommended Posts

Hello,

 

I have a new router. I have been able to connect all my wireless devices including Win7 PCs, Wii, DSi's, wireless network printer with no trouble except my Mandriva 2010.2 KDE PC. From the graphical control panel I am not getting any useful feedback beyond a connection failed message. I am using WPA2-PSK which I have used in the past with no trouble. Any suggestions on trouble shooting would be greatly appreciated.

 

Thank You,

Share this post


Link to post
Share on other sites

Have you set up your Firewall in MCC (Mandriva Linux Control Center)?

 

Start > Tools > System Tools > Configure Your Computer > Security > Set up your personal firewall.

 

 

You can also try deleting your existing connection and recreating a new one there.

 

Start > Tools > System Tools > Configure Your Computer > Network & Internet.

Edited by David Batson

Share this post


Link to post
Share on other sites

You could run 'ifup' in a command shell. It at least gives you a clue as to what it is doing.

If you don't know the command just open a shell and type (as root) ifup followed by whatever the dice is that you are connecting with.

E.G. 'ifup eth0', for your first hardwired connection, or 'ifup wlan0' for your first wireless lan.

You will get a bit more information of what is happening. If you want more information on what the process is doing run in a separate shell 'tail -f /var/log/syslog' and watch real time log entries of the attempted connection.

Share this post


Link to post
Share on other sites

I tried clearing the connection and recreating it, didn't work.

I tried cycling the power to the router, didn't work.

Firewall is configured to no firewall.

 

This is the system log

 

[root@localhost jose]# tail -f /var/log/syslog

Jan 23 11:17:20 localhost ifplugd(wlan0)[10995]: Link beat detected.

Jan 23 11:17:21 localhost ifplugd(wlan0)[10995]: Executing '/etc/ifplugd/ifplugd.action wlan0 up'.

Jan 23 11:17:22 localhost avahi-daemon[2645]: Registering new address record for fe80::218:4dff:fe70:7337 on wlan0.*.

Jan 23 11:17:25 localhost mdkapplet[1958]: Checking Network: seems disabled

Jan 23 11:17:27 localhost dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 4

Jan 23 11:17:31 localhost dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 6

Jan 23 11:17:31 localhost kernel: wlan0: no IPv6 routers present

Jan 23 11:17:37 localhost dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 14

Jan 23 11:17:51 localhost dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 19

Jan 23 11:18:10 localhost dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 9

Jan 23 11:18:19 localhost dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 9

Jan 23 11:18:25 localhost draknetcenter[10141]: modified file /etc/sysconfig/network-scripts/ifcfg-wlan0

Jan 23 11:18:25 localhost draknetcenter[10141]: modified file /etc/sysconfig/network-scripts/ifcfg-wlan0

Jan 23 11:18:25 localhost draknetcenter[10141]: changed mode of /etc/sysconfig/network-scripts/ifcfg-wlan0 to 700

Jan 23 11:18:25 localhost draknetcenter[10141]: written wlan0 interface configuration in /etc/sysconfig/network-scripts/ifcfg-wlan0

Jan 23 11:18:25 localhost draknetcenter[10141]: created file /etc/wpa_supplicant.conf

Jan 23 11:18:25 localhost draknetcenter[10141]: running: /usr/sbin/wpa_cli reconfigure

Jan 23 11:18:25 localhost draknetcenter[10141]: running: /sbin/ifdown wlan0 daemon

Jan 23 11:18:28 localhost dhclient: No DHCPOFFERS received.

Jan 23 11:18:28 localhost zcip[12969]: interface: wlan0 (00:18:4D:70:73:37)

Jan 23 11:18:28 localhost zcip[12969]: Retrieved address 127.255.255.255 for wlan0:9

Jan 23 11:18:28 localhost zcip[12969]: probing for 127.255.255.255

Jan 23 11:18:28 localhost kernel: device wlan0 entered promiscuous mode

Jan 23 11:18:28 localhost zcip[12969]: sending probe 1 for 127.255.255.255

Jan 23 11:18:28 localhost ifplugd(wlan0)[10995]: Killing child.

Jan 23 11:18:28 localhost ifplugd(wlan0)[10995]: client: Determining IP information for wlan0...

Jan 23 11:18:28 localhost ifplugd(wlan0)[10995]: Program execution failed, return value is 0.

Jan 23 11:18:30 localhost zcip[12969]: sending probe 2 for 127.255.255.255

Jan 23 11:18:32 localhost zcip[12969]: sending probe 3 for 127.255.255.255

Jan 23 11:18:34 localhost kernel: ndiswrapper (set_essid:53): setting essid failed (C0000001)

Jan 23 11:18:34 localhost kernel: device wlan0 left promiscuous mode

Jan 23 11:18:34 localhost ifplugd(wlan0)[10995]: Link beat lost.

Jan 23 11:18:34 localhost avahi-daemon[2645]: Withdrawing address record for fe80::218:4dff:fe70:7337 on wlan0.

Jan 23 11:18:34 localhost kernel: ndiswrapper (set_essid:53): setting essid failed (C0000001)

Jan 23 11:18:34 localhost draknetcenter[10141]: running: /sbin/ifup wlan0 daemon

Jan 23 11:18:34 localhost kernel: ADDRCONF(NETDEV_UP): wlan0: link is not ready

Jan 23 11:18:34 localhost ifplugd(wlan0)[10995]: SIGUSR1: Daemon suspended (#1)

Jan 23 11:18:34 localhost ifplugd(wlan0)[10995]: SIGUSR2: Daemon resumed (#1)

Jan 23 11:18:34 localhost kernel: ADDRCONF(NETDEV_UP): wlan0: link is not ready

Jan 23 11:18:34 localhost kernel: ndiswrapper (set_essid:53): setting essid failed (C0000001)

Jan 23 11:18:34 localhost kernel: ndiswrapper (set_essid:53): setting essid failed (C0000001)

Jan 23 11:18:35 localhost kernel: ADDRCONF(NETDEV_UP): wlan0: link is not ready

Jan 23 11:18:40 localhost draknetcenter[10141]: selecting wpa_supplicant network 0 through network monitor

Jan 23 11:18:41 localhost kernel: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready

Jan 23 11:18:41 localhost ifplugd(wlan0)[10995]: Link beat detected.

Jan 23 11:18:43 localhost avahi-daemon[2645]: Registering new address record for fe80::218:4dff:fe70:7337 on wlan0.*.

Jan 23 11:18:52 localhost kernel: wlan0: no IPv6 routers present

Jan 23 11:18:57 localhost ifplugd(wlan0)[10995]: Link beat lost.

^Z

[1]+ Stopped tail -f /var/log/syslog

[root@localhost jose]#

 

Next steps?

Share this post


Link to post
Share on other sites

I finally got it to work by giving up on WPA2 and just using WPA.

For whatever reason Mandriva was the only network device I have that won't work with the router using WPA2.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...