Jump to content

Mandrake 9.2 rpmdrake


Recommended Posts

New to this forum. Problem is with rpm updates. A couple of questions.

1. I have downloaded and installed Mdk 9.2 and everything seems to be working fine. I'm using the kde gui and trying to update with rpmdrake under MCC. Yesterday I was able to donwload some updates but not all of Security files and today I got two or three bug fixes downloaded. I seem to have a problem with some of the keys not matching and it asks me if I want to install anyway and I say No. I've also had alot of problems with different sites locking on the downloads.

2. Some how rpmdrake has lost a hdlist file for the updates and now everytime I try it I get the message--"The list of updates is void. This means that either there is no available update for the packages on your computer (which I know is wrong) or you already installed all of them (which is also wrong). I know the files I need to update because I wrote them down from a previous download (about 20 files). My second question is how do I get my outstanding update list back into the loop and how do I get rid of the key errors in 1 above. When I run the command " urpmi.update -a"

I get "no list file [/var/lib/urpmi/list.Updates for Mandrake Linux 9.2 (ftp1u)] exists" after running from console "urpmi.update -a -c -f --no-md5sum --wget" I get the same thing! How do I get my file called list.Updates back in the path /var/lib/urpmi/ and how did it disappear in the first place. Without it, rpmdrake and the two commands listed think that there's nothing to update.

Arguments to the urpmi command above: Note: When the original problem occurred I was using rpmdrake in the gui and not the command line which utilizes the below args.


-a = all media

-c = clear header cache

-f = force

--no-md5sum = ignore md5sum files on local machine and mirror, just sync them

--wget = use wget protocol (far more robust than curl)

Edited by javabiz
Link to comment
Share on other sites

Hello and welcome :)


Is your connection or your update source ok ? can you ping your update source ?

Also you can retry after having cleaned the urpmi cache (/var/cache/urpmi): I had problem in the past with it because it was not automatically cleaned but that was with ML9.0 if I remember well. Anyway you can try.

Just some ideas :juggle:



Link to comment
Share on other sites

Welcome to our board!


Couple of things for you:


1. The message about the gpg keys not matching is only a warning. You should still be able to install the rpms with no problems whatsoever.


2. When you get the message about the list being void: Do you have any of the checkboxes (Security, bugfixes, normal) checked? It is normal to get that message if you do not have any of those checked.


Also, on my system the urpmi source for updates is labeled as 'update_source' without the quotes. If you are still getting a problem, you might want to remove that particular source (Software sources manager, or urpmi.removemedia Update...) and open up Mandrake Update again and choose a new source (the one at the University of Utah works for me, but that's cause that is where I live...)


Try these things out and let us know what happens.


Once again, welcome to the board!

Link to comment
Share on other sites

hi javabiz.......


you might wanna check out this thread, concerning hdlists getting lost......


URPMI Issues


seems there's some problems with certain mirrors, causing the hdlists to get hosed. there is a work around listed in that thread until things are straightened out.


also, as LiquidZoo said, don't worry about gpg keys. i've ignored many of those warnings & never had a bad rpm install. and, the update source mirrors aren't always up to date, so again, do as LiquidZoo suggested & just change to another update mirror if you keep getting the "void......." message. here's a link tht shows the status of MDK update source mirrors, so you can check to se which ones are most current.....


MDK Update Mirrors



Link to comment
Share on other sites

Guest kuchwas
"urpmi.update -a -c -f --no-md5sum --wget"

-a = all media

-c = clear header cache

-f = force

--no-md5sum = ignore md5sum files on local machine and mirror, just sync them

--wget = use wget protocol (far more robust than curl)


-1- Nice cut and paste of my message #6!



And the above thread.


-2- Plus here:



-3- Cooker ML message from Warly (mandrakesoft employee)

The well known message:


medium "92_contrib" uses an invalid list file:

mirror is probably not up-to-date, trying to use alternate method


is due to a bug into urpmi.addmedia which creates a file list even if

there is none on the server, and then try to update it but does not

manage to download a new one.


rm /var/lib/urpmi/list.<media> fix the problem.


-4- More mirror errors:


A quick comparaison with easyurpmi lists shows that you're missing all mirrors

for Australia and Belgium, two mirrors from Czech Republic, etc... On the

other hand, easyurpmi lacks mirrors from Austria, one from Czech Republic,


Edited by kuchwas
Link to comment
Share on other sites

I just checked back in and was surprised to find some replies to the rpmupdate delema! I have since done much work on the problem and hope to post what I found out. I learned a few things about URPMI that I didn't know before! Thanks all for your time and trouble and I mainly found out that this is a super place to get help with Mandrake.

Link to comment
Share on other sites

I had the next message entered twice so go to next message for rpm problem below.

I almost lost the message because I was entering it in this entry box. It wouldn't add it to the

post so I copied it to OO and tried to use the text doc to paste back in here. It wouldn't work I had to copy to kate and from kate I pasted to the next post.


Edited by javabiz
Link to comment
Share on other sites

Before I say anything, do the following (assumes kde gui)

1. Open konqueror.

2. Go to opera.com and select download.

3. Pick the static for Linux at the bottom selection.

4. Download from Sweden or Switzerland sunsite ftp.

5. Select open to have konq uncompress in its archive screen.

6. Select path under your home.

7. Close konq

8. Click on your console

9. cd opera*

10. type ./install.sh

11. answer y to the two questions

12. close the console

13. From your desktop right click new-->application

14. Click on execute and browse to /home/yourhome/operadirectory/bin

15. Select opera (executable)

16. Select General tab and select O from application icons.

17. Edit box under General tab to read Opera.desktop

18. Click ok

19. Click on Opera icon and click start

20. Three things that will help you out here:

a. right click on the panel below File Edit .... where you see home icon and select skin and click on special effects and then get skins:

Here are the ones I have:

Azac 1.3.zip Epidermis.zip Occhi blu (1).zip -) (Smile).zip

Azur 1.3.zip IE6XP Native.zip Occhi blu 4 XP.zip Sofa King.zip

bright_striped.zip iMacOS Lars - Metal Edition.zip Occhi blu.zip TobsTheatre 2.zip

Circuito (1).zip iMacOS Lars.zip Opera-Wonderland.zip Tobs Theatre iron.zip

Circuito.zip Khrome.zip Phoenity 2.8.zip Tobs Theatre light.zip

Cocoa Native.zip KonquerOrPERA 1.6.zip Phoenity Redux.zip Tobs Theatre paper.zip

Cocoa.zip MacOSX Grey - Metal Edition.zip Qute Native.zip WindowsXP 2003.zip

coolOS v2.2.zip MacOSX Grey.zip SlateXP.zip XPmixup.zip

Do a search on these names and pick the one you want--select it and it will install automatically!

b. In Opera after installing the skin you want click on the star shaped icon to the right of home icon. You'll notice to the left of your browser you have Bookmarks, Contacts, History, Transfers, Links, Windows and Notes. Click on View and set to split view.

Your probably asking at this point or at the first-WHAT's THIS GOT TO DO WITH MandrakeUsers.org and installation? Here's why:

The bookmarks on Opera are outstanding but the the Notes selection will help you with immediate cut and paste for all those long Linux console commands and you can organinze anything in this little honey from books to command lines. For example: Click on notes. Click on New Folder--and type URPMI. Now highlight all this screen and right click--select Copy Note and you now have a line that starts with "Before I say anything..." Left click and drag over the folder name you created. Left click on the folder name if you don't see the note in the lower split screen and select it until you do. Highlight any command line in this note and right click and choose copy. Click on your console icon on the task bar and press the right hand corner middle box to midimize the screen so you can see Opera in the background (if your console is set up with a transparent background-this looks really cool--you see your wallpaper in the console-subdued while Opera is in the max mode)-- press your middle mouse key when the mouse is next to the prompt. Bingo---you have immediate command entry. Don't hit enter though--just backspace the command to the prompt--this is nothing but a demo not the real thing--hate to have you wipe out something you may not understand yet!

c. Now the next thinig--for those who are saying--yah but what about this ad that appears in the right hand corner of Opera. Go to the desktop and add as many desks as you desire (I have eight) Download some cool wallpaper from kde-look.org. Now after you have these wallpapers in each desktop background-I have eight--cover the Opera ad by right clicking on your Session Boxes on the Task Bar and Launching Pager. Drag and size pager to fit exactly over the ad. Side note: To scroll in the browser--press your middle scroll button.

Now for the URPMI and RPM problem.

First of all, thanks to kuchwas above for the following:


In the meantime, try this when you update your media:

WARNING!: Don't do this yet.

"urpmi.update -a -c -f --no-md5sum --wget"


-a = all media

-c = clear header cache

-f = force

--no-md5sum = ignore md5sum files on local machine and mirror, just sync them

--wget = use wget protocol (far more robust than curl)


Original Problem:

I get "no list file [/var/lib/urpmi/list.Updates for Mandrake Linux 9.2 (ftp1u)] exists" after running from console "urpmi.update -a -c -f --no-md5sum --wget" I get the same thing! How do I get my file called list.Updates back in the path /var/lib/urpmi/ and how did it disappear in the first place. Without it, rpmdrake and the two commands listed think that there's nothing to update.

"unable to take medium "Updates for Mandrake Linux 9.2 (ftp1u)" into account

as no list file [/var/lib/urpmi/list.Updates for Mandrake Linux 9.2 (ftp1u)]



As I found out this is really no big deal and will keep appearing (if you lost your update file) every time you do an update with urpmi from the command line. If this annoys you do this:

1. Go to /var/lib/urpmi

2. As su from the command line create the file list.Update with vi as su.

Note: You can use kate for the gui folks--but right click on kate and click on Properties.

Then click on Execute and check the box for run as other user and type r and return

in the user name for root. Now you can edit the file /var/lib/urpmi/list.Updates

3. In vi or kate type anything in the file-one word like garbage and save it with the filename list.Updates.

4. Go to /etc/urpmi and type the following: cp urpmi.cfg urpmi.bak

This backs up your list of 8 cds info that you can see by going into MCC (Mandrake Control Center) and selecting Software Management--->Softeware Media Manager

This step is important because if you have the first 3 CDs from a download or from mandrakeclub.com---you may decide to get the Power Pack at a later date. So this backups your original install cd info and keeps you from losing the info in urpmi.cfg when you do the update db and urpmi commands.

5. Go to http://urpmi.org/easyurpmi/index.php pick the following for main, contrib, plf and updates: (Select from choices--hint:

you have to click on the numbers in order to advance and see what is in the black box!

For main:

urpmi.addmedia main ftp://ftp.lip6.fr/pub/linux/distributions...6/Mandrake/RPMS with ../base/hdlist.cz

For contrib:

urpmi.addmedia contrib ftp://ftp.lip6.fr/pub/linux/distributions....2/contrib/i586 with ../../i586/Mandrake/base/hdlist2.cz

For plf (Penguin Liberation Front):

urpmi.addmedia plf ftp://mandrake-forum.org/pub/PLF/mandrake/9.2 with hdlist.cz

For updates:

urpmi.addmedia --update updates ftp://ftp.lip6.fr/pub/linux/distributions...dates/9.2/RPMS/ with ../base/hdlist.cz

If you downloaded Opera, click New Folder from Notes section and highlight the black box (If you clicked on the step buttons--you should have all the above info in the box) :^). Right click and Copy Note. Now drag note name over the folder name. Now you can copy and paste to the console as described above--each section of the notes (Should be 4) and run them one by one until all your urpmi sites are loaded.

HINTS: Your Opera Notes to the left of the browser window can be expanded--mouse to the vertical line and you will see two arrows--left click and make any width you want. One more thing , hover the mouse over a note line in the top view window. You should see a box with some of your note on it! This gives you a quick view of your note.


Note: I live in US MST zone so I found out by trial and error that the US sites are very busy during the day. I have had very good luck with the above sites, however, since European time is normally at night when I'm doing this during the day.

Hope this helps--I still use Konqueror, Mozilla and Galeon--but my bookmark file is 13 MB and the notes file already has notes on three books and several command lines as well. I love Opera and have used it for four years now. You also can use History, Transfers and Links to help you out.

The question on the key comparison didn't seem to come up when I added these new download sites--so hopefully that is solved. Or like kuchwas suggested the --no-md5sum keeps this from being a factor on updates. Now just highlight and right click on this command to copy notes and you will always have access to it: urpmi.update -a -c -f --no-md5sum --wge

Hope this helps!

Thanks for everyones help

Edited by javabiz
Link to comment
Share on other sites

Guest kuchwas

You should have read my post above, clicked on the links, and read them. It would have saved you alot of trouble. 'Course, some people just like to reinvent the wheel. B)

Link to comment
Share on other sites

On the next installation of mandrakeX.X I install Opera first and foremost and copy two files from the backup CD (notes.adr and operaX.adr) to /home/me/.opera and bingo I will have all the stuff I will have forgot in my notes right beside my browser window which is of course going to be on this website when I'm doing this :wall:

Besides, the problem I was having kept showing my error message on the updates even though there was no file to delete in /var/lib/urpmi with that name-please read my above post again. Your deleting of this file wasn't possible because it didn't exist. I had to create a fake file with the same name in order for the system to delete it. It could be the initial filename is hard coded (ugh) in the install and then when it goes to update it changes it unless the file can't be found then it gives the error message over and over--even though it does update with the new stuff!

Edited by javabiz
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...