Jump to content

HP Proliant with smart array P212

Guest defa

Recommended Posts

Dear all,


I am new to linux however I have been using few mandriva distributions. Now we bough HP Proliant ML110 G6 in the company and I can not install on it Mandriva Spring 2010 64 bit version.


Installation is ok but after restart I got messages that can not find disk device. The problem is the same as described on this page:



but I do not know how to resolve it. If I remove smart array I can install Mandriva Spring 2001 without problems but I need smart array for raid 0.


After boot I get the following problem:

waiting for device cciss!c0d0p1 to appear (timeount 1min)

waiting for device cciss!c0d0p5 to appear (timeount 1min)

Could not find resume device (/dev/cciss/c0d0o5)

Could not resolve resume device (/dev/cciss/c0d0o5)

Creating root device.

Kernel panic - not syncing: Attempted to kill init!

Pid: 1, comm: init Not tainted #1


The device are definitely there because I can see them and I can also mount them. I have also went through grub device.map and menu.lst and did not find any problems.


Is it possible that this problem is related to kernel because I am trying to install desktop version of mandriva on server?


Please help!

Edited by defa
Link to comment
Share on other sites

It's definitely not that you are installing the desktop version as there's not really a desktop version as such. You have a server kernel installed as shown by your post above so it has installed the appropriate kernel.


I know some distros don't always install, or install but won't boot, or other problems, such as network card unavailable for one reason or another. For debugging purposes, have a go at installing Ubuntu Server 10.04 x86_64 and see if it's any better, or perhaps OpenSUSE Linux 11.3 or CentOS 5.5. Then we can find out if you can install and get a particular distro working, or whether the problem is just with Mandriva. Alternatively perhaps do an install of Debian 5.05 (lenny) - depending on which one of the ones above you have a preference for.


The HP website doesn't have anything in terms of drivers available for other than RHEL or SUSE Enterprise Linux.


Otherwise, you can boot into rescue mode from a CD, and then chroot your install and try doing an mkinitrd to generate a new one and see if that works.

Link to comment
Share on other sites

Well I tested RHEL, OpenSuse, SLES 11.3 all works fine. It is only mandriva problem. It also boots with mandriva enterprise server 5.


I also tried to use lilo bootloader but without success. How do I run mkinitrd command from rescue mode?

Link to comment
Share on other sites

It all works fine with Mandriva Enterprise Server 5? Maybe use this, unless you have a special need for running Mandriva Spring 2010.


In short, it will be something like this, after booted with rescue CD, mount your partitions:


mkdir /mnt/mysystem
mount /dev/cciss/c0d0px /mnt/mysystem (mount / partition here)


then mount any other partitions like /boot, /usr, /var under here in the usual manner until you've got all of them mounted. Then:


chroot /mnt/mysystem /bin/bash


if it fails, chroot it without adding /bin/bash at the end. Then do:


source /etc/profile


now, you'll need to do the mkinitrd, something like this:


mkinitrd initrd-


for the correct version, check what is already in /boot - you will already have an initrd for this kernel, so just see what happens. Otherwise, I'd just use a different distro.

Link to comment
Share on other sites

Everything works but when I try to execute mkinitrd it returns error:

/sbin/mkinitrd: line 39: /usr/libexec/initrd-functions: No such file or directory

/sbin/mkinitrd: line 1031: error: command not found


I used rescue media from spring dvd.


I would use mandriva enterprise but there I have problems with graphic card drivers ati radeon hd 4670 does not work. I tried also install ati driver from their web site but not successfully. Installation was successfull but after startx there were some problems. I would use ati drivers that are in spring 2010 which works perfectly but I do not know where can I get them.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...