Jump to content

How to get Flash player 32 bit to work on 64 bit


Recommended Posts

I had flash player working on my 64 bit system. I saw the update to 10.1, removed the old security risk version, to find out Adobe is not supplying a working 64 bit version right now.


So, I did some searching, and found some posts saying to install the 32 bit version and nspluginwrapper. I have tried without success. There was not much detail, so I guess I'm doing something wrong?


Can some one guide me with more specific instructions?


Some info. uname -a reports


Linux duelie #1 SMP Tue Apr 27 20:37:44 EDT 2010 x86_64 AMD Athlonâ„¢ 64 X2 Dual Core Processor 5200+ GNU/Linux


I have downloaded this file from Adobe.

I can install it system wide with urpmi. Here is my confusion, what nspluginwrapper package should I install? Four files show up.


What else do I need to do, if anything, to get Flash to work in Firefox 3.6.6 ?

post-8470-010378000 1279208766_thumb.png

Edited by camorri
Link to comment
Share on other sites

My answer will not help you get flashplayer running for you. I couldn't get it to work either on an x86 64bit. Finish up I downgraded to the 32bit version of Mandriva. Installed the version from Adobe site and it works without problems. As well as flashplayer not working correctly I had a major problem with a program that I wrote which accesses a Mysql database on a remote server. Short of re-working the application there was no alternative but to downgrade. To be honest I didn't see any improvement by using the 64bit version. So unless anyone comes up with the solution for you you may think about installing the 32 bit version.

Link to comment
Share on other sites

Thank-you for your posts. I thought about going back to a 32 bit system, but this is the only problem I have with the 64 bit system. From what I have read, Adobe is committed to building a 64 bit flash plugin. There is no time line, however... I have a Netbook, with Ubuntu installed. So, I'm not stuck.


For the record, I tried gnash, it didn't work with the flash content I tried it on.

Link to comment
Share on other sites

The Eratta file for 10.1 is where I started. My first attempt was using the latest 32 bit Flash Player with nspluginwrapper. On my 10.0 64 bit system flash vids do not work.


Today I tried the second solution, i585 firefox, plus 32 bit Flash. Unfortunately that does not work either. For the record here are the packages I have tried and now have installed. I removed the 64 bit FF packages I had installed.


Shockwave Flash

File: libflashplayer.so

Version: Shockwave Flash 10.1 r53


Last thoughts, I did see a message that suggested I remove 'orphaned' packaes when I removed the 64 Bit Firefox.. I don't remember the exact text, and have not removed those orphans. Any possibility that is part of this problem? If yes, can someone post the command to remove the orphans?

post-8470-021607000 1279364666_thumb.png

Link to comment
Share on other sites

su then enter password.


urpme --auto-orphans.


Read carefully through the list before deleting anything. To remove anything from the list that you think should not be deleted, press the i key ( This allows you to edit the list. i as in insert) then use the arrow keys to move to the line you want excluded from the list and remove the line by means of the back space key. When done, press the Esc key then type :wq then enter.

type a lower case y then enter.


Cheers. John.

Edited by AussieJohn
Link to comment
Share on other sites

The most advanced nspluginwrapper, as well as the best working currently, is the one in Debian Sid. It can be used in other Linuxes as well (factly, this is what I'm using on my 64-bit Archlinux) with some footwork.

The wrapper works great, but flashplugin itself is as buggy as ever. OK, the huge security gap went away, but that is that: performance and stability-wise there is absolutely no improvement.

Link to comment
Share on other sites

The most advanced nspluginwrapper, as well as the best working currently


I have never used Debain Sid, can you give me some idea how to get their nswrapperplugin? I'm guessing this can work with Mandriva 64 bit.

Edited by camorri
Link to comment
Share on other sites

The binary .deb is here:


This can be unpacked using several tools (e.g. deb2rpm or deb2targz) The binaries are (AFAIK) statically built, so it's not likely to have dependency hell.

Now you can simply enter the unpacked directory, and copy as root the included files to the corresponding system directories (should be OK for Mandy).

Generally it's not advisable to install binaries like that: it may break your distro's PMS, with unpredictable consequences. But if you keep a track of those non-PMS system changes, you can easily revert them in case something goes wrong.

Link to comment
Share on other sites

  • 4 weeks later...

This is an update. I have finally got libflashplayer working on my 64 bit Mandirva 2010.1 system. Her is what I did.


This thread stated when I was running 2010. I ran an update and, and after some problems, have 2010.1 64 bit running.


I decided to give the instructions on 2010.1 http://wiki.mandriva.com/en/2010.1_Errata another shot.


The directory

was there before I did anything. I updated the slocate DB, did some searching to see if I had any thing left behind by previous attempts. There was, in my home directory. I deleted what I found.


I downloaded from Adobe the latest libflashplayer rpm file and installed it with urpmi.


Next I installed nspluginwrapper . I used MCC, install software for that. See the attachment for rpm's installed.


I can now view flashplayer conntent on utube, and other sites using firefox. SOLVED.

post-8470-084759500 1282304735_thumb.png

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...