Jump to content
xboxboy

Installing 2nd Scanner [solved]

Recommended Posts

I have a HP all in on printer/scanner F2480, which prints and scans fine (after I used updated drivers from backports). I'm happy with how this works.

 

Problem is I also have a Epson V300 scanner, which I need to use for scanning negetives and slides, which my all in one can't do.

 

SANE says I need to use the epson2 (1.0.124) backend. I cant find this in the repos, so I decided to try to use the avasys driver & iscan.

 

I download the avasys rpms and then try to install them and I get:

 

rpm -Uvh iscan-2.24.0-4.i386.rpm
Preparing...                ########################################### [100%]
       file /usr/lib/sane/libsane-epkowa.la from install of iscan-2.24.0-4.i386 conflicts with file from package sane-backends-iscan-1.0.20-8.1mdv2010.0.i586
       file /usr/lib/sane/libsane-epkowa.so.1.0.15 from install of iscan-2.24.0-4.i386 conflicts with file from package sane-backends-iscan-1.0.20-8.1mdv2010.0.i586
       file /usr/share/iscan/fdi.xsl from install of iscan-2.24.0-4.i386 conflicts with file from package sane-backends-iscan-1.0.20-8.1mdv2010.0.i586
       file /usr/share/iscan/fs-blacklist from install of iscan-2.24.0-4.i386 conflicts with file from package sane-backends-iscan-1.0.20-8.1mdv2010.0.i586
       file /usr/share/iscan/scsi from install of iscan-2.24.0-4.i386 conflicts with file from package sane-backends-iscan-1.0.20-8.1mdv2010.0.i586
       file /usr/share/iscan/usb from install of iscan-2.24.0-4.i386 conflicts with file from package sane-backends-iscan-1.0.20-8.1mdv2010.0.i586

 

I could install esci-interpreter-gt-f720-0.0.1-2.i386.rpm ok though.

 

Any help most appreciated.

Share this post


Link to post
Share on other sites

Uninstall sane-backends-iscan, and then install the avasys packages. The sane-backends-iscan package contains sane open source Epson drivers, which are not needed when you use the avasys drivers.

 

Jim

Share this post


Link to post
Share on other sites

Jim, thanks for the reply.

I had considered this, but will my HP scanner stop working then? I really want both working...I know, greedy

Share this post


Link to post
Share on other sites

The files in sane-backends-iscan (the epkowa open source "drivers") are needed only for those Epson scanners that they support. They are not needed by any other devices, such as HP scanners. The open source Epson drivers are packaged separately from other open source drivers (which are in sane-backends) in order to avoid the conflicts that you saw when you tried installing the avasys drivers originally.

 

Jim

Share this post


Link to post
Share on other sites

Nice work Jim! I got my V300 working in Mandriva!......One less reason for winblows.....

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...