MandrivaUsers.org : nothing shows up - MandrivaUsers.org

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

nothing shows up

#1 User is offline   shengchieh 

  • casual
  • Group: Members
  • Posts: 65
  • Joined: 07-October 06

Posted 17 April 2007 - 09:10 PM

I just installed Mandriva 2007 free DVD.

Now when I turn on the PC, the following shows
- BIOS
- blue screen w/ various options - linux, linux nonfb, failsafe
- light blue screen w/ big letters "FREE"
- light blue screen (no writing)
then a completely dark screen shows up, possibly a login
screen.

What happening? This happens if I choose linux or linuxnonfb.
If I choose failsafe, it logs as root. Then what?

Btw, I also noticed in BIOS, I can choose
- EGA/VGA
- CGA 40
- CGA 80
- MONO
I try switching from EGA/VGA but it keeps reverting back.

Fyi, it's PC-132 CE from MadTux.

Sheng-Chieh
0

#2 User is offline   Ixthusdan 

  • Platinum
  • Group: Platinum
  • Posts: 9,042
  • Joined: 17-September 02

Posted 17 April 2007 - 09:20 PM

First, do you get a command line login?
What video card do you have?
The people never give up their liberties but under some delusion. Edmund Burke, 1784
0

#3 User is offline   scarecrow 

  • Platinum
  • Group: Platinum
  • Posts: 5,157
  • Joined: 16-February 05

Posted 17 April 2007 - 09:54 PM

View PostIxthusdan, on Apr 18 2007, 12:20 AM, said:

First, do you get a command line login?
What video card do you have?


Yep, as above. Plus, if you are using a DVI monitor connector, please replace it (for the installation part only- you can revert after installing) with an oldfashioned VGA connector.
0

#4 User is offline   shengchieh 

  • casual
  • Group: Members
  • Posts: 65
  • Joined: 07-October 06

Posted 17 April 2007 - 10:21 PM

Thanks for your help.

no login shell - that's where a blank screen comes up.

What is a DVI monitor connector? (If I don't know, do I
have it?)

Also, is there a way to see the video card in the BIOS?
In the BIOS, I only see

Standard CMOS Features: Video:
-EGA/VGA
- CGA 40
- CGA 80
- MONO
Advanced Chipset Features: Video BIOS Cacheable:
- enabled
- disabled
Power Management Setup: Video Off Method
- DPMS
-Blank Screen
- V/N SYNC+Blank
Video Off In Suspend
- Yes
- No

Is there a way to tell the video card logging as root thru "failsafe"?

Sheng-Chieh
0

#5 User is offline   Ixthusdan 

  • Platinum
  • Group: Platinum
  • Posts: 9,042
  • Joined: 17-September 02

Posted 18 April 2007 - 02:13 AM

Please look at your computer documentation. I went to the site, but could not tell what video cards they use. Or, you could open the case and have a look!
The people never give up their liberties but under some delusion. Edmund Burke, 1784
0

#6 User is offline   shengchieh 

  • casual
  • Group: Members
  • Posts: 65
  • Joined: 07-October 06

Posted 18 April 2007 - 04:30 AM

When I do lspci as root using the "failsafe" mode, I see

VGA compatible controller: Intel Corporation
82865G Integrated Graphics Controller (rev 02)

Does that sounds like my video card or is it something else?

I see also a bunch of USB, PCI, ISA, IDE, SMBus,
and Multimedia stuffs. I use wheelchair, so I prefer not
having to open the thing if I can (bulky to deal with). I
rather reinstall Mandriva 2006 and find out from there
if needed.

Sheng-Chieh
0

#7 User is offline   Ixthusdan 

  • Platinum
  • Group: Platinum
  • Posts: 9,042
  • Joined: 17-September 02

Posted 18 April 2007 - 01:07 PM

You have an Intel integrated video chip, which means it is mounted directly to the motherboard. Boot to the command line. Su to root, type mc. This is a nice file manager program that is easy to use. Navigate to /etc/inittab. Toward the end of the file, there is a section that looks like this:
id:5:initdefault:

Change it ti look like this:
id:3:initdefault:
Save and exit.
Note the change from "5" to "3". Now, you will be able to boot in normal mode to the command line.
Next, boot to command line in normal mode and type "startx". Report the errors here.
The people never give up their liberties but under some delusion. Edmund Burke, 1784
0

#8 User is offline   shengchieh 

  • casual
  • Group: Members
  • Posts: 65
  • Joined: 07-October 06

Posted 18 April 2007 - 03:09 PM

Thank for your help!

I'm out until after late lunch. I'll try late afternoon.
(and I'll let you know what happens)

Sheng-Chieh
0

#9 User is offline   shengchieh 

  • casual
  • Group: Members
  • Posts: 65
  • Joined: 07-October 06

Posted 18 April 2007 - 09:42 PM

I did the change 5 to 3 in initab. It booted in console login.
After logging in, I typed startx and KDE starts fine. No error
shows up.

The console login (instead of GUI login) doesn't bother me,
but when I log in, I would like it to automatically run startx and
boot into KDE. How can I set this up? I.e., what script does
the console login automatically runs?

Also, is there any other way to get GUI login?

Thank for the help so far.

Sheng-Chieh
0

#10 User is offline   Ixthusdan 

  • Platinum
  • Group: Platinum
  • Posts: 9,042
  • Joined: 17-September 02

Posted 18 April 2007 - 11:17 PM

That is very curious. I expected it to give an error!
OK. Go into Configure Your Computer (MCC) and go to Boot. Select "Enable auto login...." Choose to boot graphic, but not auto login. Save and close. Reboot. See if it boots correctly.
The people never give up their liberties but under some delusion. Edmund Burke, 1784
0

#11 User is offline   shengchieh 

  • casual
  • Group: Members
  • Posts: 65
  • Joined: 07-October 06

Posted 19 April 2007 - 12:27 AM

I changed to auto login. Now no login screen (like before)
after the "FREE" screen. I ended up going back to /etc/inittab
in failsafe mode and change 5 to 3 again.

There may be an error when typing startx. The trouble is
KDE kicks too quickly and I can't see what the messages are.
I even tried

startx > startx.txt

but all the messages still come the screen and then console screen disappears quickly as KDE kicks in.

Another problem: I can't shutdown. If I choose to

*
-> logout

the only choice is to "end current session". If I choose that,
the screen goes blank, i.e., I suspect the login screen tries to
come, but the screen goes blank instead.

Sheng-Chieh
0

#12 User is offline   Ixthusdan 

  • Platinum
  • Group: Platinum
  • Posts: 9,042
  • Joined: 17-September 02

Posted 19 April 2007 - 03:05 AM

You can shut down by typing "halt" in a console. You can also shut x down if you launched from a command line session by hitting ctrl-alt-bkspc.

Let's check the xorg.conf file.
Boot up, login, su to root, type "mc" and navigate to /etc/X11/xorg.conf
Toward the bottom of this file, which video driver is being used?
The people never give up their liberties but under some delusion. Edmund Burke, 1784
0

#13 User is offline   shengchieh 

  • casual
  • Group: Members
  • Posts: 65
  • Joined: 07-October 06

Posted 19 April 2007 - 02:40 PM

I'm out this early am. Back later this PST am.

Sheng-Chieh
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users