Jump to content

Drake tools - Backup


Recommended Posts

I am trying to create a backup of my system, Spring 2009.1. I ran the Backup utility from MCC. It ran for about two hours, and created the files on my HD to backup. I tried to configure the utility to backup to my DVD drive. The backup failed, with a message saying 'no media found' ( words to that effect).


On closer inspection, on Advanced configuration, there is a drop down box to select the correct device. Mine only lists /dev/sg0. This is my HD not my DVD drive. The DVD drive is sr0. I ran these commands to show....


wodim dev=/dev/sg0 -atip
Device type	: Disk
Version 	: 5
Response Format: 2
Capabilities :
Vendor_info	: 'ATA 	'
Identification : 'WDC WD1600AAJS-0'
Revision 	: '05.0'
Device seems to be: Generic CCS Disk.
wodim: Sorry, no supported CD/DVD-Recorder found on this target.

[cliff@Duelie:~]$ wodim dev=/dev/sr0 -atip
Device type	: Removable CD-ROM
Version 	: 5
Response Format: 2
Capabilities :
Vendor_info	: 'HL-DT-ST'
Identification : 'DVD-RAM GSA-H55N'
Revision 	: '1.03'
Device seems to be: Generic mmc2 DVD-R/DVD-RW.
Using generic SCSI-3/mmc DVD-R(W) driver (mmc_mdvd).
Supported modes: PACKET SAO


If I click the drop down box, I can not select sr0, only /dev/sg0 appears, so the write to DVD never starts. Is there some other configuration I can do to allow writing to my DVD drive?

Link to comment
Share on other sites

I edited the /etc/drakxtools/drakbackup/drakbackup.conf file, and changed the following :




I still can not backup to a DVD.


This is the error reported...


Error: Does not appear to be recordable media!


To verify the drive is good, and the media I have works, I downloaded mandriva-linux-free-2010.0-x86_64.iso , ran a md5sum on the file, and burned it to a DVD+r. I can boot the DVD without problems.

So, I'm as sure as I can be this is not a DVD hardware, or media problem.

Link to comment
Share on other sites

I gave up trying to get the backup function in MCC to work. I spent some time an learned what I needed to know about tar.


I tared the directories I needed to preserve, and used K3B to write the files out to DVD's. BTSOM why the backup utility does not work on my system.


Next, I'm going to upgrade to 2010.

Link to comment
Share on other sites

I have upgraded the system to 2010. Most things are working without problems. Drakbackup was not installed during the upgrade. I had to use urpmi to install it. I went through the configuration, and for reasons I can not explain, drakbackup configuration wizard still thinks my DVD drive is /dev/sg0. That is my harddrive. My DVD drive is /dev/sr0. I edited the configuration file and corrected the error. I will test it to see if it can backup my system.


Side note, Pulse Audio does not work on my Nvidia sound hardware. If I enable it, I get very scratchy sound for a few seconds, and sound stops. Disable Pulse, and sound works again.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...