Jump to content

Mandriva Free 2010 fails to install on X41 tablet

Guest JeromeT

Recommended Posts

Guest JeromeT

I have an IBM x41 tablet, set on the docking station to use the DVD drive.

Mandriva ONE 2010 (live) works great, both GNOME and KDE.

Trying to install Mandriva 2010 Free down not work at all....


Well it goes through the what looks to be normal startup.

start the installation and it gets to the loading program into memory part and then it dumps to the below...


proceeding, please wait...

exited abnormally :-( -- received signal 7

sending termination signals...done

sending kill signals...done

unmounting filesystems...




you may safely reboot or halt your system..


ALT F3 get me more info...


* have to insmod sqlzma

* warning: unable to get module filename for sqlzma

* needs sqlzma

* error reading sqlzma: No such file or directory

* warning, insmod failed (sqlzma (null)) (-1)

* have to insmod squashfs_lzma

* warning: unable to get module filename for squashfs_lzma

* needs squashfs_lzma

* error reading squashfs_lzma: No such file or directory

* warning, insmod failed (squashfs_lzma (null)) (-1)

* have to insmod squashfs

* needs /lib/modules/

* succeeded squashfs



here I notice that there are some files missing from /lib/modules/






or the entire /dkms-binary folder.


yet I can get the mandriva one kde or gnome to work just fine from the same device, Live does not seem to be missing any of these files...


can anyone help...

Link to comment
Share on other sites

You can do some diags here from the LiveCD. If you boot it, and I hope it'll work this way, then do something like this:


find / -name squashfs*


when you find the exact path, then do:


rpm -qf /lib/modules/x.x.x.x-desktopx.x.x.x/squashfs_lzma.ko.gz


or whatever the name of the file is from the above command, you can then see if you have some missing packages. Maybe you need to install the squashfs packages or dkms_squashfs or something similar that might exist on the LiveCD, just not installed by default from the Mandriva Free. It might even be squashfs-kernel - find some packages like this:


urpmf --name squashfs


and see what list is returned, and you can choose to install the one that matches your kernel. Repeat if you find any more missing modules after installing squashfs.

Link to comment
Share on other sites

Guest JeromeT

Thank you for your response,


I tried all of the stuff you suggested, but that was in Mandriva ONE 2010.. I am not having any problems installing Mandriva ONE 2010. I am having problems installing Mandriva Free 2010...


I did your suggestions in "ONE" then took the driver files I needed and put them on a usb drive, The install for Free allows you to install thirdparty drivers before install, Squashfs-lzma fails to install, sqlzma installed fine. So I am still at square one......


I notices a few more things happening after "squashfs-lzma" fail...remember "squashfs" loads...


mounting /dev/loop0 on /tmp/stage2 as type squashfs

lomount succeeded for /tmp/mdkinst.sqfs on /tmp/stage2

it says its creating a bunch of symlinks on /tmp/stage2


killed shell

stage1: disconecting life support systems.


I then click ALT F4 and see te below repeated covering the screen.

<3>SQUASHFS error: unable to read data cache entry [2473d7]

<3>SQUASHFS error: unable to read page, block 2473d7, size e485


this works fine on my pc, just not my laptop...


Thanks again...

Edited by JeromeT
Link to comment
Share on other sites

Guest JeromeT

Well , I think its time to put on my Stupid sticker.


I started reading some other post like "can't load 2010 install dvd [solved" and other info about 2009 and found one thing in common.....

"How you burn the DVD",

Come to find out, I originally burned the first 2 disk from Opensuse 11.1 on the same tablet I am trying to install 2010 on,using the same docking station. those failed repeatedly, then I tried on my windows pc, come to find out that dvd burner is a DVD-R and i have +R dvd's (i actually got failures trying to burn these)... So I have a second x41 table with windows XP on it, I used IBM's record now to burn the ISO and it works fine now.


seems that Squash had nothing to do with the error I was getting.


Some where in some post they need to just come out and say,


SIGNAL 7 error means ,cannot read Disk, corrupt or unreadable data on disk,


Then I would not have spent 3 days trying to figure out why I cannot install this.

So I dawn my dunce cap and put on my sticker, and thank ianw1974 for responding in effort to help.

hopefully the nest guy will search and read this post and see the bold answer above..


Thanks again

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...