Jump to content

Blank desktop in 2010 / Gnome [solved]


Recommended Posts

I upgraded from 2009.1 to 2010 today...love the new splash screen and throbber!


BUT although the login screen appears OK, trying to log in (either as myself or the auto-generated guest) results in a blank desktop, with only the background image showing (if it's any help, I don't think gnome-panel loaded...or at least, its splash screen didn't appear).


On a hunch, I installed xfce, and have got a fully functional desktop that way, but any hints / tips / suggestions to get GNOME functional would be appreciated :)

Link to comment
Share on other sites

Probably nautilus is either not drawing the icons on the desktop, or that the icons have been turned off. You can run gconf-editor (if not installed, install it), and then you can go into:


apps --> nautilus --> preferences


and enable show_desktop


or check under:


apps --> nautilus --> desktop


and see if the whatever_icon_visible is checked or not. Check the items you need, and you'll have your desktop back.


Another good test, is plug in a USB stick and see if the icon shows on the desktop. If so, then the show_desktop item is enabled, but you just don't see the computer, trash and home icons.

Link to comment
Share on other sites

You can run gconf-editor

apps --> nautilus --> preferences


and enable show_desktop


Hmm...that key didn't exist (! Now created) - and neither does apps / nautilus / desktop


[Later on...]


Nope. I even removed previous kernels and all the orphans depending on them, just to be on the safe side. In whatever manages to load in gnome, there are no icons, no panels, no right-click menu - about the only signs of life are the default Mandriva background and gkrellm. Oh, and it's the same regardless of whether I log on as myself or guest (which obviously doesn't have any custom configs).


Xfce works and loads very fast (well, it is the default "light" desktop environment), but it is a bit plain and I prefer gnome (well, a functional gnome, at least!) :)



So, for your viewing pleasure, three different outputs of "ps ax" (to give you a clue as to what is running, and if there's anything odd about the gnome version). All three were taken in tty6 while X was doing its thing in tty7.

Nodesk - login prompt only.

xfce - in xfce.

gnome - in gnome (or at least, what loads as gnome)





Additional unrelated issue (from before the upgrade): Where does Compiz store its preferences? I once accidentally set the opacity on the CCSM window to 0% (oops!)...




Edited by mittfh
Link to comment
Share on other sites

Maybe in later version of Gnome, things changed and the gconf stuff for nautilus isn't in the same place. I'm pretty sure this is a gnome config issue that has the desktop stuff switched off by default, but I don't have Mandy installed to be able to check and diagnose it.

Link to comment
Share on other sites

Now solved - albeit by one of the most radical methods possible.


urpme -a gnome

urpme --auto-orphans




urpmi gnome-task-minimal


Reboot - notice MCC, Compiz and Emerald are missing...


urpmi drakconf

urpmi compiz




Since I was forced to do the 2010 upgrade in two stages (ran out of room on the root partition, then had to shut down to get to work on time - so when I restarted I shifted /var into the /home partition and symlinked it back before resuming), I suspect something may have got corrupted in the upgrade. So by nuking Gnome and reinstalling it... :)

Link to comment
Share on other sites

  • 3 weeks later...



I did an upgrade last night from 2008.0 to 2010.0 and I had the same blank screen with only the desktop background. Rather frustrating. :(


I will try your path tonight to "restore" a proper desktop.


On a side note, when I ran into this problem, I switched out of X and logged in as root. Although I know it is not a good idea, I always allow Root logins into KDE (never caused any problems in 10 years!). It required changing a field in the "kdmrc" file, and after restarting X, I logged into KDE as root and had my old 2008 desktop sitting in front of me. It's odd, as if I try to log in as my regular user...nothing still.


Upgrades shouldn't be so complicated, but they always cause some headaches which is why I stayed at 2008 for so long.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...