Jump to content
Sign in to follow this  
viking777

I seem to have achieved the impossible with Vbox

Recommended Posts

I recently decided to reinstall my virtual copy of xp, the only major change I made from the previous install was the partition on which the .vdi file lives and the mount point. So my setup is that I run vbox from ~/.VirtualBox as is usual, but the virtual hard drive is on /dev/sda12 which is mounted as /mnt/windowsvm or not - this is where the confusion lies. As I run vbox from a user account I have chowned both the folder /mnt/windowsvm and the vdi file itself (xp.vdi) to my username. The only difference from the way it has been running in the past is that previously I housed the old .vdi file on /media not /mnt. The old vdi file and containing folder have been deleted, so cannot be influencing things in any way.

 

At this stage I should tell you that the installation runs perfectly, there is no fault whatsoever with the way the virtual copy of xp runs and there is no fault with the way the computer runs, but something impossible is happening.

 

If I use fstab to mount /dev/sda12 as /mnt/windowsvm then start virtualbox, it immediately says that the drive is inaccessible. If I comment out the mount command in fstab so that /dev/sda12 is unmounted, then virtualbox runs perfectly!! Now that is impossible, but that is what appears to be happening.

 

I can confirm with both the 'mount' command and 'gparted' that /dev/sda12 is unmounted and yet the virtual hard drive that lives on that partition works normally. If /dev/sda12 is mounted (again confirmed by 'mount') the vdi it contains is inaccessible. WIHIH!

 

I don't want to overload this post with too much information at this stage, let me know if you want more, but I will include the fstab entry here - you will notice it is commented out - that is the only way vbox will work????

 

#LABEL=windowsvm /mnt/windowsvm ext3 relatime,rw,user 0 0

 

I should also add that /dev/sda12 is a freshly formatted ext3 partition that has been error checked twice now with no errors reported. Also I am not running xp from a 'saved state' or a 'snapshot' in my home folder, only from the 'unmounted' vdi file itself.

 

EDIT. I did change virtualbox versions recently as well (v3.0.4) is this new version capable of mounting linux folders by itself? It would certainly know where the vdi file is located as that information is in the ~/.VirtualBox/VirtualBox.xml file. Having said that, I just started xp in virtualbox and then ran 'mount' in linux - there is no sign of /dev/sda12 being mounted.

Edited by viking777

Share this post


Link to post
Share on other sites

Eventually solved by deleting xp.vdi then booting into partition magic and deleting it a second time!!

No explanation as to why this happened or why every tool on my computer (except partition magic) could only see 1 copy.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...