Jump to content
Sign in to follow this  
penguin12

Need help getting psX playstation 1 emu to work

Recommended Posts

Hello

 

I wasn't sure whether to post this in the Software, Games or Emulators subforum, so I decided to post this in the Software subforum.

 

I have a Playstation 1 and I also have a legal copy of the Playstation 1 game I want to play with the pSX emulator.

 

My computer has Mandriva 2009 Spring One withj KDE 4.2.

 

My computer has 1 GB RAM, a 200 GB hard drive and an ATI Radeon 9200 PRO graphics card.

 

I am trying to get the Playstation 1 emulator psX to work.

 

I previously had gotten psX to work fine on Mandriva 2009 and Ubuntu 8.04.

 

I downloaded the compressed file containing the latest version of psX from its official website, and then uncompressed the compressed.

 

The compressed file contains the psX binary for running the psX emulator, and a readme text file with instructions on getting psX to work and how to use it, and a folder named BIOS for putting a Playstation 1 BIOS file.

 

I followed all the instructions in the readme file, including putting a Playstation 1 BIOS file (SCPH1001.bin) in the BIOS folder, and installing all the required Linux dependencies.

 

After that, I made sure the psX binary was executable and then I ran it.

 

After running it, it asks me where the Playstation 1 BIOS file is,

 

I select the PS 1 BIOS file (called SCPH1001.bin) in the BIOS folder, and then a faint window appears and then disappears.

 

I don't know why the psX emulator isn't working.

 

Please help me get it working.

 

 

[moved from Software by spinynorman - welcome aboard :)]

Share this post


Link to post
Share on other sites

Open Terminal and run the command to launch pSX to provide you with more information on the fault. For me this is:

 

[lardy@spring2009 ~]$ /usr/lib/pSX/pSX

[src/linux/sound.cpp, line 215]: 'snd_pcm_hw_params_set_access(pcm_handle,hwparams,SND_PCM_ACCESS_MMAP_INTERLE

AVED)' returned 'Invalid argument'

 

The solution is to disable Pulseaudio. See pSX forum thread: http://psxemulator.proboards.com/index.cgi...amp;thread=2985

Share this post


Link to post
Share on other sites

Hello

 

Thank you Lardy

 

I disabled pulseAudio from Mandriva Control Center, and now pSX works.

 

 

However, the menus flicker and don't display properly unless I drag pSX to the bottom of the desktop.

 

This happens both with Compiz Fusion turned off and turned on.

 

Is there any way to fix this?

Share this post


Link to post
Share on other sites

No, I haven't found a solution for that.

 

Once I have managed to configure pSX, via the flickering menu, I have created individual launchers to launch my games in full-screen so I avoid it. Right-click an empty space on your desktop and select Create Launcher and use the following string in the Command field.

 

/usr/lib/pSX/pSX -f /games/psx_images/VAGRANT_STORY.mdf

 

For all the switches available:

 

[lardy@spring2009 ~]$ /usr/lib/pSX/pSX -h

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...