Jump to content

Help with lilo!!

Guest xospecialk

Recommended Posts

Guest xospecialk

i was trying to change the default boot in my mandrake config, and when i rebooted, i got a whole buncha garbage. i tried the rescue thing on cd1 of the mandrake install and tried to reinstall the bootloader and i got an error. so i went ahead and redid the mbr for windows, so at least i have half my system up...but i rreally need my linux back. any ideas on how to get my lilo back up and running?


you can refer to the posts here for things i've already tried



Link to comment
Share on other sites


Take the cd 1, make an "update" , NOT "update packages".

Though your not activating any additional packages, you'll soon be in the bootloader-config screen, voilà.


HARD way for trial and error:

Take the rescue mode, find out, how to get lilo done again.

From the rescue cd, i think, you will have to "chroot" in your root-partition, for getting lilo working correctly.

Link to comment
Share on other sites

Well you probably mucked up your lilo.conf file. If you can replace it with the original and then install it with the lilo command it would fix it.


here's my lilo.conf file..

















append="devfs=mount hdd=ide-scsi"







It pays to backup important files before making changes. As you found out, changing lilo.conf incorrectly can prevent you from getting into linux. If you had a backup then you could restore. Not harrassing you, just pointing it out as a valuable lesson :)

Link to comment
Share on other sites

....and lilo is more known, more documented and more "specialized" with patches for every need ("graphical" boot up, Animations, etc...)


No, i don't want to flame, but every loader has pre's and con's, so it's just like kde or gnome......


I think, someone not familiar to linux should take lilo, because everyone knows it well (if good or not).

If you don't like graphical things, or are a console-purist, then grub will be the choice, because it is a little bit faster in boot up and more "verbose", if you want.

Link to comment
Share on other sites

makra, I was in a hurry when I responded earlier, and just wanted to let you know that if you want grub instead of lilo you can go>mcc (Mandrake Control Center)>Boot>Boot Config, and choose grub. If you have probs with mcc doing it correctly, you can do it in console, or terminal with

lilo -U (to uninstall lilo)



cd /boot/grub

./install.sh ( to put grub in the mbr)


and lilo is more known, more documented
More known to whom? Linux users? Well, it is the li-nux lo-ader. Which also explains it's need for more docs/help...it's for linux...hence the reason so many are given the "li" screen and can't find their win partitions, and have to search for help. There's a reason that Grub is the Red Hat default loader. It's "specially" designed to handle all OS's, hence the u for unified. GRand Unified Bootloader. And you can change the colors, though basic.


I think, someone not familiar to linux should take lilo, because everyone knows it well
Everyone knows it so well for the same reasons mentioned above. I, and countless others, never had to do a rescue until lilo. Is this good for someone not familiar with linux? Yeah, really shows linux stability. In fact, a user at MUB the other day said he was going to wait and install ML when he got another computer, because of all the horror stories he has read.


No, i don't want to flame
Me either! But, I must state the obvious. Search the boards for lilo, then grub. Then google for lilo, then grub, and you'll have your undeniable answer :wink: .


Oh, and I don't care what it looks like, because it works, and I only see it for 3 seconds. :)

Link to comment
Share on other sites



The lilo normally does not cause many problems.


From debian I know, that the lilo.conf says lilo what to do.


It is not enough just to edit the conf-file, you must run

the program the conf file is referred to.


This, for linux users is clear, but - who is saying this

to the newbies, like me ?


I did not know this and have changed the lilo.conf

to make another OS as default, and it caused NO EFFECT

at all.

Solution: run lilo just by typing lilo in the bash.


That was all. This is long time ago.



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...