Jump to content

Upgrade 2008.1 to 2009 Bad Sig on package [solved]


Recommended Posts

I'm trying to upgrade my main system from 2008.1 to 2009 by following the Release notes section 2.1.2.


I updated 2008.1 as instructed. I deleted the 2008 media, and then added the 2009 media via Easy-Urpmi.


I ran the command 'urpmi --auto-select --replacefiles 2>&1 | tee upgrade.log'


Urpmi has downloaded 1506/1735 files. I now have a error message.


The following package has a bad signature:

/var/cache/urpmi/rpms/libpcks11-helper1-1.05-2mdv2009.0.i586rpm: Invalid Key ID (OK(DSA/SHA1, Thur 02 OCT 2008 07:59:02 PM EDT, ID e7898ae070771ff3))


How do I fix this? I'm stuck part way through an upgrade. I have not booted the system yet. I'm entering this form the system.


I tried deleting the file, and re-running the command 'urpmi --auto --auto-select --replacefiles' but it got the same error again.



Link to comment
Share on other sites

I'm uploading the output from the command. Since I have not booted yet, lots of things are not working, I can not launch a konsole. I had to do a Ctrl + Alt + F1 to get a command line to run the command. I sent it to the attached file. output.txt


Link to comment
Share on other sites

Everything seems to be in order.


Try clearing the cache, as root in terminal:

rm -fv /var/cache/urpmi/partial/libpcks11-helper* /var/cache/urpmi/rpms/libpcks11-helper*

then try again. If it still complains about the key, choose yes to continue, the key the package is signed with is the right one.

Link to comment
Share on other sites

Here is an update. Before I booted the system, I switched to the gui and ran Update Your System from MCC. That installed another 67 packages, and appeared to run without error.


I then booted the system, and it came up with out any problems. So I'm now running 2009 :D .


I did some testing, and most things seem O.K.


Samba, printing, NSF are all fine, without any problems.


I ran Update Your System once in 2009, and another group of packages ( about 12 ) were not up to date. When I tried to update them, I got the same message about a bad Sig on the same package. I selected Yes to continue.


I then got a conflict on Ark version 3.5.9 conflicting with the packages to install. I had to remove Ark 3.5.9, then the other packages installed.


I have a problem with the Nvidia configuration. I Think I will open a new thread for that, and for now call this solved.


Thank-you for the help...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...