Jump to content

Please help with floppy


Recommended Posts

Hey all, time again to ask you all for advice!

No matter what I try to do, I cannot get my floppy to work right.

I have tried the following, not in any order:


1. Disabling supermount

2. Disabling the icon in 'configure desktop' 'behavior' then creating a new icon.

3. Changing the 'dev' name in the icon properties

4. Enabling 'user' in options

5. Enabling supermount.


And probably more, I'm dizzy from messing with it.

Now, with my 'self-created' icon, which labels it as /dev/fd0, and mounted at /mnt/floppy, when I boot up, the error message comes up saying that "/dev/fd0 is not a valid block device.


Any ideas are greatly appreciated, as usual.


Link to comment
Share on other sites

hi 83mercedes,

silly question perhaps, but have you tried inserting a floppy, right clicking the icon to "mount", then trying to read the floppy contents? if you disabled supermount, then you must mount the drive before you can read it. how did you disable supermount? by editing your fstab file? if so, it might be helpful to post the contents of your /etc/fstab file. also (i'm not at my MDK machine right now) but if memory serves me, your floppy icon should not point to /dev/fdo, but /dev/floppy instead.


Link to comment
Share on other sites

Guest GorGor



Another way is to run mcc and change the mounts points graghically.


I disable supermount and allow USER to mount, this may be want you are after?


I then have a menu or shortcut to a kde program called kdf

or kde disk free which shows your drives and floppy and cdrom, you right hand click the device and choose MOUNT to mount it.


hope this helps

Link to comment
Share on other sites

chris z, thanks, and here is fstab:


/dev/hda1 / ext2 defaults 1 1

none /dev/pts devpts mode=0620 0 0

/dev/hda6 /home ext3 defaults 1 2

/dev/scd0 /mnt/cdrom auto user,noauto,ro,exec 0 0

/dev/hdd /mnt/cdrom2 auto ro,noauto,user,exec 0 0

/dev/fd0 /mnt/floppy auto user,iocharset=iso8859-1,sync,codepage=850,umask=0 0 0

none /proc proc defaults 0 0

/dev/hda5 swap swap defaults 0 0


I changed this in mcc, under 'mount points'.

Now, I have deleted my self-made floppy icon, and gone back to the 'default' floppy icon,

the floppy does work now, but still, during boot-up, I get the error saying /dev/fd0 is not a valid block device.

(I don't think I changed that... but I could have...)

I'll try changing it to /dev/floppy like you said there.

Nope, changing it to /dev/floppy results in the same error 'not a valid block device'.


THANKS again.

Link to comment
Share on other sites

Your fstab entry for the folppy is screwed up. It should have a noauto option included otherwise the system will try and mount the floppy during boot and report an error if it can't. Here's my floppy fstab entry:


/dev/fd0 /mnt/floppy auto noauto,user,sync 0 0


Give it a try and see if it works for you.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...