Jump to content
Arup

Booting problem with mandriva [solved]

Recommended Posts

I downloaded "mandriva-linux-2008-one-KDE-cdrom-i586". I burned the CD at 4X speed. Also i checked the md5 checksum which indicates the download is o.k.

 

 

I tried Mandriva in LiveCD mode. It failed to boot.It stopped with a blank screen just after showing the message "Loading Linux kernel". I tried different options by changing resolution and also selecting noapic, acpi=off etc. without any effect.

 

Surprisingly Ubuntu booted at first try.

 

I also downloaded and tried livecd of Mint toady. Faced same problem. After the initial splash screen it shows "loading vmlinuz.." followed by "loading initrd..." and then just hangs.I've tried the compatibility mode also.

 

So which may be the problem here?

My config is :

Athlon dual core 4000

Jetway 680G motherboard (ATI 1200 series display driver)

2GB RAM

160GB PATA, 80GB SATA (divided in two NTFS partitions)

IDE DVD-RW

 

However, the Mandriva One CD and the Mint CD that I've downloaded work correctly on other computer with Intel chipsets. So, I think the problem is with my ATI display driver.Is it?

Share this post


Link to post
Share on other sites

If it's only getting to vmlinuz, I would suggest it hasn't much to do with your graphics yet since it's not in a graphical environment. I would hazard a guess that it's your PATA/SATA mix that is causing the problem.

 

You could try and disconnect the PATA drives, and then see if the system boots with only the SATA ones attached. If the PATA controller is PCI or something, then pull this out as well so that the system doesn't see the PATA controller or just simply disable it in the BIOS if it's built onto the motherboard.

Share this post


Link to post
Share on other sites

My DVD is master and IDE HDD is slave. So this morning I pulled the data cable of the HDD and tried again. But again same results.

Share this post


Link to post
Share on other sites

Did you disable one or the other controllers in the BIOS like I suggested? We have to rule out a conflict between the PATA and SATA. If disabling SATA doesn't do it, then disable PATA and enable SATA. Report back when you've tried all.

Share this post


Link to post
Share on other sites

I can't disable SATA or PATA because my windows installation is in SATA disk and my DVD writer is PATA. I need both. :unsure:

Share this post


Link to post
Share on other sites

I assume Ian ment to dissable your sata drives, and then try to boot from the live cd, if you can get in, great, if not, then the problem may be else where, but either way, when you find out if you can or can not boot off the live cd, you can renable the sata to go back into windows or access the sata drives in general...

Share this post


Link to post
Share on other sites

Yes, you might need both - but this is troubleshooting. So if you disable one and then find it works, then you know what is the source of your problem!!!

Share this post


Link to post
Share on other sites

Well the Mandriva boot problem is solved. The kernel loading was halting after a message "Clocksource tsc unstable". Used a boot parameter "Clocksource=acpi_pm" alongwith noapic, nolapic and solved the problem. :jump:

I'll install Mandriva at night.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...