Jump to content
Sign in to follow this  
Trgy

Wins server in samba [solved]

Recommended Posts

Hello everyone.

Reacently I installed Ubuntu on my server and I wanted to run wins in samba for my network. This is my config file

 

[global]

workgroup = EUROM

server string = ed

interfaces = domain.eurom

bind interfaces only = Yes

obey pam restrictions = Yes

passdb backend = tdbsam

passwd program = /usr/bin/passwd %u

passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n *passwd:*password\supdated\ssuccessfully* .

syslog = 0

log file = /var/log/samba/log.%m

max log size = 1000

name resolve order = wins bcast host

os level = 99

wins support = Yes

panic action = /usr/share/samba/panic-action %d

invalid users = root

 

[printers]

comment = All Printers

path = /var/spool/samba

create mask = 0700

printable = Yes

browseable = No

 

[print$]

comment = Printer Drivers

path = /var/lib/samba/printers

__________________

 

Problem Is that it seems wins are not working. I cant browse any computers in my workgroup. I dit configure IP adress of wins server in other computers on the network. I probably messed something up in that smb.conf, please help

Share this post


Link to post
Share on other sites

Are all machines in the same WORKGROUP?

Share this post


Link to post
Share on other sites

Yes they are. Can I somevhow check Is my ubuntu computer master browser on the network. I sett os level to 99 and read that it should beat all other computers in ellection.

Share this post


Link to post
Share on other sites

Check if this helps:

 

http://www.defcon1.org/html/Software_Artic...-1/samba-2.html

 

further down the page it gives some config for smb.conf to ensure your machine is master browser.

 

And on ubuntu, maybe this is better:

 

http://ubuntuforums.org/archive/index.php/t-598285.html

 

it shows some other config of setting OS level higher, but also the preferred master, domain master, local master properties (that the first link also shows).

Share this post


Link to post
Share on other sites

Could samba occure problems like browsing service in windovs if there is more than one network card installed (multihome)?

Share this post


Link to post
Share on other sites

I m happy to inform U that I have solved my problem today. On my network I m using some kind of intellinet server appliance, it s just a box with two hdd s in mirror and it s managed through internet explorer. So that thing somehow became master browser on my network. I don’t know how because it does not have any operating system installed. If you have a problem with master browser on your network you can use this easy gui tool to discover it. You just have to setup name of workgroup or domain and it will tell you name of the computer that is master browser for your network. The link is here http://www.dynawell.com/reskit/microsoft/win2000/browmon.zip. It works only on windows machines. So I just put that server appliance in other workgroup and restarted my ubuntu pc and that s it. Browsing is working just fine. Now I can try to setup my domain :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...