Jump to content

Mandriva 2008 - post-install questions


Recommended Posts

Instead of sticking some questions onto other users 2008 threads, I'll start a new one.


Got a new 2008 powerpack install, so far I really like it. I have not done much with it yet, but here's a few items:


1. I tried the Software Management... nice, seems almost identical to Synaptic that I use on my debian machine. I tried selecting a few games to install, including Quake II. Some were added to the Games menu, some weren't. Also Quake II does not work...it starts then nothing ever happens. I know there is a Menu Edit feature to add stuff. What about Quake II not doing anything? Also, I installed a game called D2X-XL, and it opens a window on my desktop, but it is just a blank window, and the window (the game) can't be closed. Where is xkill, or force quit that I use to use in other distros?


2. The task bar at the bottom is kind of congested. since I don't use multiple desktops (yet), I changed from 4 to only 2. Also, I did NOT want "Beagle" during install, but it seems I have it anyway. I don't like these cataloging/searching background things. To get rid of it do I just go into Software Management and mark it for removal?


3. Is Cedega installed automatically, or do you have to do something to get it? Do I need it? Is wine just as good? Where's a good spot to learn about wine, since I've never tried it?


4. I tried the Lock The Session button on the lower right of the Taskbar. It froze my desktop, and I wasn't allowed to do anything. It left the windows I already had open, open. No privacy there. My debian machine, when you click Lock desktop, it blanks out the screen and goes to the log on window for you to later Unlock. Mandriva never allowed me to do anything anymore. What is the Lock The Desktop button supposed to do? I had to do a restart just to get my desktop back.


5. As mentioned in my Mandriva Install thread, after install I only had a partial screen. I had to go into Console and run mcc and change Display from 1280 x 768 to 1280 x 960 to get my full screen. However, every time I shutdown and then reboot, I get the partial screen again, and have to change the resolution all over again. How do I get mandriva to keep my resolution setting?


That's it for now, I'll have more question as I try more things.

Edited by null
Link to comment
Share on other sites

I think the quake II will install only the engine, you might need an original quake II cd from where you get the data files (while the Quake engine is opensourced, the game artwork is still protected by copyrights, and therefore I doubt that these will be included), you might start quake from a terminal and see what it shows (terminal messages).


the problem with d2x might be the same as with quake (just the engine), isn't this descent ???


for editing the menu you can use alacarte in gnome or kmenuedit in kde, maybe you need to install them.


Windows on your desktop can normally be killed by klicking the x in the upper right corner, maybe you have to try more than once, you will then be asked if you want to shutdown the application.


xkill mght be still in the contrib-repository, but it is not always the best idea, to use it, it kills the window, but the application may still run in the background.


yes you can remove beagle in exactly that way.


don't know about cedega and wine, I just don't use win-applications within linux ;)


the usb-feature is part of kde, it is not mandriva-specific, in gnome your usb-stick will be mounted and automatically opened in nautilus.


the screen-lock works without problems for me, maybe you have deactivated your screensaver ?


don't know about the resolution issue, have you tried to edit xorg.conf manually and insert the needed resolutions ?


what graphics-card and type of display do you use ?


saw your other questions already :D


seems that KDE tries to make live easier for users switching from windows ;)


best way to stop misbehaving applications is through gnome-system-monitor or its kde equivalent (don't know the exact english name, might be ksysguard ?), there you should search for the proccess and stop it, on the command line you can use top to find the process and then kill it

Edited by lavaeolus
Link to comment
Share on other sites

thanks lavaeolus! I guess I edited my post while you were answering my original post. You are right on the usb handling difference. I use gnome on my debian machine. I didn't know it was a gnome/kde difference with the usb handling. No problem, both ways are fine.


regarding the D2X game that could not be killed. Yes, I clicked the X on the window. No go. I also right-clicked the DX2 in the taskbar and said Close. No go. I tried all the normal ways to close it, none worked. So you may be right with what you said about quake.


lavaelous - I added Questions 4 and 5 after you answered. They are "worse" problems than the minor ones at first.

Edited by null
Link to comment
Share on other sites

sorry was just editing my post, there are maybe some additional answers now in there

Edited by lavaeolus
Link to comment
Share on other sites

The Lock the Session button now works like it is supposed to. Not sure what happened the first time I tried it... it just froze my screen the way it was and I had to do a hard reboot to get back (or go into console and do a shutdown). Anyway, now it's working like its supposed to.


Another question: the New Updates icon in the lower right just updates what you already have installed, right? ie, it doesn't install anything you don't yet have...


I suppose it is similar to my debian system, which also has an "Updates are available for your system" notification icon.


What is the "Plugged in" icon telling me? (Kpowersave). I hope it's not telling my desktop is plugged in... :rolleyes:

Edited by null
Link to comment
Share on other sites

yes the updater only installs updates for already installed packages (although I must admit I don't have this Icon, but then I did a custom install from the Free DVD, so maybe this is only in the Powerpack).


slightly OT: if you want to know if there are unneeded packages (sometimes after deinstalling packages there are unneeded libraries left on your system) there is now something similar to deborphan, it is called rpmorphan


Kpowersave is mostly of interest for Notebook-users, but since newer desktop-processors can do frequency-scaling it might be of interest for you too, but yes the plugged-in makes only sense for notebooks.

Link to comment
Share on other sites

If I remove packages through Software Management, is it supposed to also remove un-needed libraries that were needed for the package I am removing?


Also, during Install, I think I clicked "KDE Desktop" for my choice. I also like gnome. I use gnome on my primary (debian) machine. Does gnome also get installed during install, or do you need to install it afterwards?

Link to comment
Share on other sites

afaik it does not remove the libraries, the ways I know are rpmorphan or rpm-find-leaves.


if I remember correctly only aptitude removes un-needed libraries, there seems to be an aptitude-for-rpm in the contrib repository, haven't tested aptitude so far (not even on debian).


in your case gnome is not installed, but you can install gnome afterwards, just select task-gnome or task-gnome-minimal (the latter will just install the basic gnome-desktop, while the former might install additional programs which you might not want), you can use the search function in rpmdrake (aka software-management) to look for the packages you like.


to select gnome and kde at installation time you need to choose custom installation


personally I prefer a leaner system, therefore I would suggest install task-gnome-minimal and then install programs you might miss


btw. found the update-thingy, it's mdkonline, I just ignored it for long since it was a payed subscription service until some time ago.

Edited by lavaeolus
Link to comment
Share on other sites

task-gnome will install all that beagle and #/mono-crap, which I don't like


hey that's nearly real-time communication :D

Edited by lavaeolus
Link to comment
Share on other sites

which ones of these do I select? dang, I can't copy & paste... :wall:










and lots of other gnome- stuff. The gnome-panel is described as core programs for gnome.


I don't see anything called "minimal".

Link to comment
Share on other sites

For the xkill, if windows are still there but the process is dead, on KDE you can also hit ctrl-alt-esc. Note that this doesn't work (for me) with KDE + Compiz-Fusion.


Does your 3d accelleration work? This could explain why the lock screen didn't work the first time; you may want to try with a blank-screen screensaver..?


For the resolution setting, we'd need your /etc/X11/xorg.conf and your /var/log/Xorg.0.log files to see what the system is doing.

Link to comment
Share on other sites

thanks, aRTee.


My 3D acceleration has worked since first install. That D2X game still just shows a blank window that refuses to be closed. I'll try the ctl-alt-esc. Since the game doesn't work, I'll probably just remove it anyway.


The resolution resetting back to the wrong setting has not happened anymore. It has been fine the last few days. Also, the lock-screen button works correctly now, although I've only tried it once after it didn't work the first time.


I like it so far. In fact, the new IDE drive I bought (80GB) to install win2k and mandriva 2008 on... now I wish I had initially given more to linux and less to windows... Win2k has 61GB and mandriva has the rest.


All my data is on a separate SATA drive in the machine. I am probably going to resize the windows partition on the IDE drive from 61GB all the way down to 20GB or so. I am not using any file compression or any funny stuff on the windows partition so there should be no problem, right. All that is on the win2k partition is win2k and some programs. Nothing to worry about losing.


Mandriva shows 61GB for windows, something like 7GB for /, and 8GB for home. Then there's 2GB or so for swap.


My SATA drive under mandriva shows "DATA" and 118GB I think. This is all my previous win2k data - mp3s, docs, videos, etc. Then there is another partition on the SATA drive which mandriva shows as "new drive". It's a blank partition (ntfs) that doesn't have anything on it yet.


I would like to experiment with wine and some win2k games. I believe you need to copy the entire game DVDs to linux first. I'll start another thread about that later.


For now, where do I go to resize the windows partition... and how do I make / and home bigger?



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...