Jump to content

Mandriva 2008 & VMWare Workstation: bad experience

Guest baer

Recommended Posts

I installed Mandriva 2008.0 PowerPack x86_64 on my Dell Inspiron 1720 notebook.

I installed VMWare Workstation VMware-workstation-6.0.1-55017.x86_64.rpm.


I used a Windows Vista virtual machine that was created on Mandriva 2007.1 which worked very well: network access and sound both ok. Although sound only worked when no other program (like Amarok e.g.) was using /dev/dsp.


Now with 2008.0 I have no network access at all and no sound at all. I always get "Failed to open sound device /dev/dsp Device or resource busy" even when no other application is using /dev/dsp.


I have setup bridged network vmnet0 with my wireless eth1, but don't get network access in the Vista guest. I have no idea what is wrong here.

I removed vmware, installed it again, ran vmware-config.pl.

This time I choose for eth0 as bridged network (iso previously eth1, my WiFi)

Plugged in the network cable.

Started the Vista virtual machine and networking was fine.

So it seems a wireless network problem.

What could block the bridged networking via eth1?


When starting the guest Vista, I get the message "The host high-resolution timer device (/dev/rtc) cannot be set up to deliver interrupts (Invalid argument). Certain versions of the Linux kernel do not support this feature. Without the device, the guest operating system can fail to keep time correctly. To avoid this problem, see http://www.vmware.com/info?id=34."

Is this a result of the tickless kernel ?

I tried the "nohz=off" kernel parameters, but VMWare Workstation is still complaining about a timer.


When I press the button "Open virtual machine", vmware closes completely and in the command window, I can read:

[bert@localhost ~]$ vmware

/usr/lib/vmware/bin/vmware: symbol lookup error: /usr/lib64/gtk-2.0/2.10.0/filesystems/libgnome-vfs.so: undefined symbol: g_get_user_special_dir

This was no problem in Mandriva 2007.1.

Workaround start vmware with virtual machine as argument.

Link to comment
Share on other sites

I installed Mandriva 2008.0 PowerPack x86_64 on my Dell Inspiron 1720 notebook.

I installed VMWare Workstation VMware-workstation-6.0.1-55017.x86_64.rpm.


There's your problem - workstation v6.0.1 does not support Mandriva 2008 as the host OS. See here for details:






I run workstation 6.0.1 on my Dell Latitude D800 laptop with Mandriva 2007.0 as the host OS and it works like a dream with both XP Pro and Vista guest instances.


VMWare are normally fairly quick to roll in support for new distros, so I'm guessing that you will probably see Mandriva 2008 on the supported list when version 6.1 is released.

Link to comment
Share on other sites

VMWare Workstation 6.0.1 does not support my Arch Linux x86 either, but it runs brilliantly. No needs for "any-any" patches over the stock 2.6.22-9 kernel (for 6.0.0 the latest any-any was mandatory).

My only issue was guest OS freezing, when the guest was Linux with SMP kernel and 2.6.22.X kernel running. However, the tip by adamw ( passing "nohz=off" to the kernel from the grub config ) is working flawlessly, up to now.

BUT, VMWare needs a LOT of fancy footwork to run properly on 64-bit hosts. I guess you already know that, and myself is avoiding using 64-bit Os in my hosts for many reasons... one of them being VMWare.

Link to comment
Share on other sites

Mandrive 2008.0 x86_64 using kernel

VMware Workstation VMware-workstation-6.0.2-59824.x86_64.rpm


when bridged networking is configured with eth0 everything OK

when configured with eth1 WiFi then no networking in guest

find below how this is fixed


Patch for wireless networking to work


raw patch:



refined patch:



what I did:

find /usr/lib/vmware/modules/source/vmnet.tar

copy it to ~/tmp directory

tar -xf vmnet.tar

rm vmnet.tar

adapt ~/tmp/vmnet-only/bridge.c following vmware-wireless.patch shown below

tar -cf vmnet.tar vmnet-only/

replace /usr/lib/vmware/modules/source/vmnet.tar with the patched one (as root)

run vmware-config.pl (as root) to compile vmnet module again.


vmware-wireless.patch looks like

diff -Naur vmnet-only/bridge.c vmnet-only-new/bridge.c

--- vmnet-only/bridge.c 2007-08-22 03:14:05.000000000 +0200

+++ vmnet-only-new/bridge.c 2007-09-30 14:34:13.000000000 +0200

@@ -32,7 +32,7 @@

#include <linux/tcp.h>

#include <net/tcp.h>



+#if defined CONFIG_NET_RADIO || defined CONFIG_WLAN_80211

# include <linux/wireless.h>


#include "vmnetInt.h"

@@ -764,7 +764,7 @@

static Bool

VNetBridgeIsDeviceWireless(struct net_device *dev) //IN: sock


-#if !defined(CONFIG_NET_RADIO)

+#if !defined CONFIG_NET_RADIO && !defined CONFIG_WLAN_80211

return FALSE;

#elif WIRELESS_EXT > 19

return dev->wireless_handlers != NULL;

Link to comment
Share on other sites

  • 4 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...