Jump to content

Installing swat with samba [solved]


Recommended Posts

I have just installed Mandriva 2007, Spring free from the DVD image. On my 2006 system I used Swat to do various anmin tasks in samba. I have done the updates after the install. I have worked out most problems, but this one I don't understand how to fix.


I set up the online mirrors with easy-urpmi. I have Main, Main-update, contrib, contrib-update plf, plf-free and updates.


I tried to install swat, from the command line here is what I get.


urpmi samba-swat-3.0.23b-7mdv2007.0.i586

The following packages can't be installed because they depend on packages

that are older than the installed ones:



I have no idea how to figure out what packages are are too new for Swat. How do I get swat installed without forcing it?

Link to comment
Share on other sites



Thank-you for your reply. You are correct, I did add the 2007, not 2007.spring repos. I have removed the 2007 and added 2007.spring. I have updated the system, that took a lot of time, but is done. I have also installed swat, and used it.


It was an easy mistake to make, Easy-urpmi defaults to 2007, not 2007.spring. Next time I'll pay more attention to avoid that type of mistake.


Problem solved.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...