Jump to content

Mandriva 2007 Duo Core acpi problems [solved]

Guest cjm

Recommended Posts


I'm running Mandrake 2007 on a Dell XPS M1210 with a T7200 Duo Core processor. I've got it running with SMP, but am having

problems with acpi.


When shutting down, rebooting or anything that runs


/sbin/service acpid stop


the system crashes giving a huge kernel backtrace. I can't display it here as it crashes the computer. The only thing I can get from the

part of the backtrace I can see is that it can;t switch off one of the processors. Any ideas?


I',m using kernel 2.6.18-rc7.1mdvsmp (comes with Mandriva 2007

Link to comment
Share on other sites

I'm currently using the standard updated kernel (kernel- with ACPI turned off and the only problem is that the computer doesn't actually power off after the very last message "system halted" - I have to press the power button on the computer. Both CPU cores are working fine.


Since reading your message I have started downloading the kernel-multimedia-desktop-smp- package to see if there is any difference.


Perhaps you could try updating your kernel?

Link to comment
Share on other sites

There's two acpi things here at play. acpi, which the kernel provides support for and involves power management and other things, and acpid which gets this information and makes it easy for desktop apps to access. You can shut down acpid, but leave kernel acpi on -- being a desktop, you probably dont need acpid anyway, it's mostly used for battery/power/lid information/actions.


Go to the mandriva control center, or "configure my computer" and find the services panel. Turn off 'acpid' or 'acpi'. Can't remember the exact name.



Link to comment
Share on other sites

OK installed the multimedia-desktop-smp kernel and no problems, both cores working, no crash on shutdown or reboot.


I just noticed that I don't have either acpi or acpid installed. In my /etc/lilo.conf I have the following line:

append="acpi=off resume=/dev/sda5 resume2=swap:/dev/sda5 splash=silent"

My system:

Motherboard: Gigabyte GA-M59SLI-S5 mobo

CPU: AMD Athlon 64 X2 Dual-Core 5200+ Socket AM2

Memory: Adata 1024MB DDRII 800 MHz (Dual Channel)

Graphics: Gigabyte GeForce 7600 GT (GV-NX76T256D-RH)

Hard Disk: Seagate Barracuda 7200.9 SATAII 400GB


You could try uninstalling acpid (and acpi if that is installed) and see if that helps.

Link to comment
Share on other sites

Glad you go it sorted and sorry we weren't able to help you.


I can't see why acpi being compiled directly into the kernel would solve the crash when acpi is turned off at shutdown/reboot - but what would I know anyway... The main thing is that you solved the problem.


I wonder whether this should be reported as a bug???



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...