Jump to content
Sign in to follow this  
ianw1974

Debian running within vmware [solved]

Recommended Posts

I've just installed Debian within a vmware session, and for some reason the X server won't start. Has anyone got it running successfully in a vmware machine?

 

It's reporting that the colour depth 24 is a problem, but I configured for colour depth 16, and it still fails with this. Says screens found, but none usable.

Share this post


Link to post
Share on other sites

Can you post the complete error message?

Share this post


Link to post
Share on other sites

Here's the xfree86 log file. I'm currently upgrading to unstable, since I think this might have xorg, and might run better, since most distros I've run in vmware have been xorg and thought it might have been this.

 

Anyway, the log file:

 

XFree86 Version 4.3.0.1 (Debian 4.3.0.dfsg.1-14sarge1 20050901212727 fjp@localhost.localdomain)
Release Date: 15 August 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.6.8-16.0508-2 i686 [ELF] 
Build Date: 02 September 2005

This version of XFree86 has been extensively modified by the Debian
Project, and is not supported by the XFree86 Project, Inc., in any
way.  Bugs should be reported to the Debian Bug Tracking System; see
<URL: http://www.debian.org/Bugs/Reporting >.

We strongly encourage the use of the "reportbug" package and command
to ensure that bug reports contain as much useful information as
possible.

Before filing a bug report, you may want to consult the Debian X FAQ:
   XHTML version: file:///usr/share/doc/xfree86-common/FAQ.xhtml
 plain text version: file:///usr/share/doc/xfree86-common/FAQ.gz

Module Loader present
OS Kernel: Linux version 2.4.27-2-386 (horms@tabatha.lab.ultramonkey.org) (gcc version 3.3.5 (Debian 1:3.3.5-13)) #1 Wed Aug 17 09:33:35 UTC 2005 
Markers: (--) probed, (**) from config file, (==) default setting,
	 (++) from command line, (!!) notice, (II) informational,
	 (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Tue Jul 25 09:34:13 2006
(==) Using config file: "/etc/X11/XF86Config-4"
(==) ServerLayout "Default Layout"
(**) |-->Screen "Default Screen" (0)
(**) |   |-->Monitor "Generic Monitor"
(**) |   |-->Device "Generic Video Card"
(**) |-->Input Device "Generic Keyboard"
(**) Option "XkbRules" "xfree86"
(**) XKB: rules: "xfree86"
(**) Option "XkbModel" "pc104"
(**) XKB: model: "pc104"
(**) Option "XkbLayout" "us"
(**) XKB: layout: "us"
(==) Keyboard: CustomKeycode disabled
(**) |-->Input Device "Configured Mouse"
(**) |-->Input Device "Generic Mouse"
(WW) The directory "/usr/lib/X11/fonts/cyrillic" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/lib/X11/fonts/CID" does not exist.
Entry deleted from font path.
(**) FontPath set to "unix/:7100,/usr/lib/X11/fonts/misc,/usr/lib/X11/fonts/100dpi/:unscaled,/usr/lib/X11/fonts/75dpi/
:unscaled,/usr/lib/X11/fonts/Type1,/usr/lib/X11/fonts/Speedo,/usr/lib/X11/fonts/100dpi,
/usr/lib/X11/fonts/75dpi"
(==) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(--) using VT number 7

(II) Open APM successful
(II) Module ABI versions:
XFree86 ANSI C Emulation: 0.2
XFree86 Video Driver: 0.6
XFree86 XInput driver : 0.4
XFree86 Server Extension : 0.2
XFree86 Font Renderer : 0.4
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.6
(II) PCI: Probing config type using method 1
(II) PCI: Config type is 1
(II) PCI: stages = 0x03, oldVal1 = 0x00000000, mode1Res1 = 0x80000000
(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 8086,7190 card 15ad,1976 rev 01 class 06,00,00 hdr 00
(II) PCI: 00:01:0: chip 8086,7191 card 0000,0000 rev 01 class 06,04,00 hdr 01
(II) PCI: 00:07:0: chip 8086,7110 card 15ad,1976 rev 08 class 06,01,00 hdr 80
(II) PCI: 00:07:1: chip 8086,7111 card 15ad,1976 rev 01 class 01,01,8a hdr 00
(II) PCI: 00:07:3: chip 8086,7113 card 15ad,1976 rev 08 class 06,80,00 hdr 80
(II) PCI: 00:0f:0: chip 15ad,0405 card 15ad,0405 rev 00 class 03,00,00 hdr 00
(II) PCI: 00:10:0: chip 1000,0030 card 0000,0000 rev 01 class 01,00,00 hdr 00
(II) PCI: 00:11:0: chip 1022,2000 card 1022,2000 rev 10 class 02,00,00 hdr 00
(II) PCI: End of PCI scan
(II) Host-to-PCI bridge:
(II) Bus 0: bridge is at (0:0:0), (0,0,1), BCTRL: 0x0008 (VGA_EN is set)
(II) Bus 0 I/O range:
[0] -1	0	0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) Bus 0 non-prefetchable memory range:
[0] -1	0	0x00000000 - 0xffffffff (0x0) MX[B]
(II) Bus 0 prefetchable memory range:
[0] -1	0	0x00000000 - 0xffffffff (0x0) MX[B]
(II) PCI-to-PCI bridge:
(II) Bus 1: bridge is at (0:1:0), (0,1,1), BCTRL: 0x0080 (VGA_EN is cleared)
(II) PCI-to-ISA bridge:
(II) Bus -1: bridge is at (0:7:0), (0,-1,-1), BCTRL: 0x0008 (VGA_EN is set)
(--) PCI:*(0:15:0) VMWare Inc unknown chipset (0x0405) rev 0, Mem @ 0xf0000000/27, 0xe8000000/23, I/O @ 0x1060/4
(II) Addressable bus resource ranges are
[0] -1	0	0x00000000 - 0xffffffff (0x0) MX[B]
[1] -1	0	0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) OS-reported resource ranges:
[0] -1	0	0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1	0	0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
[6] -1	0	0x00000000 - 0x000000ff (0x100) IX[B]
(II) PCI Memory resource overlap reduced 0xec000000 from 0xefffffff to 0xebffffff
(II) Active PCI resource ranges:
[0] -1	0	0xe8800000 - 0xe8800fff (0x1000) MX[B]
[1] -1	0	0xec000000 - 0xebffffff (0x0) MX[B]O
[2] -1	0	0xe8000000 - 0xe87fffff (0x800000) MX[B](B)
[3] -1	0	0xf0000000 - 0xf7ffffff (0x8000000) MX[B](B)
[4] -1	0	0x00001400 - 0x0000147f (0x80) IX[B]
[5] -1	0	0x00001080 - 0x000010ff (0x80) IX[B]
[6] -1	0	0x00001070 - 0x0000107f (0x10) IX[B]
[7] -1	0	0x00001060 - 0x0000106f (0x10) IX[B](B)
(II) Active PCI resource ranges after removing overlaps:
[0] -1	0	0xe8800000 - 0xe8800fff (0x1000) MX[B]
[1] -1	0	0xec000000 - 0xebffffff (0x0) MX[B]O
[2] -1	0	0xe8000000 - 0xe87fffff (0x800000) MX[B](B)
[3] -1	0	0xf0000000 - 0xf7ffffff (0x8000000) MX[B](B)
[4] -1	0	0x00001400 - 0x0000147f (0x80) IX[B]
[5] -1	0	0x00001080 - 0x000010ff (0x80) IX[B]
[6] -1	0	0x00001070 - 0x0000107f (0x10) IX[B]
[7] -1	0	0x00001060 - 0x0000106f (0x10) IX[B](B)
(II) OS-reported resource ranges after removing overlaps with PCI:
[0] -1	0	0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1	0	0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
[6] -1	0	0x00000000 - 0x000000ff (0x100) IX[B]
(II) All system resource ranges:
[0] -1	0	0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1	0	0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1	0	0xe8800000 - 0xe8800fff (0x1000) MX[B]
[6] -1	0	0xec000000 - 0xebffffff (0x0) MX[B]O
[7] -1	0	0xe8000000 - 0xe87fffff (0x800000) MX[B](B)
[8] -1	0	0xf0000000 - 0xf7ffffff (0x8000000) MX[B](B)
[9] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
[10] -1	0	0x00000000 - 0x000000ff (0x100) IX[B]
[11] -1	0	0x00001400 - 0x0000147f (0x80) IX[B]
[12] -1	0	0x00001080 - 0x000010ff (0x80) IX[B]
[13] -1	0	0x00001070 - 0x0000107f (0x10) IX[B]
[14] -1	0	0x00001060 - 0x0000106f (0x10) IX[B](B)
(II) LoadModule: "GLcore"
(II) Loading /usr/X11R6/lib/modules/extensions/libGLcore.a
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_clip.o":  No symbols found
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_norm.o":  No symbols found
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_xform.o":  No symbols found
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_vertex.o":  No symbols found
(II) Module GLcore: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.2
(II) LoadModule: "bitmap"
(II) Reloading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Loading font Bitmap
(II) LoadModule: "dbe"
(II) Loading /usr/X11R6/lib/modules/extensions/libdbe.a
(II) Module dbe: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "ddc"
(II) Loading /usr/X11R6/lib/modules/libddc.a
(II) Module ddc: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.6
(II) LoadModule: "dri"
(II) Loading /usr/X11R6/lib/modules/extensions/libdri.a
(II) Module dri: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.2
(II) Loading sub module "drm"
(II) LoadModule: "drm"
(II) Loading /usr/X11R6/lib/modules/linux/libdrm.a
(II) Module drm: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension XFree86-DRI
(II) LoadModule: "extmod"
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
(II) Module extmod: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension FontCache
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "freetype"
(II) Loading /usr/X11R6/lib/modules/fonts/libfreetype.a
(II) Module freetype: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 2.0.2
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font FreeType
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.a
(II) Module glx: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.2
(II) Loading sub module "GLcore"
(II) LoadModule: "GLcore"
(II) Reloading /usr/X11R6/lib/modules/extensions/libGLcore.a
(II) Loading extension GLX
(II) LoadModule: "int10"
(II) Loading /usr/X11R6/lib/modules/linux/libint10.a
(II) Module int10: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.6
(II) LoadModule: "record"
(II) Loading /usr/X11R6/lib/modules/extensions/librecord.a
(II) Module record: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.13.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension RECORD
(II) LoadModule: "speedo"
(II) Loading /usr/X11R6/lib/modules/fonts/libspeedo.a
Skipping "/usr/X11R6/lib/modules/fonts/libspeedo.a:spencode.o":  No symbols found
(II) Module speedo: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.1
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font Speedo
(II) LoadModule: "type1"
(II) Loading /usr/X11R6/lib/modules/fonts/libtype1.a
(II) Module type1: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.2
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font Type1
(II) Loading font CID
(II) LoadModule: "vbe"
(II) Loading /usr/X11R6/lib/modules/libvbe.a
(II) Module vbe: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.1.0
ABI class: XFree86 Video Driver, version 0.6
(II) LoadModule: "vmware"
(II) Loading /usr/X11R6/lib/modules/drivers/vmware_drv.o
(II) Module vmware: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 10.10.2
Module class: XFree86 Video Driver
ABI class: XFree86 Video Driver, version 0.6
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
Module class: XFree86 XInput Driver
ABI class: XFree86 XInput driver, version 0.4
(II) VMWARE: driver for VMware SVGA: vmware0405, vmware0710
(II) Primary Device is: PCI 00:0f:0
(--) Assigning device section with no busID to primary device
(--) Chipset vmware0405 found
(II) resource ranges after xf86ClaimFixedResources() call:
[0] 0	0	0x000b8000 - 0x000bffff (0x8000) MX[B]
[1] 0	0	0x000b0000 - 0x000b7fff (0x8000) MX[B]
[2] 0	0	0x000a0000 - 0x000affff (0x10000) MX[B]
[3] -1	0	0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[4] -1	0	0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[5] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
[6] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
[7] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
[8] -1	0	0xe8800000 - 0xe8800fff (0x1000) MX[B]
[9] -1	0	0xec000000 - 0xebffffff (0x0) MX[B]O
[10] -1	0	0xe8000000 - 0xe87fffff (0x800000) MX[B](B)
[11] -1	0	0xf0000000 - 0xf7ffffff (0x8000000) MX[B](B)
[12] 0	0	0x000003c0 - 0x000003df (0x20) IX[B]
[13] 0	0	0x000003b0 - 0x000003bb (0xc) IX[B]
[14] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
[15] -1	0	0x00000000 - 0x000000ff (0x100) IX[B]
[16] -1	0	0x00001400 - 0x0000147f (0x80) IX[B]
[17] -1	0	0x00001080 - 0x000010ff (0x80) IX[B]
[18] -1	0	0x00001070 - 0x0000107f (0x10) IX[B]
[19] -1	0	0x00001060 - 0x0000106f (0x10) IX[B](B)
(II) resource ranges after probing:
[0] 0	0	0x000b8000 - 0x000bffff (0x8000) MX[B]
[1] 0	0	0x000b0000 - 0x000b7fff (0x8000) MX[B]
[2] 0	0	0x000a0000 - 0x000affff (0x10000) MX[B]
[3] -1	0	0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[4] -1	0	0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[5] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
[6] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
[7] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
[8] -1	0	0xe8800000 - 0xe8800fff (0x1000) MX[B]
[9] -1	0	0xec000000 - 0xebffffff (0x0) MX[B]O
[10] -1	0	0xe8000000 - 0xe87fffff (0x800000) MX[B](B)
[11] -1	0	0xf0000000 - 0xf7ffffff (0x8000000) MX[B](B)
[12] 0	0	0x000003c0 - 0x000003df (0x20) IX[B]
[13] 0	0	0x000003b0 - 0x000003bb (0xc) IX[B]
[14] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
[15] -1	0	0x00000000 - 0x000000ff (0x100) IX[B]
[16] -1	0	0x00001400 - 0x0000147f (0x80) IX[B]
[17] -1	0	0x00001080 - 0x000010ff (0x80) IX[B]
[18] -1	0	0x00001070 - 0x0000107f (0x10) IX[B]
[19] -1	0	0x00001060 - 0x0000106f (0x10) IX[B](B)
(II) Setting vga for screen 0.
(--) VMWARE(0): VMware SVGA regs at (0x1060, 0x1061)
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/X11R6/lib/modules/libvgahw.a
(II) Module vgahw: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.6
(--) VMWARE(0): caps:  0x000083E2
(--) VMWARE(0): depth: 16
(--) VMWARE(0): bpp:   16
(--) VMWARE(0): vram:  16777216
(--) VMWARE(0): pbase: 0xf0000000
(--) VMWARE(0): mwidt: 2360
(--) VMWARE(0): mheig: 1770
(EE) VMWARE(0): Driver can't support depth 24
(II) UnloadModule: "vmware"
(II) UnloadModule: "vgahw"
(II) Unloading /usr/X11R6/lib/modules/libvgahw.a
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to submit@bugs.debian.org.

 

It's the last part more than anything that is causing the problems, the warning aren't that serious. I've configured it using "xf86config" so many times, it's frustrating.

Share this post


Link to post
Share on other sites

Do you have a screen set up in the XFree config file? If yes, try to gradually go from 8 bit to 24 bit. But I guess that it will only get fixed if you run Xorg instead of XFree. AFAIK they do not include an SVGA driver for the VMware virtual video adapter in XFree.

Share this post


Link to post
Share on other sites

I did try the vesa and even with 8 bit still doesn't work :cry:

Share this post


Link to post
Share on other sites
I did try the vesa and even with 8 bit still doesn't work :cry:

If that's relevant, IIRC when running Linux under vmware, vmware tools must be installed before you configure X.

Share this post


Link to post
Share on other sites

I'll give it a go, but never needed it on any other distro in vmware. Will report back.

Share this post


Link to post
Share on other sites

OK, upgrade to unstable finished, and I now have xorg instead of xfree86. I can now get a gui perfectly fine. Am in Gnome 2.14 :P

 

However, can't install vmware tools, but then these aren't really needed too much. The only prob is I can't use xorgcfg or any command line tool to reconfigure xorg. Guess I gotta edit manually.

Share this post


Link to post
Share on other sites

Yep, all OK now. Now got 1024x768, so that's cool.

 

Seems that xfree86 was the problem, and using unstable and doing the:

 

apt-get update
apt-get dist-upgrade

 

did the trick ;)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...