Jump to content

Gentoo Emerges [solved]

Recommended Posts

I'm wondering if it's possible to pass parameters to emerge, so that you can choose your own installation parameters.


For example, let's say I want to install bind to /usr/local/bind. The normal command when using the source is:


./configure --prefix=/usr/local/bind


What I'd prefer, is to use emerge for by builds, because it then makes the init scripts easier for adding to startup using:


rc-update add named default


because I've compiled from source, this script doesn't exist, so therefore, I need to create one. If I used the emerge, I wouldn't have to, thus making my life easier.


The reason I've asked is because I'm following a HOWTO guide on Postfix with MYSQL, and it only mentions Slackware/Debian distros for creating the startup commands.


Using emerge would be the way forward, since it compiles anyway. But how would I pass my chosen parameters?

Link to comment
Share on other sites

I reckon you're doing the right thing to achieve your aim but...


Is it really worth the hassle just to stick to a tutorial, to the letter?


Some people like to put their software on a separate /usr/local partition to save it in case of filesystem corruption, but when it's built against software elsewhere, in the gentoo way, and other software may depend on it, it's seems like storing up problems for yourself.


Let us know how well it works anyway :D

Link to comment
Share on other sites

Well, I installed it all as per the emerges, I didn't change anything :P


It all seemed to go OK, had to find the various config files etc, etc, etc. I then was updating the system, and I think I may have caused a problem, but will find out tomorrow. I'll explan briefly.


First I did:


emerge --update world


then I decided to:


emerge --update --deep world


and then I read lines about clearing old apps or dependencies not required, so:


emerge --update --deep --newuse world
emerge --depclean


the problem was, I was getting an error on the revdep-rebuild, because of something to do with an x11-lib/something or other that wouldn't let me fix the cyrus-sasl, courier-authlib, postfix, libwww and another app related to my install. I tried to remove this x11-lib/filename but it said it wasn't installed, and I couldn't install it either, because it didn't exist in portage. Not sure what happened.


Anyway, I removed each of my apps individually, and then emerged them back in, so find out tomorrow when I try the revdep-rebuild again to see if there is a problem.


If not, I think what I'll do is build clean again, do the updates first, and then go for sorting out my software after that! :P


Oh, my desktop is OK though, I configured X and KDE today, so happy with that working!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...